HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Nov 19, 2012, 06:01 PM
Registered User
The Netherlands, NH, Amsterdam
Joined Mar 2008
136 Posts
Quote:
Originally Posted by jabu32 View Post
it is mounted underneath the board. x axis is pointed in the same direction as if it was mounted on top but the y (and z?) is backwards. i think i got it working correctly by comparing the stuff capt wrote above. i had to reverse y and z i believe. i had to reverse the x axis on the ACC also which seemed odd.

how do i check the boxes to make it stunt mode for pos 1 and ACC+MAG+BAR for pos 2?
Check my post here about my thoughts on sensor direction, as WhiteTurbo had a similar problem (although for him the software changed, not the hardware ).

Sometimes it's tricky to tick the boxes in the GUI, might be due to Java implementation/limitation on certain PC platforms (you might want to try MultiWiiWinGUI).

For me it works to click the top-right corner of the checkbox in the supplied GUI. Click Save after you're done and check in GUI if sensors become active (green) when flicking the switch on TX. Don't forget to calibrate ACC (keep copter as level as possible, wait till LED stops blinking) and MAG (click button and rotate copter 360 degrees on all 3 axes within 30 seconds)
shufflez is offline Find More Posts by shufflez
Reply With Quote
Sign up now
to remove ads between posts
Old Nov 19, 2012, 07:55 PM
Suspended Account
Joined Jun 2012
988 Posts
Quote:
Originally Posted by jbalat View Post
Can anyone walk me through headfree. Im using the latest dev.
I have the gear switch turning on BARO, MAG, ACC and HEADFREE at the same time

I take off with the switch on and its pretty stable but when I push the stick forward the quad just moves forward and not away from me. All controls just work as normal like headfree is not enabled.

Are they any tricks or anything I need to enable before I flash ?
try without mag enabled

mag acts like you point north you stay pointing north till you move the sticks i,e if you turn the flying quad by hand it will return to the heading defined by stick input

headfree acts like a compass defined by the sticks so no matter which way quad is facing front back left and right are the same

looking at the above it would appear having both on at once is the same as having two dogs on one stick if settings are equal both ways they will cancel each other out? but if headfree were 60% and mag 40% you might get a very weak headfree mode?
neobot is offline Find More Posts by neobot
Reply With Quote  (Disabled)
Old Nov 20, 2012, 12:48 AM
Registered User
Joined Feb 2012
59 Posts
Quote:
Originally Posted by dopplet View Post
Very cool, what are you using to drive the brushed motors on the circuit board?

Andrew
I just used bad brushless ESC's N-channel FET.
It is marked f8880.
jangkihoon is offline Find More Posts by jangkihoon
Reply With Quote
Old Nov 20, 2012, 05:55 PM
Registered User
Joined Feb 2011
842 Posts
sorry for cross posing but you have to get one of these. It will save a lot of broken props on your full size quads until you get your skills up

Check out the v939 video here
jbalat is offline Find More Posts by jbalat
Reply With Quote
Old Nov 21, 2012, 10:40 PM
Registered User
Joined Feb 2011
842 Posts
Quote:
Originally Posted by neobot View Post
try without mag enabled

mag acts like you point north you stay pointing north till you move the sticks i,e if you turn the flying quad by hand it will return to the heading defined by stick input

headfree acts like a compass defined by the sticks so no matter which way quad is facing front back left and right are the same

looking at the above it would appear having both on at once is the same as having two dogs on one stick if settings are equal both ways they will cancel each other out? but if headfree were 60% and mag 40% you might get a very weak headfree mode?
Thanks for that I kind of thought that would be the case.. Looks like its doing something now but with all that wind around I could only try it out a couple of seconds at a time. The documentation on this feature is really hard to find, I think it could easily save you if you lost your orientation when flying out far away.
jbalat is offline Find More Posts by jbalat
Reply With Quote
Old Nov 22, 2012, 12:24 PM
"Let's put a camera on that.."
spagoziak's Avatar
Twin Cities, MN
Joined Feb 2010
1,063 Posts
MWC Survey Updated

Hi folks! It's been a long time since I've been to this thread--took a break to work on a Skywalker & Arduplane.

I just built a tiny quad and realized that the survey I built last year has grown out of date. Not any more!

If you haven't thrown in your best config yet, head over and add it. The purpose is to give others an idea of where to set their config so they can get their new toys off the ground successfully.

This is the survey:
https://docs.google.com/spreadsheet/...tKQlE6MQ#gid=0

This is the results in graphic form (some of the answers don't graph well):
https://docs.google.com/spreadsheet/...gridId=0#chart

This is the spreadsheet view of the results:
https://docs.google.com/spreadsheet/...thkey=CKDQ6O0L

If I missed something or got it wrong, please PM me and I'll fix it.

spag
spagoziak is offline Find More Posts by spagoziak
Last edited by spagoziak; Nov 23, 2012 at 08:50 AM. Reason: fixed spelling!
Reply With Quote
Old Nov 22, 2012, 01:16 PM
DiaLFonZo - UAV/Drone
Dialfonzo's Avatar
Canada, QC
Joined Oct 2007
6,850 Posts
Hi All,

Just wonder which PID settings is for the Gimbal in the GUI..

sorry for the dumb question

Eric
Dialfonzo is online now Find More Posts by Dialfonzo
RCG Plus Member
Old Nov 22, 2012, 01:24 PM
OS Sponsor
kinderkram's Avatar
Germany, NRW, Dusseldorf
Joined Jun 2010
5,303 Posts
Hi Spag,
nice to meet you again!

Great initiative on the survey - will be very useful for beginners.
I'll post my values once I find some time...
kinderkram is offline Find More Posts by kinderkram
RCG Plus Member
Reply With Quote
Old Nov 27, 2012, 02:15 AM
Registered User
Fairway's Avatar
Joined Sep 2004
10 Posts
Great board....very small

Quote:
Originally Posted by jangkihoon View Post
did you use this?? I just came across the video today.
How-To: Shrinkify Your Arduino Projects (3 min 42 sec)


If not how did you do it? Great job...

Thanks
Phil
Fairway is offline Find More Posts by Fairway
Reply With Quote
Old Nov 27, 2012, 02:17 AM
I = V/R
Tw34k's Avatar
United States, FL, Jacksonville
Joined Aug 2012
61 Posts
Pretty sure multiwii will never work on a ATtiny 45/85.
Tw34k is offline Find More Posts by Tw34k
Reply With Quote
Old Nov 27, 2012, 04:28 AM
Registered User
reinhpe's Avatar
Österreich, Niederösterr., Haschendorf
Joined Jan 2009
138 Posts
Quote:
Originally Posted by Fairway View Post
did you use this??
With only two PWM outputs you would be very limited!
reinhpe is offline Find More Posts by reinhpe
Reply With Quote
Old Nov 27, 2012, 04:31 AM
Emress
sirbow2's Avatar
United States, SD, Rapid City
Joined Nov 2011
1,936 Posts
i think someone said earlier that you need to not have MAG selected when on headfree. try that.
sirbow2 is offline Find More Posts by sirbow2
Reply With Quote
Old Nov 27, 2012, 06:37 AM
DiaLFonZo - UAV/Drone
Dialfonzo's Avatar
Canada, QC
Joined Oct 2007
6,850 Posts
Quote:
Originally Posted by sirbow2 View Post
i think someone said earlier that you need to not have MAG selected when on headfree. try that.
Exacly
HeadFree is something that use the MAG
Dialfonzo is online now Find More Posts by Dialfonzo
RCG Plus Member
Old Nov 27, 2012, 06:46 AM
Multicopter Addict
braindead4554's Avatar
Southwest Minnesota
Joined Feb 2010
718 Posts
My mag is off by 90 degrees. Should be pointing north and it shows that it is pointing east. Have recalibrated at least 10 times and always says the same thing. Using the Multiwii pro board.

Anyone know where to change that in the code? Been poking around but no dice yet
braindead4554 is offline Find More Posts by braindead4554
Reply With Quote
Old Nov 27, 2012, 06:48 AM
DiaLFonZo - UAV/Drone
Dialfonzo's Avatar
Canada, QC
Joined Oct 2007
6,850 Posts
Quote:
Originally Posted by braindead4554 View Post
My mag is off by 90 degrees. Should be pointing north and it shows that it is pointing east. Have recalibrated at least 10 times and always says the same thing. Using the Multiwii pro board.

Anyone know where to change that in the code? Been poking around but no dice yet
It's not very important where it point the north at.
What is important is that the position is repetitive and exact.

Like if you turn it 90deg it move 90deg in the GUI etc..
Dialfonzo is online now Find More Posts by Dialfonzo
RCG Plus Member