HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Aug 17, 2012, 01:21 AM
Registered User
Slovakia
Joined Nov 2010
1,221 Posts
Yes, that is why I was thinking if it's even possible to fix. When I spotted this behavior I suddenly realized the problem with auto leveling that MultiWii and Naza have when flying fast. They both do not level out fast, instead they keep flying and level out very slowly. I think that is the same problem...

I wonder if there is a gimbal controller that does not feature this effect. Naza gimbal sucks, MultiWii works well, especially 2.1 version when servo refresh rate can be set higher. But it looks like it can only be used for really easy flying... oh well.
alek3d is offline Find More Posts by alek3d
Reply With Quote
Sign up now
to remove ads between posts
Old Aug 17, 2012, 03:17 AM
SILURIA / UK
Shikra's Avatar
United Kingdom
Joined Jun 2009
2,432 Posts
Could use a second multiwii with different PIDS etc for the gimbal. Tune to how you like.

Or fly slower
Shikra is online now Find More Posts by Shikra
RCG Plus Member
Latest blog entry: MultiWii OSD - MWOSD NG
Reply With Quote
Old Aug 17, 2012, 03:52 AM
Registered User
Joined Apr 2008
356 Posts
anyone with a blackvortex board managed to get the integrated GPS to work?
Any idea about that?
GliderLover is offline Find More Posts by GliderLover
Reply With Quote
Old Aug 17, 2012, 05:23 AM
Registered User
Slovakia
Joined Nov 2010
1,221 Posts
Quote:
Originally Posted by Shikra View Post
Could use a second multiwii with different PIDS etc for the gimbal. Tune to how you like.

Or fly slower
I actually use Naza as FC and MWC as Gimbal controller because Naza flies well but gimbal control sucks.

For the MWC Gimbal there are no PID settings, just P setting for roll and pitch. Too little -> it lags, too much -> too sensitive.

I think I just have to fly slow.
alek3d is offline Find More Posts by alek3d
Reply With Quote
Old Aug 17, 2012, 08:01 AM
Registered User
Nurbs's Avatar
Stockholm, Sweden
Joined Aug 2003
316 Posts
Quote:
Originally Posted by rimshotcopter View Post
Do you have a bypass filter on the 1.2GHz Transmitter?
Quote:
Originally Posted by capt View Post
Probably interference from the FPV TX as it never happened before, the gear is so close on a copter it is a constant battle. Also possible the rx lost power momentarily and tripped the MW failsafe.
I do not have any filters yet and I only use one LiPo for everything so I know I can make some improvements there.
But I just don't understand why it didn't recover from the fail safe when I basically stood next to the copter and didn't get any more response.
It seemed like the program has crashed and needed a reboot.

Can the FPV TX cause that? Maybe through interference through the common wires?
Nurbs is online now Find More Posts by Nurbs
Reply With Quote
Old Aug 17, 2012, 08:08 AM
Registered User
rimshotcopter's Avatar
United States, CA, Los Angeles
Joined Aug 2009
11,692 Posts
Quote:
Originally Posted by Nurbs View Post
Can the FPV TX cause that? Maybe through interference through the common wires?
Well, I personally have never experienced the problem because I have not flown outside of LOS however, I have read numerous horror stories in the Video Piloting Forum Seems 1.2Ghz and 2.4Ghz don't mix very well and a bypass filter is required. This maybe why you are unable to reproduce the problem during ground testing.
rimshotcopter is offline Find More Posts by rimshotcopter
Reply With Quote
Old Aug 17, 2012, 12:16 PM
Registered User
Cumbria in the U.K
Joined Jan 2008
1,925 Posts
Quote:
Originally Posted by rimshotcopter View Post
Well, I personally have never experienced the problem because I have not flown outside of LOS however, I have read numerous horror stories in the Video Piloting Forum Seems 1.2Ghz and 2.4Ghz don't mix very well and a bypass filter is required. This maybe why you are unable to reproduce the problem during ground testing.

1.2 Ghz equipment is going to have a second harmonic at 2.4 Ghz. Perfect !
In close proximity the two systems will have problems.
sparklet is offline Find More Posts by sparklet
Reply With Quote
Old Aug 17, 2012, 01:25 PM
Registered User
man1024's Avatar
Joined Oct 2011
364 Posts
How to test MultiWii failsafe in action? I don't want to crash my lovely quad. Fly close to the ground with rope attached, LOL?
man1024 is offline Find More Posts by man1024
Reply With Quote
Old Aug 17, 2012, 02:15 PM
Registered User
rimshotcopter's Avatar
United States, CA, Los Angeles
Joined Aug 2009
11,692 Posts
Quote:
Originally Posted by man1024 View Post
How to test MultiWii failsafe in action? I don't want to crash my lovely quad. Fly close to the ground with rope attached, LOL?
What I do is remove the props, arm the copter, spin the motors at about 1/3 or less throttle, then shut the power off on the transmitter. As for auto-landing etc, that is not working to the degree that it should so I don't worry about that. My only concerns are fly-aways.
rimshotcopter is offline Find More Posts by rimshotcopter
Reply With Quote
Old Aug 18, 2012, 02:05 AM
Registered User
Joined Jan 2011
1,005 Posts
Quote:
Originally Posted by alek3d View Post
I actually use Naza as FC and MWC as Gimbal controller because Naza flies well but gimbal control sucks.

For the MWC Gimbal there are no PID settings, just P setting for roll and pitch. Too little -> it lags, too much -> too sensitive.

I think I just have to fly slow.
I'm having the same behaviour as you, with my ecilop and naze32. After some time the gimbal goes left and back after some fast flight.

I will try to use the APM gimbal feature to see if there is diference.
nicodh is offline Find More Posts by nicodh
RCG Plus Member
Old Aug 18, 2012, 05:08 AM
Registered User
Kalmar, Sweden
Joined Apr 2009
63 Posts
Need assistance from you multiwii gurus!

Please have a look in this thread about my 10DOF problem..
http://www.rcgroups.com/forums/showthread.php?t=1714221
markusb2 is offline Find More Posts by markusb2
Reply With Quote
Old Aug 20, 2012, 07:04 AM
Registered User
Joined Mar 2012
88 Posts
how to use the artificial horizon remzibi osd in multiwii 2.1
cronalex is offline Find More Posts by cronalex
Reply With Quote
Old Aug 21, 2012, 05:28 PM
RTFM // copter damaged
warthox's Avatar
Joined Aug 2009
1,726 Posts
just default settings...
no post except cuts...

mwc quad // floating (5 min 4 sec)
warthox is offline Find More Posts by warthox
Last edited by warthox; Aug 21, 2012 at 05:34 PM.
Reply With Quote
Old Aug 21, 2012, 06:02 PM
If it flies, I will crash it
mxspode's Avatar
USA, CO, Westminster
Joined Jan 2008
3,022 Posts
It was just a dead calm day out there wasn't it. Very nice as usual Markus. Nice to see another side to your flying. I always enjoy watching your clips.

Rob...
mxspode is offline Find More Posts by mxspode
Reply With Quote
Old Aug 21, 2012, 09:18 PM
Registered User
Joined Feb 2011
688 Posts
Another Awesome video. Good work !!
jbalat is offline Find More Posts by jbalat
Reply With Quote