HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Apr 24, 2010, 06:20 AM
Registered User
Joined Apr 2010
1 Posts
Question
Cessna 182 (980 mm, EPO) Art-Tech

Hi all,

I have bought an 'Art-Tech Cessna 182 Skaylane 2.4GHZ RTF V3 EPO mit Simulator BLAU' several days ago from hobbyfly.de. It was nice and it has worked properly. However, I tried to disconnect the battery from the speed controller by a small screwdriver. The connection was very-very tight. During this manipulation sparks have occured. Now the plane does not operate, only a continuous bipping from the brushless motor can be hear. The servos are pulsating. It does not referr to the radio signs. Is the problem great? What should I do?

Thanks, Tamás Karosi
karosi is offline Find More Posts by karosi
Reply With Quote
Sign up now
to remove ads between posts
Old Apr 24, 2010, 02:21 PM
WARNING: May contain spam
Xpress..'s Avatar
United States, CA, Alpine
Joined Oct 2007
20,936 Posts
Sounds like you fried something.

NEVER use a screwdriver to unplug a battery!!!!!!
Xpress.. is offline Find More Posts by Xpress..
Reply With Quote
Old Apr 25, 2010, 08:38 AM
fmw
Registered User
fmw's Avatar
Joined Jul 2009
1,955 Posts
If you shorted the battery terminals then you can discard and replace the battery. You may have to replace more than that but start with the battery.
fmw is offline Find More Posts by fmw
Reply With Quote
Old Apr 27, 2010, 02:38 PM
avt
Hell Flyer
Israel
Joined Nov 2006
1,222 Posts
If you have another battery, try it.
If the problem is not solved - look for a new ESC.
avt is offline Find More Posts by avt
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion How to install Spektrum DX6i in Art-Tech Cessna 182 V2 kahays77 Electric Plane Talk 8 May 29, 2010 03:40 PM
Discussion Art-Tech Cessna 182 Version 2 tagmann50 Parkflyers 0 Apr 09, 2010 02:38 AM
Discussion Art Tech Cessna 182 nitro conversion !!! ryank Fuel Plane Talk 8 Sep 08, 2009 02:10 PM