SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Jan 03, 2012, 10:16 AM
Me a long time ago
Flypoppa's Avatar
London N.E. UK
Joined Jan 2007
6,093 Posts
Quote:
Originally Posted by Jcome View Post
Hi guys,

I think that troubleshooting my battery problems I managed to do something weird. When I cut throttle all the way down, the motor stops spinning instantly instead of continuing spinning a little bit without power. I was wondering if anybody managed to get the beep codes for the esc that comes stock with the rtf version.

Thanks,

Juan
What you have is 'brake on'. This is helpfull as it reduces drag when in glide mode.
I don't know what ESCs you have, but some can be programmed with a card. This saves a lot of figureing out with the beeps.
Flypoppa is offline Find More Posts by Flypoppa
RCG Plus Member
Sign up now
to remove ads between posts
Old Jan 03, 2012, 10:48 AM
Registered User
United States, AZ, Tucson
Joined Dec 2011
164 Posts
Quote:
Originally Posted by Flypoppa View Post
What you have is 'brake on'. This is helpfull as it reduces drag when in glide mode.
I don't know what ESCs you have, but some can be programmed with a card. This saves a lot of figureing out with the beeps.
Thanks, that's what I suspected it was. I may want to leave it like that, then, but I have no idea what other things I might have accidentally programmed. The ESC is the one that comes with the RTF Sky Surfer from readymaderc. I cannot read any information through the black shrink wrap.
Jcome is offline Find More Posts by Jcome
Reply With Quote
Old Jan 03, 2012, 02:57 PM
Registered User
Australia, VIC, Melbourne
Joined Jan 2012
14 Posts
Hi Guys. I am new to RC flying, so any advice I can get would be greatly appreciated.

I have recently bought a Bixler RTF and I was putting it together last night. I have been through quite a few pages in ths thread (but there are so many). I have followed some of the mods on the first page (including putting another Carbon Fibre tube into the wing Spar, adding a spar to the bottom of the fuse, Extreme Packaging tape for the nose, wings and fuse). I also bought with it the recommended Turnigy Plushy 30A ESC and a couple of pros (which I need to drill out to get to fit).

So, after I had glued everything together last night (using Hot glue) I thought I would hook up the included ESC and and everything and test out and make sure everything was working. So I got everything set up and bound to the receiver no problems. All servo's appear to be working fine (all surfaces working fine), however the throttle does not appear to be working. With the throttle all the way down everything works as expected. As I start pushing up on the throttle the Aileron's start twitching and don't react as they should (go in random directions when pushing one way or the other) but the motor does not spin at all. When the battery is plugged into the ESC the ESC beeps and the prop seems to stutter a bit and then is still.
I have been able to get the throttle to work 2 or 3 times, but when it has it has been in reverse (stick fully up is no throttle, all the way down is full throttle), but the ailerons still stutter and don't work correctly.

I have tried a few configuration and programming routines I have seen online (start transmitter with stick fully up and then move it fully down to configure the range) but none seem to work or fix the stuttering.
I am hoping this is only a problem with the ESC and by putting in the Turnigy one it should fix this. Can any provide advice on this.

Also, any advice on what plugs I need to get the Turnigy to plug into the Bixler. It doesn't come with any so I do need the battery plugs and the motor plugs.

Thanks in advance guys!
msolok is offline Find More Posts by msolok
Reply With Quote
Old Jan 03, 2012, 03:21 PM
Registered User
AshtonFlyer's Avatar
United Kingdom, England, Bristol
Joined Dec 2011
628 Posts
Quote:
Originally Posted by jc2259 View Post
Duff links - they do not point to J-Power Sky Surfer.
This is the UK distributor for the JPower Sky Surfer

http://www.jperkinsdistribution.co.u...0-%20J%20Power

The site has a store locator by postcode (altho' it seems a lot of the stores don't stock the SS, they can order them)
AshtonFlyer is offline Find More Posts by AshtonFlyer
Reply With Quote
Old Jan 03, 2012, 03:26 PM
Better then Sliced Bread!
NorCalMatCat's Avatar
United States, CA, Arcata
Joined Oct 2011
2,650 Posts
Quote:
Originally Posted by msolok View Post
Hi Guys. I am new to RC flying, so any advice I can get would be greatly appreciated.

I have recently bought a Bixler RTF and I was putting it together last night. I have been through quite a few pages in ths thread (but there are so many). I have followed some of the mods on the first page (including putting another Carbon Fibre tube into the wing Spar, adding a spar to the bottom of the fuse, Extreme Packaging tape for the nose, wings and fuse). I also bought with it the recommended Turnigy Plushy 30A ESC and a couple of pros (which I need to drill out to get to fit).

So, after I had glued everything together last night (using Hot glue) I thought I would hook up the included ESC and and everything and test out and make sure everything was working. So I got everything set up and bound to the receiver no problems. All servo's appear to be working fine (all surfaces working fine), however the throttle does not appear to be working. With the throttle all the way down everything works as expected. As I start pushing up on the throttle the Aileron's start twitching and don't react as they should (go in random directions when pushing one way or the other) but the motor does not spin at all. When the battery is plugged into the ESC the ESC beeps and the prop seems to stutter a bit and then is still.
I have been able to get the throttle to work 2 or 3 times, but when it has it has been in reverse (stick fully up is no throttle, all the way down is full throttle), but the ailerons still stutter and don't work correctly.

I have tried a few configuration and programming routines I have seen online (start transmitter with stick fully up and then move it fully down to configure the range) but none seem to work or fix the stuttering.
I am hoping this is only a problem with the ESC and by putting in the Turnigy one it should fix this. Can any provide advice on this.

Also, any advice on what plugs I need to get the Turnigy to plug into the Bixler. It doesn't come with any so I do need the battery plugs and the motor plugs.

Thanks in advance guys!
Quite odd, because of the effect on control surfaces I am thinking it could be a bad ESC, otherwise your radio has some wierd program mix going on. Jittering motor control would indicate a bad connection between ESC and motor, but would not cause control surfaces to do anything.
NorCalMatCat is offline Find More Posts by NorCalMatCat
Reply With Quote
Old Jan 03, 2012, 03:29 PM
CURIOSITY Has Landed!
Fugitive_Bill's Avatar
Sydney, Australia
Joined Jul 2005
1,158 Posts
A couple of quick ideas: I would be making sure all leads are plugged in firmly (Servos/ESC/Motor) and that all batteries (TX/RX/Flight Pack) are fully charged.
Fugitive_Bill is offline Find More Posts by Fugitive_Bill
Reply With Quote
Old Jan 03, 2012, 03:49 PM
Registered User
Australia, VIC, Melbourne
Joined Jan 2012
14 Posts
Quote:
Originally Posted by NorCalMatCat View Post
Quite odd, because of the effect on control surfaces I am thinking it could be a bad ESC, otherwise your radio has some wierd program mix going on. Jittering motor control would indicate a bad connection between ESC and motor, but would not cause control surfaces to do anything.
Thanks for that. That's what I was thinking. I am just using the stock 4 channel radio system that comes with the RTF version of the plane (So just a cheap Hobbyking branded model), so not sure how programable it really is. I do have a Turnigy 9x on the way, but it is on backorder from the Aus warehouse (which is the model with the C-Tick cert which I need for use in Aus), so hopefully changing the ESC for the one I bought fixes it.

Fugitive_Bill: Thanks for the suggestions. I have checked all connections, unplugged everything, replugged it all in but still the same problems. As far as I can tell, it does not appear to be a problem with the connections. All servo's are working fine as long as throttle is down.
As for the battery, I hooked up the stock battery to the included charger last night for a good few hours, and still the same problem.
msolok is offline Find More Posts by msolok
Reply With Quote
Old Jan 03, 2012, 07:54 PM
Registered User
WombatControl's Avatar
United States, MN, Minneapolis
Joined Jul 2011
301 Posts
Quote:
Originally Posted by WAM74 View Post
Or rcfoam.com
They seem to have some decent prices - and I love the quote at the top of their page for CF rods.

"You'll want to give a worker of the week award to this inanimate carbon rod."

Brilliant!
WombatControl is offline Find More Posts by WombatControl
Reply With Quote
Old Jan 03, 2012, 09:39 PM
Registered User
United States, CA, Los Angeles
Joined Feb 2008
120 Posts
"You'll want to give a worker of the week award to this inanimate carbon rod."

But it's only doing its job.

WombatRightsAdvocate
Alpha35 is offline Find More Posts by Alpha35
Reply With Quote
Old Jan 03, 2012, 10:50 PM
Registered User
AshtonFlyer's Avatar
United Kingdom, England, Bristol
Joined Dec 2011
628 Posts
"You'll want to give a worker of the week award to this inanimate carbon rod."
AshtonFlyer is offline Find More Posts by AshtonFlyer
Reply With Quote
Old Jan 04, 2012, 04:20 AM
Registered User
United Kingdom, England, Ripon
Joined Dec 2011
309 Posts
Well its taken me nearly a week but ive finally read through most of this thread!!! Its convinced me to stick an order in for a Bixler with HK, I havnt flown for about 20 years (nitro as a kid) and wanted to have a go at flying again, its taken me a bit of reading to catch up with all this brushless stuff. So now for the confession I ordered a Art Tech cessna 182 500 class.....flew it......hated it!! Way too heavy for me to learn to fly again and has to fly a hell of a lot faster than I thought it would, so thats getting stored for a while. Really looking forward to trying the Bixler out
Simon2504 is offline Find More Posts by Simon2504
Reply With Quote
Old Jan 04, 2012, 05:07 AM
Rookie
planex's Avatar
Australia, VIC
Joined Jun 2011
1,453 Posts
Quote:
Originally Posted by msolok View Post
Hi Guys. I am new to RC flying, so any advice I can get would be greatly appreciated.

I have recently bought a Bixler RTF and I was putting it together last night. I have been through quite a few pages in ths thread (but there are so many). I have followed some of the mods on the first page (including putting another Carbon Fibre tube into the wing Spar, adding a spar to the bottom of the fuse, Extreme Packaging tape for the nose, wings and fuse). I also bought with it the recommended Turnigy Plushy 30A ESC and a couple of pros (which I need to drill out to get to fit).

So, after I had glued everything together last night (using Hot glue) I thought I would hook up the included ESC and and everything and test out and make sure everything was working. So I got everything set up and bound to the receiver no problems. All servo's appear to be working fine (all surfaces working fine), however the throttle does not appear to be working. With the throttle all the way down everything works as expected. As I start pushing up on the throttle the Aileron's start twitching and don't react as they should (go in random directions when pushing one way or the other) but the motor does not spin at all. When the battery is plugged into the ESC the ESC beeps and the prop seems to stutter a bit and then is still.
I have been able to get the throttle to work 2 or 3 times, but when it has it has been in reverse (stick fully up is no throttle, all the way down is full throttle), but the ailerons still stutter and don't work correctly.

I have tried a few configuration and programming routines I have seen online (start transmitter with stick fully up and then move it fully down to configure the range) but none seem to work or fix the stuttering.
I am hoping this is only a problem with the ESC and by putting in the Turnigy one it should fix this. Can any provide advice on this.

Also, any advice on what plugs I need to get the Turnigy to plug into the Bixler. It doesn't come with any so I do need the battery plugs and the motor plugs.

Thanks in advance guys!
I had a similar issue with the twitching you speak of but on another plane
My issue was the receiver (RX) was too close to the ESC and when the throttle was up, the receiver (RX) and the ESC were interfering
This was causing the ailerons to switch when the throttle was on
But with the throttle down there was no twitching
I moved the RX and ESC to opposite ends of the plane and the issue was gone
Also make sure the antenna on the RX is straight and not looping around or doubling back
The issue I had was also with a HK 6 channel TX and I assume that's what you are using from the RTF version

As for the throttle, the only thing I can think of is the throttle switch/throttle reverse switch on the bottom panel of the transmitter is flicked up the wrong way?
Try flicking the switch up/down whichever way is opposite to the way it is now and try again?

Flick the switch, turn the TX on then plug the battery to the plane in
Keep hands away

If it doesn't work then unplug the battery and try process again from start

Hope that helps
planex is online now Find More Posts by planex
Reply With Quote
Old Jan 04, 2012, 05:12 AM
Rookie
planex's Avatar
Australia, VIC
Joined Jun 2011
1,453 Posts
In the picture below you can see the switch panel I am referring too
Throttle being the second last panel

planex is online now Find More Posts by planex
Reply With Quote
Old Jan 04, 2012, 06:57 AM
Registered User
Australia, VIC, Melbourne
Joined Jan 2012
14 Posts
Quote:
Originally Posted by planex View Post
I had a similar issue with the twitching you speak of but on another plane
My issue was the receiver (RX) was too close to the ESC and when the throttle was up, the receiver (RX) and the ESC were interfering
This was causing the ailerons to switch when the throttle was on
But with the throttle down there was no twitching
The issue I had was also with a HK 6 channel TX and I assume that's what you are using from the RTF version

As for the throttle, the only thing I can think of is the throttle switch/throttle reverse switch on the bottom panel of the transmitter is flicked up the wrong way?
Try flicking the switch up/down whichever way is opposite to the way it is now and try again?

Flick the switch, turn the TX on then plug the battery to the plane in
Keep hands away
Thanks, I will give it a try. When I have been testing this, it has been with the RX and ESC out of the plane sitting next to each other. I will try testing them further from each other when I next have the chance (in a day or two).

Thanks for the tip on the switches. They are all set to the down / standard position at the moment, but I will try switching the throttle to reverse. I think I did try they without any results, but I shall try again!
msolok is offline Find More Posts by msolok
Reply With Quote
Old Jan 04, 2012, 07:37 AM
The figure "9" Specialist
aeronca's Avatar
A Barrier Island in New Jersey, USA
Joined Oct 2003
3,475 Posts
Quote:
Originally Posted by msolok View Post
Thanks, I will give it a try. When I have been testing this, it has been with the RX and ESC out of the plane sitting next to each other. I will try testing them further from each other when I next have the chance (in a day or two).

Thanks for the tip on the switches. They are all set to the down / standard position at the moment, but I will try switching the throttle to reverse. I think I did try they without any results, but I shall try again!
When "playing" with or changing the switch positions on the throttle control be sure you have REMOVED THE PROPELLER first!

Aeronca
aeronca is offline Find More Posts by aeronca
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
For Sale Cyber Sky Parachute (Sky Surfer) shv2sail Aircraft - Electric - Airplanes (FS/W) 6 May 28, 2013 02:14 AM
Discussion Sky Surfer nickwayne11c Electric Plane Talk 15 Nov 18, 2011 02:36 PM
Discussion Banana Hobby Sky Surfer Problems cavy92 Electric Plane Talk 56 Nov 02, 2010 02:49 AM
Question Sky Surfer LiPo mod, help... Freight Dog Power Systems 0 Aug 17, 2006 01:45 PM
Swashplate Assembly with Center Ball; is this the swash with ball mod i want? tekforce Micro Helis 4 Feb 08, 2004 05:28 PM