SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Mar 05, 2010, 06:02 PM
Registered User
phildoubleday's Avatar
Joined Mar 2009
50 Posts
Help!
Did I just smoke my RX and ESC? : GraysonHobby Customer Service

This is the first time I've done any of this and I think I screwed up.

Here is the story so far:

Was going to bind RX to TX. Plugged the ESC into Channel 3 ( 'Throttle' in the manual )

Then I plugged the battery into the ESC, heard a sizzle, and the wires in my hand got really hot, really fast. Hot enough that I can still feel where I was holding the wires.

Pulled it apart as fast as I could, (was connected for maybe 2 1/2 seconds) and started to try and figure out what went wrong.

I'm not even sure what questions I should be asking let alone any of the answers. Any help will be greatly appreciated.
phildoubleday is offline Find More Posts by phildoubleday
Last edited by phildoubleday; Apr 09, 2010 at 10:16 AM.
Reply With Quote
Sign up now
to remove ads between posts
Old Mar 05, 2010, 07:11 PM
Registered User
phildoubleday's Avatar
Joined Mar 2009
50 Posts
Ok, I've had a little more time to asses the situation. Here's what I know now:

The RX is fine. I just checked it out on an RC truck.

I bought the battery and ESC from Grayson Hobby as one of their beginner combos, and stupid me assumed they would have the polarity correct on the connectors. So I hooked up the battery to the ESC opposite of the way it should have been. So my new questions are:

Did I just fry my ESC?

Is the battery still OK?




My fingers are blistering now! I guess really hot was 2nd degree burn hot!
phildoubleday is offline Find More Posts by phildoubleday
Reply With Quote
Old Mar 05, 2010, 07:11 PM
Glenn
wellington53's Avatar
United States, WI, Oconto Falls
Joined Jan 2004
2,751 Posts
Quote:
Originally Posted by phildoubleday View Post




Then I plugged the battery into the ESC, heard a sizzle, and the wires in my hand got really hot, really fast. Hot enough that I can still feel where I was holding the wires.
It seems like the polarity was wrong to me,
Anyone else?
wellington53 is offline Find More Posts by wellington53
Reply With Quote
Old Mar 05, 2010, 07:26 PM
Registered User
Dr Kiwi's Avatar
Chattanooga, Tennessee, United States
Joined May 2003
27,199 Posts
Talk to Basil at Grayson... if indeed they reversed the connectors then he should make it right.

You may well have fried the ESC and even melted one of the battery tabs.
Dr Kiwi is offline Find More Posts by Dr Kiwi
Reply With Quote
Old Mar 05, 2010, 11:28 PM
Registered User
phildoubleday's Avatar
Joined Mar 2009
50 Posts
Thanks for responding guys. I'll be getting into contact with Grayson and post the outcome. I hope I'll have only good news to report!
phildoubleday is offline Find More Posts by phildoubleday
Reply With Quote
Old Mar 06, 2010, 08:28 AM
Registered User
Beaumont, TX
Joined Feb 2007
1,333 Posts
Check the polarity of the connectors AND wires on the battery. I received a battery where the wires were hooked up to the connector correctly, according to their colors, but were connected to the battery wrong.

Simple explanation: the red wire was wired to the negative side of the battery and the black wire was wired to the positive side of the battery.

I found out the cheap way because, luckily, I hooked the battery up to my watt meter before hooking it up to anything else. The watt meter had no display so I checked the battery with my multi meter and found out the wires were reversed at the battery. No harm, no foul, no damaged equipment.

Since I had ordered multiple batteries, it was real easy to look at all of them and see that one battery had the red and black wires going to different sides than all the others.

Just checked all my batteries and, not wanting to say this is a valid rule of thumb, all of them EXCEPT for four 450 mAh 2 cells from Gravity Hobby, have the black wire to the right and the red wire to the left when you set them on end with the power leads coming off of the battery pointing towards you.

What do you want to bet that I am going to check out the Gravity Hobby batteries BEFORE I hook them up to anything?

(Hey, 500 posts! LOL)
Pete Miller is offline Find More Posts by Pete Miller
Last edited by Pete Miller; Mar 06, 2010 at 08:43 AM.
Reply With Quote
Old Mar 06, 2010, 02:12 PM
characters welcome!
Mark Wood's Avatar
United States, CA, Bear Valley Springs
Joined Feb 2000
26,335 Posts
If the battery was mis-wired the battery and ESC are seriously compromised. Grayson owes you a new one of both if they soldered the connector on. Period.

mw
Mark Wood is offline Find More Posts by Mark Wood
Reply With Quote
Old Mar 25, 2010, 05:24 PM
Registered User
phildoubleday's Avatar
Joined Mar 2009
50 Posts
Well, Grayson has offered to replace the items which is great, but they just don't have the same sense of urgency as they do when sending out their regular orders.

USPS Tracking:
Your item was delivered at 9:02 AM on March 10, 2010 in GRAYSON, GA 30017.

I spoke with them on the phone today, and they said it should ship out either tomorrow or Saturday, but the person I spoke with made sure to emphasize that it 'should' not that it will. Oh well, what's another week.
phildoubleday is offline Find More Posts by phildoubleday
Reply With Quote
Old Mar 25, 2010, 05:33 PM
Buildin'em and flyin'em
JaggedEdge's Avatar
United States, NY, Erie
Joined Dec 2007
447 Posts
Quote:
Originally Posted by Pete Miller View Post
Check the polarity of the connectors AND wires on the battery. I received a battery where the wires were hooked up to the connector correctly, according to their colors, but were connected to the battery wrong.

Simple explanation: the red wire was wired to the negative side of the battery and the black wire was wired to the positive side of the battery.

I found out the cheap way because, luckily, I hooked the battery up to my watt meter before hooking it up to anything else. The watt meter had no display so I checked the battery with my multi meter and found out the wires were reversed at the battery. No harm, no foul, no damaged equipment.
Same thing happened on mine only I didnt realize at the time that my watt meter wasnt lit up. Plugged the pack in and popped one of the cells. Good thing it was just a $11 25c 2200.
JaggedEdge is offline Find More Posts by JaggedEdge
Reply With Quote
Old Apr 08, 2010, 05:43 PM
Registered User
phildoubleday's Avatar
Joined Mar 2009
50 Posts
Now I'm getting a little upset.

OK, this little story has gone from bad to worse! Grayson has a 2 - 3 week returns policy, so yesterday morning I'm starting to wonder where my package is. I go back to one of the many, less than a complete sentence, emails Grayson has sent to get the tracking number and find out.

Turns out the tracking number they gave me was the tracking number from the original order. Concerned, I send them and email asking for the correct tracking number, which they oblige me with by the end of the day. But after getting home from work, their package is on my doorstep. I think,"Great, it's here. And I was getting worried!"

I open the package, and all it contains is an ESC! Where is the battery? So now I'm getting a little upset. I look into the bottom of the envelope to try and find the female bullet connectors and shrink wrap,(kinda like the one's that were attached to the ESC I sent them) and find nothing. But it turns out that is not that big a deal because the motor they had sent with the same order I was getting replacements for, is also bad!

So I'm sure they are going to want me to send that back to them on my dime too, and I can just add $10+ bucks of shipping to my original order, get those female bullets I'm missing, and have a nice day. Well, maybe not this month anyway. I gathered myself as best I could and sent them this email:

Dear GraysonHobby,

Your package did arrive today, but the only thing it contained was an 18Amp ESC. The package I sent to you included both, an 18Amp ESC as well as a 'GraysonHobby 800mAh 11.1V 15C/20C' battery. Is the battery being shipped separately? Also, the ESC I sent you had the female 'gold bullet' connectors soldered on. Am I going to have to buy some more of those as well? In addition to all this, I hooked the 2208-17 to the 20 Amp ESC from my other order, and the motor just 'clicks' at me. As you can imagine, after everything: cost of extra shipping, lack of communication, emails, phone calls, incorrect tracking number ,missing battery, missing female connectors, and now a 'brand new' motor just clicking at me, I am furious! I am undoubtedly, but understandably (I'm sure plenty of people try to take advantage of your company), going to be asked to ship the motor back for a replacement. I chose the 'flight package' based on the fact that I would be saving $20 by buying the package. Adding an additional $5+ dollars for shipping, and now that savings is more than cut in half! Your company has a very good reputation, and I'm sure I am one of the few who have slipped through the cracks. I want to be understanding, but it is becoming increasingly harder to do so when your company's mistakes have been a source of irritation for over three weeks, are still not resolved, have become even more bothersome with the addition of the motor, and are costing me money! I want to be out flying my plane, not tracking down where my stuff is, composing emails, and wondering how much more grief I will endure before this is resolved.

I would like to suggest that:

1) A battery, of equal or greater value, be in the mail ( if it isn't already ) no later than 09 April 2010.
2) Upon receiving the motor for exchange, my account be credited with the actual cost of shipping on the box, not to exceed $6.

I don't find either of these requests unreasonable or unwarranted, and would just like this matter to be resolved as quickly as possible.

A prompt response will be greatly appreciated.

Sincerely,

Phillip Doubleday



As of this posting I have heard nothing from them about this. I'll let ya'll know how things end up turning out.
phildoubleday is offline Find More Posts by phildoubleday
Last edited by phildoubleday; Apr 09, 2010 at 10:17 AM.
Reply With Quote
Old Apr 09, 2010, 10:15 AM
Registered User
phildoubleday's Avatar
Joined Mar 2009
50 Posts
Fri, April 9, 2010 8:22:07 AM


"Grayson Hobby is on the road ane will be closed from April 9th - April
12All orders and emails will start to ship and on Tuesday April 13th

Thank You...

The Staff at Grayson Hobby''


My original message went out: Wed, April 7, 2010 8:46:57 PM. That gave them an entire work day to respond, but instead I receive this 'bulk message' which only serves to add to my frustration.




UPDATE:

This arrived just before noon:


Fri, April 9, 2010 11:53:09 AM

"Hello

We will take care of this for you when we return on Tuesday. We
apologize for the delay and will refund you all shipping fees and
credit you your shipping charges

Thanks

Basil"

That certainly made me feel a little better. Hopefully, everything is on it's way to being resolved.
phildoubleday is offline Find More Posts by phildoubleday
Last edited by phildoubleday; Apr 09, 2010 at 06:07 PM.
Reply With Quote
Old Apr 15, 2010, 08:41 AM
Registered User
phildoubleday's Avatar
Joined Mar 2009
50 Posts
Grayson has offered to send a replacement battery and motor, without my having to send in the motor I currently have. That fixes everything. Thank you Grayson.
phildoubleday is offline Find More Posts by phildoubleday
Reply With Quote
Old Apr 15, 2010, 02:12 PM
No, I dont work for HH ;)
Bowerz's Avatar
Southampton, Hampshire, UK
Joined Sep 2009
3,768 Posts
Dude, that story sucks but glad to hear it is sorted!

Liam
Bowerz is offline Find More Posts by Bowerz
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question Did I damage my ESC? Larry076 Power Systems 6 Mar 04, 2010 03:42 PM
Help! Did I just fry something in my ESC? neven Electric Heli Talk 5 Dec 02, 2009 05:44 PM
Question Did the motor smoke my ESC or is my ESC the culprit? Kurpal Foamies (Scratchbuilt) 13 May 15, 2008 06:26 PM
Did i just killed my ESC? zQzQ Power Systems 5 Oct 30, 2005 11:25 AM
Did i just killed my ESC? zQzQ Power Systems 0 Oct 26, 2005 09:58 AM