HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jun 20, 2001, 06:59 PM
Build'em and Crash'em
Ken Lapointe's Avatar
Narragansett, RI
Joined Oct 2000
3,123 Posts
Desperately need help with motor interference problem

I have a slightly beat up Astroflight 40G running on 20 cells that causes all kinds of interference on the radio when its running. The control servos all move all over the place. The Astroflight 204 ESC is right behind the motor, the battery is behind that. The ESC is about 12 inches from the Rx

In order to get rid of the interference I have tried each of the following and re-tested for interference:
Changed Radios (different frequency, and number of channels)
Changed speed controls
Changed capacitors
Changed Rx battery
Twisted wires on battery and ESC control wires
Ran the motor for an hour at 10 amps to see if the brushes needed to be seated more
Took the motor apart and smoothed the cummulator contacts.

None of that worked.

The radio gear works fine when there is no motor running.

The radio also works fine when the motor is running without a prop.

I even hooked the battery directly to the motor with the prop on it and then there was no problem either.

What is left to try?
Should I try some kind of diode on the motor? RF cokes on the ESC control wires ?
Would it be worth it to send it somewhere? The motor seems to be working fine other than the interference it causes.

Any help or ideas would be greatly appreciated
Thanks

Ken
Ken Lapointe is online now Find More Posts by Ken Lapointe
Reply With Quote
Sign up now
to remove ads between posts
Old Jun 20, 2001, 07:11 PM
BEC
Registered User
BEC's Avatar
Auburn, Washington USA
Joined Jan 2001
12,935 Posts
Motor timing??

Also, where is the Rx in relation to the motor battery (and what other ESC besides the 204) did you try?
BEC is offline Find More Posts by BEC
Reply With Quote
Old Jun 20, 2001, 07:23 PM
Registered User
Clayton's Avatar
Jackson Hole, Wyoming
Joined Feb 2001
574 Posts
I know this may sound too simple ,but it also may solve your problem. Have you tried wrapping your reciever in aluminum foil to shield it from the field generated by the battery? I've found that even my esc next to the reciever causes interference. Once again maybe this isn't the solution. But every time I have had interference this has solved it.
Clayton is offline Find More Posts by Clayton
Reply With Quote
Old Jun 20, 2001, 08:42 PM
Registered User
Canada, NS, Lunenburg
Joined Oct 1999
3,863 Posts
The clue might be where you say "slightly beat up".

When did you last change the brushes?

If it runs without causing interference under no load, it may be that the timing has drifted off.

I suggest you replace the brushes and retime the beast.
DaveSawers is offline Find More Posts by DaveSawers
Reply With Quote
Old Jun 20, 2001, 11:14 PM
Registered User
Folsom,Ca,USA
Joined Apr 2001
992 Posts
Fact that it works ok without prop means that noise is created by higher current which IMHO brush noise.

Something is rotten here.
I have 4 ( non beat up ) Astros and have never had any noise problems at all!
Isn't 20 cells at little too many? My Astro book shows data at 18 cells. Too high a voltage would do this! How much current is it drawing?? 30 -35 a on the ground I know is acceptable.

I suspect worn comutator / brushes.
re: Smoothing the comutator, I understand that they need to be turned on a lathe for perfect "roundness" to keep noise free brush contact.

Might be time to send it to Astro for an overhaul!

Dave
DaveW is offline Find More Posts by DaveW
Reply With Quote
Old Jun 20, 2001, 11:57 PM
Senior Member
Dallas, Texas, USA
Joined Feb 2000
363 Posts
I have had excellent results reducing interference by using a small toroid installed on the rx servo wire running from the ESC to the receiver. However, you are using an OPTO isolated ESC (the 204) and shouldn't be getting noise sent down the wires from the motor/esc to the RX. Something's definitely up here. When you replaced the capacitors, you put one from each brush to the casing and one across the power leads/brushes themselves right (three total)?

Castle Creations has info on the toroid (they are also available at electronic supply stores).

-Cash
Cash Traylor is offline Find More Posts by Cash Traylor
Reply With Quote
Old Jun 21, 2001, 04:04 PM
Build'em and Crash'em
Ken Lapointe's Avatar
Narragansett, RI
Joined Oct 2000
3,123 Posts
Guys,
To answer your questions

Motor was just retimed for 4.5 amps no load.

I have tried 2 different 204 ESC units. They aer the only ESC units I have that will handle the 20 cells.

The Rx is about 4 inches behind the motor battery

I have not tried aluminum foil, but will try it latter this afternoon

The brushes were change recently, after my last crash, which I think was caused by the motor interference.

On 20 cells it is drawing 32 Amps.

Yes 3 caps, one from each lead (.047) to case and one across the leads (0.01)

Thanks for the help guys.

Ken

Ken Lapointe is online now Find More Posts by Ken Lapointe
Reply With Quote
Old Jun 21, 2001, 04:16 PM
Registered User
rcastab's Avatar
SF Bay Area, California, USA
Joined May 2001
372 Posts
what kind if RX are you using?
rcastab is offline Find More Posts by rcastab
Reply With Quote
Old Jun 22, 2001, 06:40 AM
Build'em and Crash'em
Ken Lapointe's Avatar
Narragansett, RI
Joined Oct 2000
3,123 Posts
Aluminum foil didn't help

The Rx is a Futaba.

The motor is now in a box headed to New Creations R/C for a little tender care.

Thanks for the help guys

Ken
Ken Lapointe is online now Find More Posts by Ken Lapointe
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Need some help with a motor/ECS problem blk96gt Power Systems 20 Mar 15, 2005 06:59 PM
Need help with motor overheating! rdogg32 Electric Heli Talk 11 Jul 14, 2002 10:34 AM
I need help with motor timing. jtthebiggafigga Electric Plane Talk 3 Jun 09, 2001 11:12 PM
E.E. Lightning-pusher scale electric need help with motor/battery etc bipeflyer Scale Kit/Scratch Built 5 May 01, 2001 05:33 PM
E.E. Lightning-pusher scale electric need help with motor/battery etc bipeflyer Scale Kit/Scratch Built 0 Apr 29, 2001 05:02 AM