HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Feb 22, 2010, 03:45 PM
Registered User
Bangalore India
Joined Sep 2006
25 Posts
Help!
OSD firmware error says unknown,giving incorrect values

Using OSD(text) installed with eagle tree V2 system USB Flight Data Recorder.

I am using Recorder Firmware version 5.54 and OSD Firmware 1.15.

Problem 1:
The OSD keeps saying firmware unknown. I update firmware , it shows correct firmware and then after a while it again goes into saying firmware version unknown , all settings are lost.

Problem 2:
The USB Recoreder is showing correct values in Live Mode on PC. Its able to show all values as desired including voltage values

The OSD is unable to show voltage values instead it shows a '*' for RxV and Pkv for motor battery.

The Amp and wattage values are also incorrect in OSD , it goes to high and doesn't get updated . I have configured it correctly to show live values instead of max values.

All the parameters are correctly shown in USB Flight Data Recorder in PC mode , howerver OSD is unable to show it.


for Support Guys:

What shoud I do , go ahead and order a new OSD or is this a known problem with OSD (text version)

Please let me know I am in urgent need of solution.


Thanks
Puneet
puneetp is offline Find More Posts by puneetp
Reply With Quote
Sign up now
to remove ads between posts
Old Feb 28, 2010, 07:54 PM
Microbursts hurt.
jknust's Avatar
United States, MD, Mt Airy
Joined Jun 2005
198 Posts
Did you ever find an answer? I'm having what appears to be the same problem. I just received the ET products from Tower. I went to the ET web site to download latest software (versus using the CD). The eLogger V3 & OSD Pro both wanted firmware updates (so I did it). However, I am in an endless loop, where the OSD Pro always comes up "OSD Pro Firmware Version UNKNOWN", I do an update, and it says "Firmware successfully updated!!". I've tried powering down, restarting, etc. and it is always like this. And I get back to the "The firmware of your OSD Pro needs to be updated with the version of the Eagle Tree Windows Application you just installed. The Firmware Control utility will now run. Please click the 'Update OSD Firmware' button when prompted."

Here are a few screens of what I keep seeing.

I'm running eLogger Application version 8.30 according to the software.
jknust is online now Find More Posts by jknust
Reply With Quote
Old Mar 02, 2010, 10:56 PM
billpa's Avatar
Joined Nov 2003
4,936 Posts
Puneet, I think we got your issue resolved through the support ticket system. If not, we will.

jknust, after you click OK on the "firmware update succeeded" screen, a screen should appear that lets you configure your OSD Pro. You need to configure parameters and then click "OK" on that page. Let me know if you are seeing something different.
billpa is offline Find More Posts by billpa
Site Sponsor
Reply With Quote
Old Apr 21, 2010, 06:25 PM
Registered User
Joined Apr 2010
1 Posts
TIP: Should be in a FAQ somewhere - these linked steps should be documented - save these guys some angst

I only found this one thread on the whole of the net - maybe not such a commonly found pitfall I guess - but I instantly got the idea from billpa's one line - another support call saved.

Seeing - "OSD Pro Firmware Version UNKNOWN" - ever, though seems a bit weird and off-putting.

Even when you do it the right way, you see at one point - "OSD Pro not connected - No firmware Info Available"

But I'm all go now.

TIP: I just don't like the logic of how it worked - I like this logic (A) firmware has a version - you download the new firmware (B) you see the new version (C) but the parameters are all defaults - so you save new parameters - the old A B C works all the time.
OghamTheBold is offline Find More Posts by OghamTheBold
Reply With Quote
Old Apr 24, 2010, 06:41 PM
billpa's Avatar
Joined Nov 2003
4,936 Posts
Ogham, sorry you got caught in this issue and glad you solved it. With our recent software releases, we have eliminated the "Cancel" option with the OSD configuration page, which effectively eliminates the problem. I agree with your "ABC" comment above about the firmware version, but the OSD Pro architecture makes this problematic, believe it or not.
billpa is offline Find More Posts by billpa
Site Sponsor
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question OSD Pro, eLogger V3, GPS V4 problems updating firmware in OSD Pro jbfoamy Eagle Tree Systems 23 Jun 02, 2012 03:59 PM
Help! Castle ice 100 giving 6 beeps after flight, what error? gundamnitpete Castle Creations 16 Mar 31, 2010 07:45 AM
Help! Erratic values on standar OSD Megafluffy Eagle Tree Systems 26 Jan 01, 2010 04:49 PM
Help! Flight recorder firmware version error ? Sly1979 Eagle Tree Systems 2 Oct 30, 2009 02:00 PM
Discussion Black Stork OSD 1.5 firmware centered characters version fpvsystems FPV Talk 0 Oct 19, 2009 06:50 PM