HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jan 28, 2010, 09:57 AM
Registered User
Australia, QLD, Kallangur
Joined Nov 2005
32 Posts
Discussion
Successful Installation of XPS gear

Hi Jim,
Just thought you would like to know that last weekend I attended our annual Sailplane Expo held at Armidale NSW. This is a large major event now in its 30th year, with open Thermal duration and various other classes mainly Nostalgia Glider and Electric running within the same competition. Leading up to the event I was undecided between staying with 36meg gear or changing to 2.4gig mainly because both of the models I intended to use are both full carbon construction, and all the negative comments being made. After considering all that has been said and your comments about no need for slave receivers etc, a few weeks before the event I installed the sailplane RX in the Eraser 2000 and gave it a couple of outings, the results were so positive that I then installed another sailplane RX into the Faser with similar good results. I competed in all rounds of open thermal with the Eraser 2000 and the Faser as back up. Very pleased to report that the Xtreme Link System worked 100% no matter what part of the sky or attitude the model was in, in fact it felt more positive than when using 36meg. My transmitter was a Multiplex Royal/Evo Pro 12 with XPS module running in mode 4 ETSI and both models had the 8ch sailplane RX, 6 digital servos and 5 cell 2000mahr enerloop batteries. I inserted a short length of DuBro antenna tube which carried the rx antenna holding it clear of the fuse and wing,this you can make out in the attached pictures.
Full marks for a well made fully supported system!!!
WombatDave is offline Find More Posts by WombatDave
Last edited by WombatDave; Jan 30, 2010 at 04:29 AM. Reason: Pics not sent
Reply With Quote
Sign up now
to remove ads between posts
Old Jan 28, 2010, 06:43 PM
Registered User
twang's Avatar
Australia, QLD, King Scrub
Joined Jun 2005
1,370 Posts
You forgot the pix Dave
twang is online now Find More Posts by twang
Reply With Quote
Old Jan 28, 2010, 09:03 PM
Registered User
Brisbane Australia
Joined Mar 2003
568 Posts
Dave,
Was there any restriction placed on the number of models that could use 2.4 Ghz at the same time at Armidale?

Just as a guess. What percentage of the models would you say were on 2.4 Ghz?
Graeme Marion is offline Find More Posts by Graeme Marion
Last edited by Graeme Marion; Jan 31, 2010 at 03:01 AM.
Reply With Quote
Old Jan 30, 2010, 04:42 AM
Registered User
Australia, QLD, Kallangur
Joined Nov 2005
32 Posts
Sorry my mistake

Missing pics my fault, tried to attach which where to large.....Dumbo me.
WombatDave is offline Find More Posts by WombatDave
Reply With Quote
Old Jan 30, 2010, 04:57 AM
Registered User
Australia, QLD, Kallangur
Joined Nov 2005
32 Posts
Hi Graeme, Not sure of the total percentage, will try to have a look at the full listing in the next few days.

Dave

We placed no restriction on the use of 2.4Gig
WombatDave is offline Find More Posts by WombatDave
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Pushrod Installation For A V Tail V1VrV2 Composites Fabrication 3 Jan 19, 2010 08:33 PM
Question Retractable Gear Installation Seadog Scale Sailplanes 8 Aug 31, 2009 09:32 AM
Discussion Can someone explain this picture (XPS Rx installation) borneobear Radios 25 Mar 07, 2008 12:29 PM
Whoops! "XPS - Loss of control" - Turns out to be operator error -Follow proper installation Bunyan Xtreme Power Systems 26 Sep 28, 2007 05:16 PM
Discussion Am I correct in my XPS installation? Henrique Lang Xtreme Power Systems 9 Aug 14, 2007 02:55 PM