SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old May 06, 2010, 05:41 PM
A&P/IA
chevronflyer's Avatar
United States, FL, Middleburg
Joined Feb 2007
570 Posts
ok just finished up with the test runs.... i changed the power leads to deans plugs, ran the stock motor and battery. I recorded 175 watts of stable power at 15 amps draw on stock setup. running the numbers that equates to 87 watts per pound. (my plane came out to 1lb 12 oz plus 4 oz additional nose weight for cg so 2 lbs ready to fly)

this my friends is not enough to get off water period.... that is why you are all having so much trouble and all it does is skip around. trainers that produce a lot more lift than this plane need 70 to 80 watts per pound minimum just to fly at all. ideally you would want to see 100 to 125 watts per pound for great float plane performance.
i did some checking and you can get by with an eflite park 480 outrunner or equiv. giving around 275 watts total power for about 137 watts per pound on this plane, so that is what i am going to do next, install an eflite 480, 40 amp esc, and a 3 cell 2100mah lipo.
here are a few pics showing what area i cut out to fit my 2100 in the plane. took about 5 minutes to cut out one side of the battery tray area and slide it in with velcro to secure it to the fuse floor.

even with my 3s 2100mah all the way forward in the nose, i still have to add weight to get the cg right, its still 5mm too tail heavy so i could go with a 2500mah 3s pack even if i wanted to to make the cg fall in range and up my flight times... may as well make the extra weight work for me instead of being dead weight
chevronflyer is offline Find More Posts by chevronflyer
Reply With Quote
Sign up now
to remove ads between posts
Old May 09, 2010, 12:59 AM
Registered User
Joined Mar 2010
62 Posts
Hey Gang this is my second ICON A5 I bought this month, I put everything together just like the instructions say, all my other planes fly but these A5's everything works but the engine, am I missing something here? I have the whole plane working but the engine just keeps making all of the beeps. Is there an order in connecting the wires if so please contact me...josephconnick@yahoo.com I mean this is ridiculous please help me, Thanks Joe
connick50 is offline Find More Posts by connick50
Reply With Quote
Old May 09, 2010, 07:54 AM
A&P/IA
chevronflyer's Avatar
United States, FL, Middleburg
Joined Feb 2007
570 Posts
Quote:
Originally Posted by connick50 View Post
Hey Gang this is my second ICON A5 I bought this month, I put everything together just like the instructions say, all my other planes fly but these A5's everything works but the engine, am I missing something here? I have the whole plane working but the engine just keeps making all of the beeps. Is there an order in connecting the wires if so please contact me...josephconnick@yahoo.com I mean this is ridiculous please help me, Thanks Joe
hey connick50, mine did the same thing. rapid beeping. the esc is not seeing a low enough throttle setting to arm itself. either put your throttle trim all the way down as low as it can go or go into your settings and set the throttle travel in low stick from 100% to 150% or what ever the max percent your radio goes
chevronflyer is offline Find More Posts by chevronflyer
Reply With Quote
Old May 09, 2010, 09:36 AM
Registered User
Joined Mar 2010
62 Posts
how do I do that?
connick50 is offline Find More Posts by connick50
Reply With Quote
Old May 09, 2010, 09:58 AM
Registered User
Joined Mar 2010
62 Posts
How do I set my throttle low enugh so my plane will arm itself?
connick50 is offline Find More Posts by connick50
Reply With Quote
Old May 09, 2010, 10:41 AM
Registered User
jims123's Avatar
USA, CA, San Diego 92120
Joined Oct 2007
3,088 Posts
Joe,
I will try to help..
1st UNPLUG the battery..
make sure the servo connection from your ESC to your receiver is plugged in correctly and is not flipped, (with the white or yellow lead polarized just like the servos are) and in the same servo channel (it's CH 1 or 3 depending on your transmitter) then once it is plugged in, on the throttle (the left stick) pull it all the way back OFF/ towards you, then on the trim setting, set it all the way down towards you too.. (this is a slider just to the right of the stick) . then plug in the battery .. it should beep, then beep again after you move the stick.. once it is armed .. as you re-plug the battery back in it typically will beep three times (once per Lipo Cel) and then stop beeping .. let us know if that Helps..
JimS
jims123 is offline Find More Posts by jims123
Reply With Quote
Old May 09, 2010, 12:38 PM
Registered User
Joined Mar 2010
62 Posts
jim you are the Daddy thank you so much, I got it running right now Thank you My Friend
connick50 is offline Find More Posts by connick50
Reply With Quote
Old May 09, 2010, 01:22 PM
Registered User
Joined Mar 2010
62 Posts
oh no.......THE ENGINE RUNS BUT BACKWARDS, I DON'T HAVE THE SWITCH ON REVERSE NO MATTER WHICH WAY IT RUNS, IT RUNS THE WRONG WAY, CAN A PROP BE ON BACKWARDS? i NEED hELP ONE MORE TIME...JOE
connick50 is offline Find More Posts by connick50
Reply With Quote
Old May 09, 2010, 03:55 PM
Love anything RC
merlin703's Avatar
Alexandria, Virginia
Joined Mar 2008
3,575 Posts
If you haven't been playing with your radio settings, you can just swap two wires from the ESC to the motor and it should do it.
merlin703 is offline Find More Posts by merlin703
Reply With Quote
Old May 09, 2010, 04:06 PM
Registered User
Joined Mar 2010
62 Posts
mERLIN CAN YOU EXPLAIN A LITTLE FOR ME, i REALLY APPREICATE IT...JOE
connick50 is offline Find More Posts by connick50
Reply With Quote
Old May 09, 2010, 06:00 PM
Registered User
Joined Mar 2010
62 Posts
Hey fella's everything has worked I appreciate everyones help, as soon as the weather clears I'll post some picture of Y'alls help. Thanks Again......Joe Connick
connick50 is offline Find More Posts by connick50
Reply With Quote
Old May 09, 2010, 07:14 PM
A&P/IA
chevronflyer's Avatar
United States, FL, Middleburg
Joined Feb 2007
570 Posts
be sure your prop is on the right way... pushers can be tricky to figure out wich way the prop goes
chevronflyer is offline Find More Posts by chevronflyer
Reply With Quote
Old May 09, 2010, 07:54 PM
Registered User
jims123's Avatar
USA, CA, San Diego 92120
Joined Oct 2007
3,088 Posts
Quote:
Originally Posted by chevronflyer View Post
be sure your prop is on the right way... pushers can be tricky to figure out wich way the prop goes
yes that's really true.. especially if you swap the rotation direction..

Joe,
this below may not be 100% correct but is what I believe..

on most planes that are not pushers ((the motor is mounted on the nose, and the prop generally spins counter-clock-wise (ccw) while you are looking down nose.. with the tail in the back) In that case the prop size number label should be facing towards wind out in front to the plane.. but as you move and flip the same motor 180 to push a pusher plane like ours, it will be most efficient if two things are done.. the prop is flipped over so the numbers again are facing into the wind.. and secondly to stop it from blowing air in the wrong direction.. you flip any two of the ESC leads to make it spin CCW again if looking at the prop from the front of the plane.. I am sure you noticed the three white in line bullet connectors make it easy to swap..

one last tip.. if you have a swim suit and /or small boat .. get it ready and seal up the canopy with tape cause if it flips over on take off (as it's liable to do with the small original motors).. try to get it out of the water fast..

by the way by simply blowing mouth-to-mouth air down the mid-line seam down the fuselage. Found several spots where there was no heat-glue, so that's why mine was taking on water I am sure. So have since PU glue'd a better seal down the center line too..

Regards,
JimS
jims123 is offline Find More Posts by jims123
Reply With Quote
Old May 09, 2010, 08:11 PM
Registered User
jims123's Avatar
USA, CA, San Diego 92120
Joined Oct 2007
3,088 Posts
I believe Chevron is correct (above) and that unless it's perfectly glassy or you are on ice and snow.. this plane is a little under powered so here's the new MicroDan motor and new ESC I added to mine.. I also added the bamboo sticks to give the wings a little lift and dihedral to help during take off. And i just noticed that I did not take the advice I just gave Joe on the three bladed prop you see here.. I do believe it'll be more efficient once i flip it and the ESC leads BOTh so the lable and numbering is pointing towards the front of the plane.. (so i wil fixit) I have not modified the battery bay yet but likely will later and will pull the 3oz of nose weight super glued in the ( assuming it survives.. the other odd I thing I need to re-add is the stiffener for the Elevator control rod so it can stop it bending .. and retain the full +/-1/2 inch throw i believe this guy needs too,. I will work on doing that soonest..
Regards,
JimS
jims123 is offline Find More Posts by jims123
Reply With Quote
Old May 10, 2010, 10:49 AM
Love anything RC
merlin703's Avatar
Alexandria, Virginia
Joined Mar 2008
3,575 Posts
Sorry Joe, I left the office right before you posted this. I see you got everything working and Jim has further elaborated on my suggestions about swaping wires from the ESC to the motor to reverse the rotation of the motor.

My goodness, so many mods to get this thing up in the air.... by the time it's up in the air, it might look like a completely new plane... it would be funny if it ends up looking like a Seawind
Quote:
Originally Posted by connick50 View Post
mERLIN CAN YOU EXPLAIN A LITTLE FOR ME, i REALLY APPREICATE IT...JOE
merlin703 is offline Find More Posts by merlin703
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Icon A5 (real airplane) zaguruinzasky FPV Aircraft 34 Dec 24, 2010 12:59 PM
Discussion Interesting new LSA amphibian in the works: The Icon A5 Thomas B Waterplanes 30 May 14, 2010 02:00 AM
Wanted Icon Ballast Tube atjurhs Aircraft - Sailplanes (FS/W) 1 Jan 17, 2010 05:45 PM
Sold 2 NIB ICON Kits termite Aircraft - Electric - Airplanes (FS/W) 6 Jan 07, 2010 06:04 AM
Discussion Icon A5 EliasRR Mexico 4 Aug 02, 2009 02:33 AM