HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Aug 21, 2012, 02:05 PM
Registered User
United States, MI, Houghton
Joined Jan 2005
4,444 Posts
Oh, Kerwin.......should I get you and the missus a few theater tickets for the show? My treat if you're coming up! Let me know.
snowman is online now Find More Posts by snowman
Reply With Quote
Sign up now
to remove ads between posts
Old Aug 21, 2012, 02:21 PM
RC = Drama Free
DaOldGuy's Avatar
United States, PA, Bellefonte
Joined Dec 2007
11,660 Posts
Quote:
Originally Posted by snowman View Post
You can in the picture that screw closest to the bottom is almost touching one of the cage supports!
I've never had a problem with VH before, but whoa! "if this problem does exist, please contact us again." Well, duh........this guy in his infinite wisdom sure didn't remedy the problem telepathically!!!!!
Loosen the 2 screws, slide to prop saver a little farther out on the shaft?
DaOldGuy is online now Find More Posts by DaOldGuy
Reply With Quote
Old Aug 21, 2012, 04:37 PM
Registered User
United States, MI, Houghton
Joined Jan 2005
4,444 Posts
The collar that makes up the prop saver is a part of the outer cage casting and cannot be slid up (the whole cage is press fitted onto the shaft) .....lame......I know.....what can you expect from reverse engineered products made in China.....
snowman is online now Find More Posts by snowman
Reply With Quote
Old Aug 21, 2012, 04:37 PM
A trail of smoke is GOOD!
waynemia's Avatar
USA, TX, Springtown
Joined May 2008
7,149 Posts
My 10C came back today and is working again. Man that makes me feel better. I will have to copy all the models from this one to the one I got from Bill.

Well, I bought the LT-40 the club member got at the Swapmeet. We did a few repairs on the covering, took out the tank, took out the old 4.8V Nicd battery, loosened up the carb barrel, and I was going to check out the servos. The servos are Airtronics. I don't have any prior experience with them. I immediately noticed the switch color code was wrong. The ground was in the middle instead of one side. What the hell? Then I noticed the servo plugs were different. Then all the wiring on the servos were reversed.

OK, so, all the Airtronics stuff is coming out! That will be a red flag in the future.

So I will install a new tank (bigger), switch, battery, servos, and I put a 12.25 x 3.75 prop on.

The Alpha 60 has had the cosmetics cleaned up. Started the engine -- evo 61. I runs ok but the nasty MAS prop has to go. It has seen way too many prop strikes. I am going to put a MAS 3 blade 12 x 6 on it. I need a bigger nose wheel, it is leaning down hill a little. Servos are JR. They are working but I need bigger horns. I don't have any JR stuff. I may just change those servos too. Took the tail feathers off, added blue locktite, and tightened everything up. I already have receiver in it. It does not have a charge switch so that has to be changed. I have not decided if I want to fly it with the 61 in it first or just put the 91fx on now. I kinda want to see in it in the air.

Pulled the Kadet out of the trailer. I will look at it tomorrow. If the repairs are simple, I will get started on it. Otherwise, I think I will get the new ones flying.

Busy, busy ....
waynemia is offline Find More Posts by waynemia
Reply With Quote
Old Aug 21, 2012, 04:39 PM
Registered User
United States, MI, Houghton
Joined Jan 2005
4,444 Posts
Wow Wayne,.....you're really into it!!!! Go get 'em!!!
snowman is online now Find More Posts by snowman
Reply With Quote
Old Aug 21, 2012, 04:46 PM
Registered User
kerwin50's Avatar
winston mo
Joined Oct 2006
7,461 Posts
Snowy I tried to get you to buy the blue wonder Hurc http://www.headsuprc.com/servlet/the...ushless/Detail.
It has a removable prop saver.
Snowy I'm really giving it some hard thought on coming up. No promises though. Mainly money LOL
kerwin50 is offline Find More Posts by kerwin50
Reply With Quote
Old Aug 21, 2012, 04:51 PM
Registered User
SnowDog1974's Avatar
United States, IL, Crystal Lake
Joined Jan 2009
5,130 Posts
Quote:
Originally Posted by waynemia View Post
My 10C came back today and is working again. Man that makes me feel better. I will have to copy all the models from this one to the one I got from Bill.

Well, I bought the LT-40 the club member got at the Swapmeet. We did a few repairs on the covering, took out the tank, took out the old 4.8V Nicd battery, loosened up the carb barrel, and I was going to check out the servos. The servos are Airtronics. I don't have any prior experience with them. I immediately noticed the switch color code was wrong. The ground was in the middle instead of one side. What the hell? Then I noticed the servo plugs were different. Then all the wiring on the servos were reversed.

OK, so, all the Airtronics stuff is coming out! That will be a red flag in the future.

So I will install a new tank (bigger), switch, battery, servos, and I put a 12.25 x 3.75 prop on.

The Alpha 60 has had the cosmetics cleaned up. Started the engine -- evo 61. I runs ok but the nasty MAS prop has to go. It has seen way too many prop strikes. I am going to put a MAS 3 blade 12 x 6 on it. I need a bigger nose wheel, it is leaning down hill a little. Servos are JR. They are working but I need bigger horns. I don't have any JR stuff. I may just change those servos too. Took the tail feathers off, added blue locktite, and tightened everything up. I already have receiver in it. It does not have a charge switch so that has to be changed. I have not decided if I want to fly it with the 61 in it first or just put the 91fx on now. I kinda want to see in it in the air.

Pulled the Kadet out of the trailer. I will look at it tomorrow. If the repairs are simple, I will get started on it. Otherwise, I think I will get the new ones flying.

Busy, busy ....
The old Airtronics stuff used a different connector scheme until they got smart and started using the same connector scheme as Hitec and a few others. I've got some old ATX servos with my 72mhz Airtronics radios, so I know what you are talking about
SnowDog1974 is online now Find More Posts by SnowDog1974
Reply With Quote
Old Aug 21, 2012, 06:23 PM
Registered User
United States, MI, Houghton
Joined Jan 2005
4,444 Posts
Kerwin.....the motor you suggested was out of stock! Why recommend an out-of-stock motor to me? Cruel man, cruel!
snowman is online now Find More Posts by snowman
Reply With Quote
Old Aug 21, 2012, 06:57 PM
A trail of smoke is GOOD!
waynemia's Avatar
USA, TX, Springtown
Joined May 2008
7,149 Posts
Quote:
Originally Posted by SnowDog1974 View Post
The old Airtronics stuff used a different connector scheme until they got smart and started using the same connector scheme as Hitec and a few others. I've got some old ATX servos with my 72mhz Airtronics radios, so I know what you are talking about
I could fix the pesky servos by flipping the wires on the connectors. I just don't know if they are worth the effort. It isn't like they are super special. I think I may just give them away and tell the person that takes them to deal with it.

Waldo, the guy with the glider is going to just give it to me. I am supposed to get it tomorrow. I can take some photos of the installation. I will test the release servo too. I don't know if perhaps there was so much tension on the tow line, the servo could not pull the pin. I plan to test the plane release too. The design is the same for the tow plane and the glider.

Does anyone know if JR and Hitec servo arms are the same? I need to put longer arms on the Alpha servos. I have loads of Futaba stuff and virtualy nothing for anything else.
waynemia is offline Find More Posts by waynemia
Reply With Quote
Old Aug 21, 2012, 07:54 PM
Montana Transplant
mt_flyer's Avatar
United States, OR, Klamath Falls
Joined Aug 2005
1,923 Posts
Quote:
Originally Posted by waynemia View Post
My 10C came back today and is working again. Man that makes me feel better. I will have to copy all the models from this one to the one I got from Bill.

Well, I bought the LT-40 the club member got at the Swapmeet. We did a few repairs on the covering, took out the tank, took out the old 4.8V Nicd battery, loosened up the carb barrel, and I was going to check out the servos. The servos are Airtronics. I don't have any prior experience with them. I immediately noticed the switch color code was wrong. The ground was in the middle instead of one side. What the hell? Then I noticed the servo plugs were different. Then all the wiring on the servos were reversed.

OK, so, all the Airtronics stuff is coming out! That will be a red flag in the future.

So I will install a new tank (bigger), switch, battery, servos, and I put a 12.25 x 3.75 prop on.

The Alpha 60 has had the cosmetics cleaned up. Started the engine -- evo 61. I runs ok but the nasty MAS prop has to go. It has seen way too many prop strikes. I am going to put a MAS 3 blade 12 x 6 on it. I need a bigger nose wheel, it is leaning down hill a little. Servos are JR. They are working but I need bigger horns. I don't have any JR stuff. I may just change those servos too. Took the tail feathers off, added blue locktite, and tightened everything up. I already have receiver in it. It does not have a charge switch so that has to be changed. I have not decided if I want to fly it with the 61 in it first or just put the 91fx on now. I kinda want to see in it in the air.

Pulled the Kadet out of the trailer. I will look at it tomorrow. If the repairs are simple, I will get started on it. Otherwise, I think I will get the new ones flying.

Busy, busy ....
Quote:
Originally Posted by waynemia View Post
I could fix the pesky servos by flipping the wires on the connectors. I just don't know if they are worth the effort. It isn't like they are super special. I think I may just give them away and tell the person that takes them to deal with it.

Waldo, the guy with the glider is going to just give it to me. I am supposed to get it tomorrow. I can take some photos of the installation. I will test the release servo too. I don't know if perhaps there was so much tension on the tow line, the servo could not pull the pin. I plan to test the plane release too. The design is the same for the tow plane and the glider.

Does anyone know if JR and Hitec servo arms are the same? I need to put longer arms on the Alpha servos. I have loads of Futaba stuff and virtualy nothing for anything else.
what Jr servos are in it.... and NO the splines are different
mt_flyer is offline Find More Posts by mt_flyer
Reply With Quote
Old Aug 21, 2012, 08:31 PM
RC = Drama Free
DaOldGuy's Avatar
United States, PA, Bellefonte
Joined Dec 2007
11,660 Posts
The Sage gets messy...

I have a Car Trailer with 2, 3500 axles and I stressed it out bring big blue home on it. Big Blue scales in a 6400 lbs, 3 tons of smooth riding, axle eating pleasure bus.... with a bed in back.

Car Trailer lived, is not currently friendly with me. The running boards left me one inch gap on each side of the trailer fenders.

Axle has been pulled and messured... Will be calling in the moring to see if they can make one.....

Strange enough.... The bearings are still in tac and roll free.... Seems the Axle was what failed.

Bought a van at lunch.... I have Big Blue <pictured> I have little blue <chevy HHR> and now Medium Blue 2000 Chevy Astro Van with 88K miles and mild hail damage.... Its Medium blue in color.....
DaOldGuy is online now Find More Posts by DaOldGuy
Reply With Quote
Old Aug 21, 2012, 08:37 PM
RC = Drama Free
DaOldGuy's Avatar
United States, PA, Bellefonte
Joined Dec 2007
11,660 Posts
Quick Story...

Jen and I were headed to get some food, on the way there I seen someone that was familiar..... It was the dude from Flite Test that does all of the RC reviews <lot of HK stuff>. We walked up by Becky and Jim, I pointed them out and made some crack about they are here to "Copy the Rest".

Video.... Love the second song! Oh and the flying is very cool too.

3DHS 103 Extra-gas pilot Joe Smith at Knight Hawks Club (8 min 24 sec)
DaOldGuy is online now Find More Posts by DaOldGuy
Reply With Quote
Old Aug 21, 2012, 09:22 PM
A trail of smoke is GOOD!
waynemia's Avatar
USA, TX, Springtown
Joined May 2008
7,149 Posts
Daniel - I went all the way to the shop to look at the JR servos. One the way back, I started looking at the moon. The moon is framed by Saturn, Mars, and Spica tonight. Cool triangle next to the moon. Anyway, I forgot what servos they are. They had STANDARD on the label.

So I have cloned all the models from my 10C to the backup 10C. I am a happy camper. I love those memory modules. The only pain is you have to do one model at a time. Copy each of the 15 models in the tx memory to the memory module, move, the memory module, then copy the models from the module to the tx memory. Takes a little while when you have a lot of models but it is worth it. I also have a set saved in a different page in the module for safety. My memory module can save 16 models in each of 8 pages for a total of 143 models including the 15 in the transmitter. So far, I have not filled up 31 models including the ones I sold already.

Almost all my planes are on my 10C. That is why it was such a problem when I had to send mine in. Now I can just move the transmitter RF module to the other transmitter and I am good to go. No binding problems since the are bound to the rf module, not the transmitter.

Maybe I will switch everything to Futaba one of these days.


OK, I went back and looked again. The servos are ST47 Standard.
waynemia is offline Find More Posts by waynemia
Last edited by waynemia; Aug 21, 2012 at 09:32 PM.
Reply With Quote
Old Aug 21, 2012, 09:47 PM
A trail of smoke is GOOD!
waynemia's Avatar
USA, TX, Springtown
Joined May 2008
7,149 Posts
Happy Twins

Well, except for the CAP - CHP thing.
waynemia is offline Find More Posts by waynemia
Reply With Quote
Old Aug 21, 2012, 10:34 PM
Montana Transplant
mt_flyer's Avatar
United States, OR, Klamath Falls
Joined Aug 2005
1,923 Posts
Quote:
Originally Posted by waynemia View Post
Daniel - I went all the way to the shop to look at the JR servos. One the way back, I started looking at the moon. The moon is framed by Saturn, Mars, and Spica tonight. Cool triangle next to the moon. Anyway, I forgot what servos they are. They had STANDARD on the label.

So I have cloned all the models from my 10C to the backup 10C. I am a happy camper. I love those memory modules. The only pain is you have to do one model at a time. Copy each of the 15 models in the tx memory to the memory module, move, the memory module, then copy the models from the module to the tx memory. Takes a little while when you have a lot of models but it is worth it. I also have a set saved in a different page in the module for safety. My memory module can save 16 models in each of 8 pages for a total of 143 models including the 15 in the transmitter. So far, I have not filled up 31 models including the ones I sold already.

Almost all my planes are on my 10C. That is why it was such a problem when I had to send mine in. Now I can just move the transmitter RF module to the other transmitter and I am good to go. No binding problems since the are bound to the rf module, not the transmitter.

Maybe I will switch everything to Futaba one of these days.


OK, I went back and looked again. The servos are ST47 Standard.
sun just setting here... I will go look and see what I can shoot...lot's of smoke in the air....

PM sent
mt_flyer is offline Find More Posts by mt_flyer
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion New Club Thread - Northern Beaches Soaring Club Psionic001 Australia 5 Feb 24, 2011 08:19 PM
Help! Tower SUper Saver Club la528it Hot Online Deals 9 Jan 10, 2010 05:48 PM
Discussion San Francisco Model Yacht Club's multi-club Swap Meet craig_c Dock Talk 17 Oct 13, 2009 02:28 AM