HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old May 14, 2003, 10:09 PM
Senior Member
Hayward, CA
Joined May 2003
72 Posts
LightFlight LiPos and charger

I recently bought 1 etec 7.2v 1200 lipo pack, 1 etec 10.8v 1200 lipo pack, the battery charger for it, and the 15v power supply. I got them all today but I think there is a problem. The charger I bought is the CH-C72108 here is a picture from an ebay auction:

http://cgi.ebay.com/ws/eBayISAPI.dll...&category=2565

I set up the charger to 1.2 amps ( 2 jumpers), 7.6v pack (jumper near the green led), I installed the heatsink on the charger and connected the 15v power supply provided. Then I connected the 7.8v 1200 lipo pack to the charger and the red light came on steady. Before I charged the battery I measured the voltage at 7.59v. After 2 hours on the charger it was still 7.60 volts. I also measured the current from the charger to the battery and it came out at 0.01 amps. Now this those not seem right since the charger is set at 1.2amps. Also neither the charger nor the battery is even warm, but the power supply is very warm. Is this how it suppose to be going? It has been 2.5 hours and the red light is still on. Let me know.
candy7man is offline Find More Posts by candy7man
Reply With Quote
Sign up now
to remove ads between posts
Old May 15, 2003, 03:08 AM
luc
I plant balsa sticks too
luc's Avatar
France
Joined Feb 2000
3,585 Posts
I Have 2 of these chargers which work as a charm and are very cheap. The charge on li-poly is special: The 1200 mA (if you set the jumpers adequately) only are at the beginning of charge, after they decrease quite rapidly, to top the voltage. But the voltage on 2 cells should top at 8.4 V approx (I have 3 cells and it goes till 12.65V). It is normal that the red light lits when you plug batteries only. Check if it lits when you plug your wall charger only. If it does not (my guess), then the problem comes from the wall charger. If it does, check the output voltage after the charger, before plugging the batteries: you should find something close to 9V..
luc is offline Find More Posts by luc
Reply With Quote
Old May 15, 2003, 03:12 AM
luc
I plant balsa sticks too
luc's Avatar
France
Joined Feb 2000
3,585 Posts
pics
luc is offline Find More Posts by luc
Reply With Quote
Old May 15, 2003, 04:55 AM
Senior Member
Hayward, CA
Joined May 2003
72 Posts
After debugging some more I found a couple of interesting things. First if I connect the power supply the red light does not come on, I checked the power supply and it gave me 0.5v so I gave it as a bad power supply. Well it seems that this power supply has a voltage cut off or some kind of protection because while I was testing the charger with other power supplies it clicked. I then tested it and gave me 18.05v (is a 15v supply). I plugged it again in the charger and it clicked again, then I measured it again back to 0.5v. Also, the connector to the charger was really hot. Needless to say I think there is a short on the connector. Now the sad part is that I took out for good 2 other power supplies . I then measured the resistance between the + and - of the incoming connector to the charger and it game me 0.5ohms, or what a wire would have meaning a short. I think I need to send it back.
candy7man is offline Find More Posts by candy7man
Reply With Quote
Old May 15, 2003, 05:17 AM
luc
I plant balsa sticks too
luc's Avatar
France
Joined Feb 2000
3,585 Posts
That's what I thought....problem come from the power supply or the connector, not the charger
luc is offline Find More Posts by luc
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Sold 3s lipos+charger cheap okie larry Aircraft - Electric - Batteries & Chargers (FS/W) 3 Jan 17, 2006 03:40 PM
Assistance with Lipos and charger. needrcspeed Electric Power Cars 2 Dec 05, 2005 01:46 AM
Sold FS: GWS Tiger Moth set-up - NEW - Laser4, flight pack, Lipos, Charger..Plus LOTS MORE Etonic Aircraft - Electric - Airplanes (FS/W) 5 Jul 25, 2005 08:59 PM
FS:HitecTx&RX, 350motors, Naro servos, Pixie, lipos, charger cysior69 Aircraft - Electric - Airplanes (FS/W) 26 Aug 05, 2004 04:39 PM
The "I have to sell something" sale...CM airframe, lipos + charger, esc's Etonic Aircraft - Electric - Airplanes (FS/W) 12 Sep 16, 2003 09:36 AM