HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old May 28, 2012, 02:52 PM
Registered User
TheKnightFerrin's Avatar
Oregon
Joined Jan 2011
91 Posts
Quote:
Originally Posted by nimic View Post
Hi, ive got some trobble with my KK Multicopter Blackboard.
This is my configuration:

- XXD 2218 1000KV motor*4
- 3.17mm Shaft adaptor*4
- GWS 3-blade Propeller*4
- Hobbywing 20A ESC*4

Futaba FF/ Empfänger R6106

Firmware is KaputteinkUK V4.7
The ESC is learnd bei RX and the Motors start on RX without board

Config ESC:

1. Brake: Off
2. Akku Typ: Lipo
3. Cut Off Modus: Soft Cut
4. Cut OFF Medium 3,15V
5. Start Modus: Normal
6. Timing: High

When i got into armed Modus, only the ESC from Motor1 starts up and the other ESC give a beep.
What have i done wrong?

Thanks ...

Michael
Also I may be out of the loop but I thought the timing should be medium?
TheKnightFerrin is offline Find More Posts by TheKnightFerrin
Reply With Quote
Sign up now
to remove ads between posts
Old May 28, 2012, 06:28 PM
Registered User
VA
Joined Nov 2009
2,586 Posts
medium for most but some motors require high.

Try calibrating all esc at once by setting yaw pot to zero, tx on and throttle high and powering board. When you here the beep for high throttle stored then lower throttle to set low point. Turn everything off and restore yaw pot to previous position. All esc should then arm.
pug398 is offline Find More Posts by pug398
Reply With Quote
Old May 29, 2012, 02:50 AM
Mmmmmmm!
WiseDuck's Avatar
Kingdom of Sweden, Dalarna County, Sater
Joined Oct 2011
3,283 Posts
I have the same problem. I calibrated the throttle range by turning the YAW pot to 0, then I did the usual full throttle, wait for beeps, zero throttle, confirmation beeps procedure. Seemed to work fine. I unplug it, move yaw to 50% again and then I arm the board. I get the usual beeps, but only motor 1 starts. The others start much later, or not at all, or they start if I yank the tricopter in the motors direction. But then they slow down again and eventually stop.
WiseDuck is online now Find More Posts by WiseDuck
Reply With Quote
Old May 29, 2012, 01:44 PM
KK Tri Flyer
mattcro's Avatar
United Kingdom, Scotland, Glasgow
Joined Feb 2012
346 Posts
WiseDuck, are you now trying KK tricopter firmware 1.6?

That version includes PI control, so you are probably seeing the "lazy motor" issue or I-term windup. The general solution is to set your TX trims (or subtrim if you have them) to suit the KK board as described in various other posts/threads... I needed quite a bit of forward and left trim to get mine flying level.

Also make sure your throttle channel travel/rate is 100% before doing the ESC calibration, as the KK board assumes you are using full throttle range. You can reduce the upper throttle endpoint later to allow a bit of headroom for manoeuvring at "full" throttle.

http://www.rcgroups.com/forums/showthread.php?t=1587021 has some discussion on this issue.
mattcro is offline Find More Posts by mattcro
Reply With Quote
Old Jun 06, 2012, 11:14 PM
Registered User
Joined Jan 2010
488 Posts
My quad just developed a problem, not sure if anyone is familiar.

I just upgraded the firmware from the standard xcopter 4.7 to xcopter 4.7acro. Seems to fly good for the most part, except for some reason every once and a while the quad suddenly makes a strange whine and flips over.

It happens most when I go to make a sudden direction change, it will whine and fall. It also happens if I lightly bump the landing gear on the ground, it whines and flips itself over. So far its happened 5 times just in about 10 minutes.

Anyone know what would be causing this?

I'm using dt750 motors, 18a rctimer (hobbywing compatible) esc's, 10x4.5 props, and a hobbyking V2 board.
carl1864 is offline Find More Posts by carl1864
Reply With Quote
Old Jun 07, 2012, 01:37 AM
Registered User
Joined Jan 2006
267 Posts
Quote:
Originally Posted by carl1864 View Post
My quad just developed a problem, not sure if anyone is familiar.

I just upgraded the firmware from the standard xcopter 4.7 to xcopter 4.7acro. Seems to fly good for the most part, except for some reason every once and a while the quad suddenly makes a strange whine and flips over.

It happens most when I go to make a sudden direction change, it will whine and fall. It also happens if I lightly bump the landing gear on the ground, it whines and flips itself over. So far its happened 5 times just in about 10 minutes.

Anyone know what would be causing this?

I'm using dt750 motors, 18a rctimer (hobbywing compatible) esc's, 10x4.5 props, and a hobbyking V2 board.
i'm using thesame firmware on my microquadX . i had to deal with the no.4 lazy motor, but after some trims it flies so well.
in your case you might want to check your bullet plugs,
mandis is offline Find More Posts by mandis
Reply With Quote
Old Jun 07, 2012, 01:19 PM
KK Tri Flyer
mattcro's Avatar
United Kingdom, Scotland, Glasgow
Joined Feb 2012
346 Posts
Are you getting a squeal from one or more motors and then sudden fall or flip?

You might have to change the ESC timing to medium (if it was low) or high. The acro firmware probably works the ESCs/motors a lot harder - sudden increases in throttle can cause the motors/ESC to lose sync and then you lose power, sometimes completely.
mattcro is offline Find More Posts by mattcro
Reply With Quote
Old Jun 07, 2012, 04:35 PM
Registered User
Joined Jan 2010
488 Posts
I think you may be right about the timing. I did a little research into it, and the situation definetly seems to be the squeal of death, when a esc looses sync.

Had timing on medium. I'm going to try switching timing to high once all the rain here stops and give it a try.

It is kind of strange, it never happened at all on the regular 4.7 firmware, after many flights, even fpv, and pushing it as hard as I could push it with that firmware. As soon as I switched to acro, its happening all the time, and I haven't even taken the quad more than 10 feet high, and haven't done any flips yet.
carl1864 is offline Find More Posts by carl1864
Reply With Quote
Old Jun 08, 2012, 01:44 AM
KK Tri Flyer
mattcro's Avatar
United Kingdom, Scotland, Glasgow
Joined Feb 2012
346 Posts
I'm just guessing that the acro firmware is much more aggressive on throttle.

If you have plenty of lift with the 10x4.5 props then maybe you can try 9x4.7 or 9x4.5 props and see if that makes the motors happier without losing too much lift.
mattcro is offline Find More Posts by mattcro
Reply With Quote
Old Jun 08, 2012, 02:16 AM
Master of Flash
LazyZero's Avatar
Alsdorf/Eifel, Germany
Joined Jun 2005
1,510 Posts
Not on throttle but on the axes.

Christian
LazyZero is offline Find More Posts by LazyZero
Reply With Quote
Old Jun 08, 2012, 02:21 AM
Registered User
Slovenia, Ljubljana
Joined Sep 2011
1,268 Posts
Quote:
Originally Posted by mattcro View Post
I'm just guessing that the acro firmware is much more aggressive on throttle.

If you have plenty of lift with the 10x4.5 props then maybe you can try 9x4.7 or 9x4.5 props and see if that makes the motors happier without losing too much lift.
with smaller props, quad will be much more sensitive.
er9xuser is offline Find More Posts by er9xuser
Reply With Quote
Old Jun 08, 2012, 03:46 AM
Registered User
Joined Jan 2006
267 Posts
just sharing my latest build.
Micro copterx HK 2.1 KK 4.7
micro copterX HK v2.1 / KK 4.7fw (1 min 40 sec)
mandis is offline Find More Posts by mandis
Reply With Quote
Old Jun 10, 2012, 02:52 AM
Registered User
Joined Oct 2010
22 Posts
Is it possible to turn off all stabilisation in flight?
I want to use the boards in fixed wing, but I want to be able to turn it off and have the signals pass straight through from receiver to servos.
I bought several boards before I realised I could not find a way to do this.
Msunduzi is offline Find More Posts by Msunduzi
Reply With Quote
Old Jun 10, 2012, 02:11 PM
If it flies, I will crash it
mxspode's Avatar
USA, CO, Westminster
Joined Jan 2008
3,000 Posts
Have a look here.

Rob...
mxspode is offline Find More Posts by mxspode
Reply With Quote
Old Jun 14, 2012, 12:36 AM
Registered User
Joined Mar 2009
338 Posts
Flashing the I.C.

Hi just got a "Rolf R Bakke" black board <5.5> and no info with it?? Am I correct in thinking this Rolf is Kaptain KuK? Also could someone please point me to a link to Flashing the I.C chip and Connecting it all. Read all sorts of info on the forums but getting nowhere fast .

Thanks in advance, MIKE.
micarus is offline Find More Posts by micarus
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Quadrotor brushless controller airbotix Multirotor Talk 63 Aug 06, 2010 11:15 AM
Discussion ALPO -Aerobatic Low Parts count Original design. Brian Courtice Foamies (Scratchbuilt) 8 Sep 21, 2009 03:57 AM
Discussion Any tips for my first flight with a low wing plane? Warthog_Fan Fuel Plane Talk 4 Sep 06, 2009 07:53 AM
Help! Need help with Low-cost QuadRotor Hero.sl Coaxial Helicopters 5 Jun 28, 2009 02:26 AM
Question Searching Simple Controller for Free Flight flymax Power Systems 8 Jan 07, 2006 10:07 AM