HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Aug 07, 2010, 10:23 AM
Quad Whisperer
Joined Jul 2008
943 Posts
Quote:
Originally Posted by jjk77 View Post
@KapteinKUK:
Is there a chance that the controller is working with other potmeter than this

Code:
10 KOhm trim potmeter (3314j) (From the HK401B gyro)
I desoldered one hk401B gyro pcb and also the potmeter are not the same anymore. I have measured nearly 25K not 10K. Or ist it right that a 10K pot can have 25K resistance between to legs?

At this point it is kind of frustrating to get all the peaces together but than nothing seems to be as aspected.
Yes, you can use the 25k pots.
kapteinkuk is offline Find More Posts by kapteinkuk
Reply With Quote
Sign up now
to remove ads between posts
Old Aug 07, 2010, 10:25 AM
No, it's the same plane ...
jjk77's Avatar
Deutschland, Nordrhein-Westfalen, Bochum
Joined Jul 2010
149 Posts
Quote:
Originally Posted by kapteinkuk View Post
The makers of the HK401B gyro has changed the hardware. I will fix the first post.
Ok, thanks.

Here some pictures of the new gyro hardware:



the gyro itself:


and the other side (pots are already desoldered):


main pcb (pots are already desoldered):
jjk77 is offline Find More Posts by jjk77
Last edited by jjk77; Aug 07, 2010 at 11:10 AM. Reason: added picture
Reply With Quote
Old Aug 07, 2010, 10:32 AM
No, it's the same plane ...
jjk77's Avatar
Deutschland, Nordrhein-Westfalen, Bochum
Joined Jul 2010
149 Posts
Quote:
Originally Posted by kapteinkuk View Post
The makers of the HK401B gyro has changed the hardware. I will fix the first post. You can use the 22uF caps instead of the 47uF ones
Well, ok, but thats quite not possible, you need 7 of them, but the gyro only has 2. So i don't have a spare gyro to take the cap from this one :-(. I've ordered them seperatly from another dealer where the Type B version is in stock. But good to know ...
jjk77 is offline Find More Posts by jjk77
Reply With Quote
Old Aug 07, 2010, 10:51 AM
Registered User
Joined May 2010
488 Posts
Quote:
Originally Posted by oeyvindo View Post
I have just completed the v6 PCB. When I connect the power the LED flash once and then it takes exactly 32 sec before it lights steady. The ESC signals no input from the receiver.
I have checked and rechecked the soldering and measured the voltage across the capacitors. Everything seems to be in order.

Any ideas anyone?
If the ESCs do not detect a programmed chip just confirm the chip is in the socket the correct way round? Also check that none of the pots are turned all the way down.

If you think there is an error on the chip I will send you another one out free of charge. It is possible it was damaged in the post, but unlikely.
Niall is offline Find More Posts by Niall
Last edited by Niall; Aug 07, 2010 at 11:00 AM.
Reply With Quote
Old Aug 07, 2010, 10:54 AM
Quad Whisperer
Joined Jul 2008
943 Posts
Quote:
Originally Posted by jjk77 View Post
Well, ok, but thats quite not possible, you need 7 of them, but the gyro only has 2. So i don't have a spare gyro to take the cap from this one :-(. I've ordered them seperatly from another dealer where the Type B version is in stock. But good to know ...
There is three 22-47uF caps in the HK401B gyro, the third is on the main PCB
kapteinkuk is offline Find More Posts by kapteinkuk
Reply With Quote
Old Aug 07, 2010, 11:00 AM
No, it's the same plane ...
jjk77's Avatar
Deutschland, Nordrhein-Westfalen, Bochum
Joined Jul 2010
149 Posts
Quote:
Originally Posted by kapteinkuk View Post
There is three 22-47uF caps in the HK401B gyro, the third is on the main PCB
Sure? This one on the main isn't labeled as the others with "22 / 10V" but "AJ7Y". That would be great if it is a 22µF cap ...

By the way, kapteinkuk, thanks a lot for this project, you've done a fantastic job!

jens

EDIT: In posting http://www.rcgroups.com/forums/showp...postcount=3497 i added a picture of the main pcb from above
jjk77 is offline Find More Posts by jjk77
Last edited by jjk77; Aug 07, 2010 at 11:11 AM.
Reply With Quote
Old Aug 07, 2010, 11:15 AM
Quad Whisperer
Joined Jul 2008
943 Posts
Quote:
Originally Posted by oeyvindo View Post
I have just completed the v6 PCB. When I connect the power the LED flash once and then it takes exactly 32 sec before it lights steady. The ESC signals no input from the receiver.
I have checked and rechecked the soldering and measured the voltage across the capacitors. Everything seems to be in order.

Any ideas anyone?
Is the flash very short (0.1 sec) or longer (0.8 sec)?
kapteinkuk is offline Find More Posts by kapteinkuk
Reply With Quote
Old Aug 07, 2010, 11:26 AM
Quad Whisperer
Joined Jul 2008
943 Posts
Quote:
Originally Posted by jjk77 View Post
Sure? This one on the main isn't labeled as the others with "22 / 10V" but "AJ7Y". That would be great if it is a 22µF cap ...

By the way, kapteinkuk, thanks a lot for this project, you've done a fantastic job!

jens

EDIT: In posting http://www.rcgroups.com/forums/showp...postcount=3497 i added a picture of the main pcb from above
Thanks
Some of the gyros I have caps with 22uF markings and other has the cryptic markings. So I assume they are 22uF. They measures to >20uF on my C meter that only goes to 20uF.
kapteinkuk is offline Find More Posts by kapteinkuk
Reply With Quote
Old Aug 07, 2010, 11:32 AM
Went to mow a meadow
frank48's Avatar
Joined Feb 2007
1,443 Posts
Quote:
Originally Posted by kapteinkuk View Post
Thanks
Some of the gyros I have caps with 22uF markings and other has the cryptic markings. So I assume they are 22uF. They measures to >20uF on my C meter that only goes to 20uF.
I have just had a look at the last 3 gyros I got from HK and all 3 are marked 22uf so I reckon it should be ok for Jens to use them

Frank
frank48 is offline Find More Posts by frank48
Reply With Quote
Old Aug 07, 2010, 11:37 AM
No, it's the same plane ...
jjk77's Avatar
Deutschland, Nordrhein-Westfalen, Bochum
Joined Jul 2010
149 Posts
Quote:
Originally Posted by frank48 View Post
I have just had a look at the last 3 gyros I got from HK and all 3 are marked 22uf so I reckon it should be ok for Jens to use them

Frank
Thanks, so the chinese guys take all caps they can get . As long as our tri- and quadrocopters are flying with these caps, i also would take any
jjk77 is offline Find More Posts by jjk77
Reply With Quote
Old Aug 07, 2010, 12:33 PM
Jakub J's Avatar
Krakow/POLAND
Joined Dec 2009
1,738 Posts
One, two, TRI!

Hi

First flying my TRIcopter foldable frame.
STRANGE THING but not bad flying

http://www.youtube.com/watch?v=1mXk4iMGpbo

Firmware 1.3, motor 2 center of frame 33cm.
RTF <> 930g including 3300mAh 3S LiPo, motor savers etc.

Jakub
Jakub J is offline Find More Posts by Jakub J
Site Sponsor
Reply With Quote
Old Aug 07, 2010, 12:55 PM
Registered User
Norge, Østfold
Joined Aug 2010
4 Posts
Quote:
Originally Posted by Niall View Post
If the ESCs do not detect a programmed chip just confirm the chip is in the socket the correct way round? Also check that none of the pots are turned all the way down.

If you think there is an error on the chip I will send you another one out free of charge. It is possible it was damaged in the post, but unlikely.
It's a strange error. When I apply power the LED flashes once, and then it's dead for 32 sec before it lights steady. But the ESC recives no signal. If the YAW pot meter is set to zero. The same thing happens, but it only takes 20 sec before the LED starts flashing. And it goes dead when I move (reversing the gyro) either YAW, ROLL or PITCH on the transmitter.

You did send me two chips, but I have not tried the other one. I asumed only one of them was programmed. I'll just wait for my programmer to arrive and try to figure it out. Thanks anyways.

And for the record. I don't blaim you a bit for my problems with the controller board.
oeyvindo is offline Find More Posts by oeyvindo
Reply With Quote
Old Aug 07, 2010, 01:21 PM
Went to mow a meadow
frank48's Avatar
Joined Feb 2007
1,443 Posts
frank48 is offline Find More Posts by frank48
Last edited by frank48; Aug 13, 2010 at 07:10 AM. Reason: spelling
Reply With Quote
Old Aug 07, 2010, 01:31 PM
throw new IOPilotException();
IceWind's Avatar
Ireland, County Dublin, Dublin
Joined Feb 2005
2,659 Posts
Quote:
Originally Posted by oeyvindo View Post
It's a strange error. When I apply power the LED flashes once, and then it's dead for 32 sec before it lights steady. But the ESC recives no signal. If the YAW pot meter is set to zero. The same thing happens, but it only takes 20 sec before the LED starts flashing. And it goes dead when I move (reversing the gyro) either YAW, ROLL or PITCH on the transmitter.

You did send me two chips, but I have not tried the other one. I asumed only one of them was programmed. I'll just wait for my programmer to arrive and try to figure it out. Thanks anyways.

And for the record. I don't blaim you a bit for my problems with the controller board.
Make sure you're not doing the same mistake I did, distracted I connected the esc in the wrong place (M6 - first on the left) and I had the tricopter software loaded that only uses 3 outputs M1 - 3.
IceWind is online now Find More Posts by IceWind
Reply With Quote
Old Aug 07, 2010, 01:59 PM
Registered User
Norge, Østfold
Joined Aug 2010
4 Posts
Quote:
Originally Posted by IceWind View Post
Make sure you're not doing the same mistake I did, distracted I connected the esc in the wrong place (M6 - first on the left) and I had the tricopter software loaded that only uses 3 outputs M1 - 3.
I have tried M1 - M3 and servo on M4 without any luck. Think it's something else.

Open for any suggestions though.
oeyvindo is offline Find More Posts by oeyvindo
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Quadrotor brushless controller airbotix Multirotor Talk 63 Aug 06, 2010 11:15 AM
Discussion ALPO -Aerobatic Low Parts count Original design. Brian Courtice Foamies (Scratchbuilt) 8 Sep 21, 2009 03:57 AM
Discussion Any tips for my first flight with a low wing plane? Warthog_Fan Fuel Plane Talk 4 Sep 06, 2009 07:53 AM
Help! Need help with Low-cost QuadRotor Hero.sl Coaxial Helicopters 5 Jun 28, 2009 02:26 AM
Question Searching Simple Controller for Free Flight flymax Power Systems 8 Jan 07, 2006 10:07 AM