SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Nov 09, 2009, 10:02 AM
No RC will end without a fight
FlyingBaby's Avatar
Perth, Australia
Joined Jan 2009
211 Posts
Discussion
Need Help to fix Belt CP V2 Swash Plate not level when pushing or pulling elevator is

Hi there,

I need some help setting up my belt cp v2. When I power up my heli and push my elevator, the swash plate should tilt down in the front and the back should raise up right... but my swash plate actually tilt down in front and the back actually raise and also "bank to the right" (left back servo push up more than the back right servo).. and when I pull my on my elevator, the the swash plate should tilt up in the front and the back should depress right... but my swash plate actually tilt up in front and the back actually depress and also "bank to the left" (right back servo push up more than the back left servo)

It is very hard to express it.. I also include a video, please have a look and please suggest me with some way to solve this.

http://www.youtube.com/watch?v=J4zULJqyT24

I am using DX6I... Can it be transmitter control setting is wrong??

Summary

I mean when I push the elevator forward the two servos at the back of the swash plate do not move evenly... (one move more than the other) and the swash tilt to the right. and when I pull the elevator back the two servos at the back of the swash plate do not raise evenly, (one raise more than the other) and therefore the swash plate tilt to the left.

What is actually the problem????

Is it the servo? or is it transmitter settings?? I am using DX6I



Hope to hear from anyone please....

Regards,

Allan
FlyingBaby is offline Find More Posts by FlyingBaby
Last edited by FlyingBaby; Nov 09, 2009 at 11:40 PM.
Reply With Quote
Sign up now
to remove ads between posts
Old Nov 09, 2009, 12:47 PM
Registered User
Lake Zurich, IL
Joined Jan 2008
5,654 Posts
Quote:
Originally Posted by FlyingBaby View Post
Hi there,

I need some help setting up my belt cp v2. When I power up my heli and push my elevator, the swash plate should tilt down in the front and the back should raise up right... but my swash plate actually tilt down in front and the back actually raise
What are you trying to say?

BTW, please disconnect your motor from ESC when you adjust the servo. You are making me nervous.

Try servo reverse in your tx to get to proper swash movement. Looking from the tail, right cyclic will move the left side up and the right side down; looking from the side, push forward elevator will move the front down and raise the rear of the swash. Of course, throttle pushing forward will raise the entire swash evenly. Hope this help.
sidneyw is offline Find More Posts by sidneyw
Site Sponsor
Reply With Quote
Old Nov 09, 2009, 11:38 PM
No RC will end without a fight
FlyingBaby's Avatar
Perth, Australia
Joined Jan 2009
211 Posts
NO.. I mean when I push the elevator forward the two servos at the back of the swash plate do not move evenly... (one move more than the other) and the swash tilt to the right. and when I pull the elevator back the two servos at the back of the swash plate do not raise evenly, (one raise more than the other) and therefore the swash plate tilt to the left.

What is actually the problem????

Is it the servo? or is it transmitter settings?? I am using DX6I
FlyingBaby is offline Find More Posts by FlyingBaby
Reply With Quote
Old Nov 10, 2009, 09:50 AM
Registered User
Lake Zurich, IL
Joined Jan 2008
5,654 Posts
Glad to know the problem is resolved.
sidneyw is offline Find More Posts by sidneyw
Site Sponsor
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion ESky Belt CP V2 or Honey Bee King 3? IgnatiusJohan Beginner Training Area (Heli-Electric) 12 Apr 20, 2010 12:17 PM
Discussion Belt CP v2 or Honeybee King 3? green_one Micro Helis 3 Nov 01, 2009 11:52 AM
Poll esky 450 belt cp v2 or HK450 with allthings needed to fly guitaramp68 Electric Heli Talk 9 Oct 24, 2009 01:21 PM
Help! esky Belt Cp V2 transmitter not working Thomas*rc Micro Helis 0 Sep 30, 2009 07:00 PM
Question esky Belt Cp V2 transmitter not working Thomas*rc Power Systems 0 Sep 30, 2009 06:23 AM