SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Jan 15, 2013, 06:16 PM
Just fly
evltoy's Avatar
Australia, VIC, Glen Waverley
Joined Jan 2011
2,103 Posts
Radio gear? servos?

My mcpx did something like this. One minute it was flying fine. Then while in a hover it just banked hard left into the ground for no reason. Worked out it was a combination of low batt in the TX (DX4e) and someone else with a High end futaba radio doing FPV.

Not saying that you have issues with signal, but I would be looking at the electronic if al HW has been swapped out.

By the way.. my crappy 450 is still have major tail vibes in ID1 & 2. this after changing out 95% of the heli almost 3 times. Thinking it may be the belt or shaft on motor.
evltoy is offline Find More Posts by evltoy
Reply With Quote
Sign up now
to remove ads between posts
Old Jan 15, 2013, 06:28 PM
Need More PURPLE !!
Dejavu*Xion's Avatar
United States, NV, Las Vegas
Joined Aug 2012
3,670 Posts
Hmmmmmmm......There is a thought..I am using an orange rx.. get what ya pay for kinda thing. So thats a possibility. This Friday i will pick up a genuine Align head for it. ....And yes these lil 450's can be a pain in the #@%!,,,But still one of my fav. to fly.
Dejavu*Xion is offline Find More Posts by Dejavu*Xion
Reply With Quote
Old Jan 15, 2013, 06:40 PM
Just fly
evltoy's Avatar
Australia, VIC, Glen Waverley
Joined Jan 2011
2,103 Posts
My 450 has got the better of me. I have wasted too much time trying to debug the thing that I'm either going to bin it, buy another SE kit or go cut my losses with all the extra parts I have and go the PRO.
evltoy is offline Find More Posts by evltoy
Reply With Quote
Old Jan 15, 2013, 08:00 PM
Registered User
mhills51's Avatar
kansas city
Joined Feb 2007
12,237 Posts
Make sure your swash isn't getting stuck!
mhills51 is offline Find More Posts by mhills51
RCG Plus Member
Old Jan 15, 2013, 11:15 PM
Need More PURPLE !!
Dejavu*Xion's Avatar
United States, NV, Las Vegas
Joined Aug 2012
3,670 Posts
Quote:
Originally Posted by mhills51 View Post
Make sure your swash isn't getting stuck!
Ahhhh . I like that idea also. I'll lube it 2marrow and try it out again. ( sounds like something in a penthouse forum ) lol
Dejavu*Xion is offline Find More Posts by Dejavu*Xion
Reply With Quote
Old Jan 15, 2013, 11:23 PM
Closed Account
Joined Aug 2007
4,497 Posts
Make sure to work it a bit on the bench before that next flight. Full cyclic in all orientations while exercising positive and negative pitch to make sure it has good characteristics for smooth flight.
eagle777 is offline Find More Posts by eagle777
Last edited by eagle777; Jan 15, 2013 at 11:35 PM. Reason: I started using Teflon grease instead of light oil, it seems to stick better to the main shaft.
Reply With Quote
Old Jan 15, 2013, 11:39 PM
Need More PURPLE !!
Dejavu*Xion's Avatar
United States, NV, Las Vegas
Joined Aug 2012
3,670 Posts
Ahhh man do i feel like an idiot !! ha...Sometimes its the simple things in life we overlook. I could not wait. So i lubed it up, ran a battery thru it out in back yard. ( Flood lights on ) And no jumps.. I was over thinking it all.. And all i needed was a bit of ye ol tri-flo..Once again thanks Mhills..U Da Man !!

** Read your post dave, Ill be sure and put it thru trial before i take it out loop, Invert the heli **

A drop of oil.....Pfffttttt....the simple things i tell ya..ha ha
Dejavu*Xion is offline Find More Posts by Dejavu*Xion
Reply With Quote
Old Jan 16, 2013, 04:46 AM
Registered User
United States, NY, New York
Joined Nov 2010
2,310 Posts
Oh the things you can accomplish at 2am when you can't sleep and you have to be up at 3:05am for a 12 hr shift at work. I put my VWINRC 500ESP back together. I replaced the tail boom holder all the way back. New main shaft, main gear, swap the rx for another project, the skids, and canopy mount. I regeared the tail servo and right aileron servos last week. Tested the electronics and all seems good. I just need to spool it up and check for vibs. Then buy the Align blades.
ridge_racer is offline Find More Posts by ridge_racer
Reply With Quote
Old Jan 21, 2013, 12:10 AM
Registered User
United States, NY, New York
Joined Nov 2010
2,310 Posts
Problems and more problems. I have a bad vibs at the tail when I spool up to a certain rpm. Not the tail shaft and I have balanced the tail blades. I did find the tail shaft bearings fitted loose inside the bearing holders. I used some thread lock to secure them inside. Hope that works.
ridge_racer is offline Find More Posts by ridge_racer
Reply With Quote
Old Jan 25, 2013, 05:15 AM
Registered User
Atomic Skull's Avatar
Joined Dec 2011
3,194 Posts
500 Pro canopies are back in at HK. Got a buddy code if anyone wants one cheaper.

Turnigy High-End Fiberglass Canopy for Trex 500 Pro

Atomic Skull is online now Find More Posts by Atomic Skull
Reply With Quote
Old Jan 25, 2013, 11:36 AM
Registered User
United States, NY, New York
Joined Nov 2010
2,310 Posts
AS....That's a really nice canopy. Reminds me of the ALZRC canopies.
ridge_racer is offline Find More Posts by ridge_racer
Reply With Quote
Old Jan 25, 2013, 11:37 AM
Registered User
3d astronaut's Avatar
United States, MI, Paw Paw
Joined Sep 2011
4,104 Posts
I have that canopy on my 500 and it looks great. The quality is fantastic. Was a tight fit with my older (somewhat) puffy batteries but the new lipos fit just fine
3d astronaut is offline Find More Posts by 3d astronaut
RCG Plus Member
Last edited by 3d astronaut; Jan 25, 2013 at 11:44 AM.
Reply With Quote
Old Jan 26, 2013, 08:04 AM
Registered User
Joined Jan 2013
1 Posts
hk500gt

is the worse buy ever cant rev it up makes a very weird sound and looses its tracking im using a thyphoon 500 motor with a red brick esc 80A head speed seems to high can anyone maybe help me with pitch and throttle curves im using a dsx 7 jr radio


thanks
MARIUS114 is offline Find More Posts by MARIUS114
Reply With Quote
Old Jan 26, 2013, 09:33 AM
Registered User
United States, NY, New York
Joined Nov 2010
2,310 Posts
The HK500GT in most cases does not fly right out of the box like an Align. You may need to change some parts to get it to spin smooth and maintain proper tracking. Could you post a video of the weird noise so myself and others can hear? As far as the tracking, it can be a number of things. You could have a slightly bent head block or the head dampers are too soft. For the throttle curve you want to set it so that at 0 deg pitch you only run 2700 rpm. Use Dark Horse's calculator get this information. http://dhrc.rchomepage.com/calc.htm
ridge_racer is offline Find More Posts by ridge_racer
Reply With Quote
Old Jan 26, 2013, 09:48 AM
Registered User
mhills51's Avatar
kansas city
Joined Feb 2007
12,237 Posts
Quote:
Originally Posted by MARIUS114 View Post
is the worse buy ever cant rev it up makes a very weird sound and looses its tracking im using a thyphoon 500 motor with a red brick esc 80A head speed seems to high can anyone maybe help me with pitch and throttle curves im using a dsx 7 jr radio


thanks
Weird sound and low power could be from one of the three legs of power going to your motor has a poor solder joint. Just like the speed control turns the motor into a speaker. I had the same thing with that combo, but my motor was one of the first turnigy 500l. It came with the bullets already installed, but not the speed control or the other way around, it's been three years lol! All I do remember was it being the connectors that I didn't solder. I thought my red brick has just gone bad and it wasn't until I needed those bullets for another heli that I cut the shrink off and found the solder half melted and brownish color.

Sense then I have seen two other guy's run into the same thing with a weird sound and going down. I told them to check and both of them turned out to be the same.
mhills51 is offline Find More Posts by mhills51
RCG Plus Member
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
I got some Fan Fold what to build thread part II started by emoone!!! Don Sims Foamies (Kits) 188 Jan 23, 2010 08:28 PM
Mountain Models Tantrum Partial Build Thread.. Tram Parkflyers 142 Apr 03, 2004 10:41 PM
My Bobolink Build Thread (very Colibri like) Jim Poor Hand Launch 65 Dec 10, 2003 04:48 PM
Laird Super Solution Build Thread! boomerace Parkflyers 178 Oct 29, 2003 07:20 PM
Switchback re-build thread (or What the $#*& was that!) Biggles604 Parkflyers 17 Jun 23, 2003 09:34 PM