SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Oct 29, 2012, 12:50 PM
Registered User
United States, NY, New York
Joined Nov 2010
2,310 Posts
thx mhills
ridge_racer is online now Find More Posts by ridge_racer
Reply With Quote
Sign up now
to remove ads between posts
Old Oct 29, 2012, 01:10 PM
Registered User
Atomic Skull's Avatar
Joined Dec 2011
3,194 Posts
Quote:
Originally Posted by mhills51 View Post
Those are tarot blades. You can get them at AC-RC.com http://www.ac-rc.com/product_info.ph...m9vqejjfnvjit5
They all have a little hole drilled in to the root on the underside for some reason. Miracle Mart told me that Tarot told them it was to check hardness.

The ALZRC neon yellow tail blades I got are garbage, they produce so much vibes that they actually vibrated the locktited screw that holds the pitch control arm loose. The CF Tarot ones only produce vibes in the 100-150 range while the ALZRC plastic ones were around 900.
Atomic Skull is offline Find More Posts by Atomic Skull
Last edited by Atomic Skull; Oct 29, 2012 at 03:11 PM.
Reply With Quote
Old Oct 29, 2012, 03:53 PM
Registered User
United States, NY, New York
Joined Nov 2010
2,310 Posts
Did you buy them from an online vendor or from a vendor on ebay?
ridge_racer is online now Find More Posts by ridge_racer
Reply With Quote
Old Oct 29, 2012, 04:26 PM
Registered User
Atomic Skull's Avatar
Joined Dec 2011
3,194 Posts
Quote:
Originally Posted by ridge_racer View Post
Did you buy them from an online vendor or from a vendor on ebay?
The ALZRC tailblades? I got them from oomodel. The plastic Tarot blades I bought from Miracle Mart are even worse, they actually make the tailfin buzz. I think I'll be using CF tailblades from now on.
Atomic Skull is offline Find More Posts by Atomic Skull
Reply With Quote
Old Oct 29, 2012, 05:52 PM
Registered User
mhills51's Avatar
kansas city
Joined Feb 2007
12,237 Posts
The best are the tarot 500 CF. I have them on all my 500's
mhills51 is offline Find More Posts by mhills51
RCG Plus Member
Old Oct 29, 2012, 08:40 PM
Registered User
Atomic Skull's Avatar
Joined Dec 2011
3,194 Posts
Was doing pitch pumps, at the bottom of a pump it starts spinning wildly had to hit throttle hold and just let it come down. Cracked tailfin (fusuno FG not carbon) damaged canopy, bent mainshaft, possible bent feathering shaft. Gorilla Gear saved it from worse damage (gear are a little bent on one side)

I can't find any cause for this, the tail is fine, the tail servo works perfectly. All I can think of is that maybe the belt slipped but the tension seems fine.

EDIT: bent feathering shaft and bent pitch control arm on one grip also, glad I ordered a set of pitch control arms on my last order from Infinity hobby. Bearings in the grip with the bent arm are also trashed. The collar on the mainshaft also slid up, not sure if this happened before or after the crash. The screws seem loose though. I remember a farting sound as it started spinning now, so maybe the collar slipped and dumped more pitch into the blades than it could counteract torque for?
Atomic Skull is offline Find More Posts by Atomic Skull
Last edited by Atomic Skull; Oct 29, 2012 at 09:25 PM.
Reply With Quote
Old Oct 29, 2012, 09:20 PM
Registered User
mhills51's Avatar
kansas city
Joined Feb 2007
12,237 Posts
Don't think it was the belt unless it broke. Sounds more like something binded in the linkage or servo got stuck.
mhills51 is offline Find More Posts by mhills51
RCG Plus Member
Old Oct 29, 2012, 10:08 PM
Registered User
Atomic Skull's Avatar
Joined Dec 2011
3,194 Posts
Quote:
Originally Posted by mhills51 View Post
Don't think it was the belt unless it broke. Sounds more like something binded in the linkage or servo got stuck.
Checked it over and there was nothing wrong except two of the motor wires had popped out (probably when it hit) and the collar had slipped, and a few of the head links had popped (again probably when it hit) First thing I looked at when I got to it was the tail and rudder servo and they were working fine. I'm also sure that the servo didn't get stalled by the tail rotor because it's a full sized servo and is more than up to the task. None of the RX or gyro wires were loose either.

What's really disturbing me is that I can't find a clear cause for this.


At least there was no serious damage, that gorilla gear was worth the $20. Got a little bent though, going to boil it for a minute and straighten it back out.
Atomic Skull is offline Find More Posts by Atomic Skull
Reply With Quote
Old Oct 29, 2012, 10:25 PM
Registered User
mhills51's Avatar
kansas city
Joined Feb 2007
12,237 Posts
Just because your using a full size servo don't mean it can't bind. It happens all the time on 600's. Worst is people put the full size on a 500 because they have some kind of binding and instead of finding it they think a larger servo will just take care of it. Instead the servo has the power to really get it stuck. When doing hard pitch pumps the slider slams to one side of the shaft. If the trim is even real close the fast reaction of the gyro and servo can slam it into the holder and get stuck. When setting mine up I put it all the way over to were it is not binding and then back away one more notch.

On my 450 with the mini servo. If just one of the guides gets moved just a tad it is enough to send it spinning. At least twice I had to auto and save it all because I didn't take a second to make sure the rudder was moving back and forth without any hesitation before taking off.
mhills51 is offline Find More Posts by mhills51
RCG Plus Member
Old Oct 29, 2012, 11:23 PM
Registered User
Atomic Skull's Avatar
Joined Dec 2011
3,194 Posts
Quote:
Originally Posted by mhills51 View Post
Just because your using a full size servo don't mean it can't bind. It happens all the time on 600's. Worst is people put the full size on a 500 because they have some kind of binding and instead of finding it they think a larger servo will just take care of it. Instead the servo has the power to really get it stuck. When doing hard pitch pumps the slider slams to one side of the shaft. If the trim is even real close the fast reaction of the gyro and servo can slam it into the holder and get stuck. When setting mine up I put it all the way over to were it is not binding and then back away one more notch.
The slider moves freely with no binding and I left the pitch travel range at 100% on the Robird which leaves about 2mm between the slider and either end of the travel. So I can't see how that could be it. It is possible that the rudder control rod bent a little and jammed in the guides. I think I'll replace it with a CF one. Only ones I've been able to find are for the 500 Pro so I'll have to remove the metal end cap cut the rod down and reglue the metal end back on. If I could just find the end caps I could make my own much more cheaply.


Mainshaft bearings are ok despite the bent shaft. It's possible that the single piece mainshaft block and thrust bearings saved the radial bearings from damage.
Atomic Skull is offline Find More Posts by Atomic Skull
Last edited by Atomic Skull; Oct 29, 2012 at 11:32 PM.
Reply With Quote
Old Oct 31, 2012, 06:57 PM
Need More PURPLE !!
Dejavu*Xion's Avatar
United States, NV, Las Vegas
Joined Aug 2012
3,670 Posts
Happy halloween ,, I'd say the Mrs. could use a bikini wax eh..ha
Dejavu*Xion is offline Find More Posts by Dejavu*Xion
Last edited by Dejavu*Xion; Oct 31, 2012 at 09:19 PM.
Reply With Quote
Old Oct 31, 2012, 07:14 PM
Registered User
mhills51's Avatar
kansas city
Joined Feb 2007
12,237 Posts
That was great!! lol! Just dropped the kids and wife down in the rich part of town
mhills51 is offline Find More Posts by mhills51
RCG Plus Member
Old Oct 31, 2012, 08:37 PM
Need More PURPLE !!
Dejavu*Xion's Avatar
United States, NV, Las Vegas
Joined Aug 2012
3,670 Posts
Going to get full size candy bars ther ..ha....I just ordered a turnigy 220w power supply for my 200w eco-6-10 charger...no more 1.5 hours charge time for me on 5000mah........I went ahead and did the ems shipping . Anybody know a round abouts time frame ems is to the states ?
Dejavu*Xion is offline Find More Posts by Dejavu*Xion
Reply With Quote
Old Oct 31, 2012, 08:56 PM
Just fly
evltoy's Avatar
Australia, VIC, Glen Waverley
Joined Jan 2011
2,103 Posts
I have me-self the turnigy 1080W PSU. WOW this thing is a killer.

Using 2x 106B ichargers @ 10A each for 6S and the PSU doesnt even know the chargers are running.
evltoy is offline Find More Posts by evltoy
Reply With Quote
Old Oct 31, 2012, 09:17 PM
Need More PURPLE !!
Dejavu*Xion's Avatar
United States, NV, Las Vegas
Joined Aug 2012
3,670 Posts
1080w psu good gawd .. Im sure thats prolly all you will ever need. Yes 3 years later im just now getting hip to power chargers and power supplys. lol. My little accucell6 charging time took all day. how many days is e.m.s to oz evltoy ?
Dejavu*Xion is offline Find More Posts by Dejavu*Xion
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
I got some Fan Fold what to build thread part II started by emoone!!! Don Sims Foamies (Kits) 188 Jan 23, 2010 08:28 PM
Mountain Models Tantrum Partial Build Thread.. Tram Parkflyers 142 Apr 03, 2004 10:41 PM
My Bobolink Build Thread (very Colibri like) Jim Poor Hand Launch 65 Dec 10, 2003 04:48 PM
Laird Super Solution Build Thread! boomerace Parkflyers 178 Oct 29, 2003 07:20 PM
Switchback re-build thread (or What the $#*& was that!) Biggles604 Parkflyers 17 Jun 23, 2003 09:34 PM