HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Oct 25, 2012, 05:30 PM
Suspended Account
Joined Sep 2012
428 Posts
Quote:
Originally Posted by mhills51 View Post
My precious is how I thought of my 500pro until a burned up servo brought it down. After that first crash it no longer has the title "never been crashed" lol!

When I raced motorcycles and you got a new set of leathers the first thing you did was roll around on the ground to ruff them up. If you didn't you were just asking to crash.
That's funny. I remember during my first MSF class decades ago the instructor saying to just go ahead and drop your bike. Get it out of the way because a new rider is going to eventually do it anyway. Never dropped mine, though.
crvnation is offline Find More Posts by crvnation
Reply With Quote  (Disabled)
Sign up now
to remove ads between posts
Old Oct 25, 2012, 05:33 PM
..................
Dejavu*Xion's Avatar
United States, NV, Las Vegas
Joined Aug 2012
3,462 Posts
you took msf classes ? lmfao
Dejavu*Xion is offline Find More Posts by Dejavu*Xion
Reply With Quote
Old Oct 25, 2012, 06:17 PM
Registered User
mhills51's Avatar
kansas city
Joined Feb 2007
11,911 Posts
At least I have a AMA road racing license lol! And if you dropped your bike you would fail the test and be out $400
mhills51 is online now Find More Posts by mhills51
RCG Plus Member
Old Oct 25, 2012, 08:51 PM
Registered User
Atomic Skull's Avatar
Joined Dec 2011
3,062 Posts
Maiden hover tonight. Was flying great then I piroed it and on the stop it let out with a BRRRRRR!! and flipped forward into the ground. Minimal damage, I think was saved it was the low headspeed (2400 rpm) and me hitting throttle hold the instant things went south. Only damage is a bent tail rotor shaft, broken tailboom, broken tail blades, ruined tail rotor shaft bearings bent rudder control rod and a slight scuff on the tip of one main rotor blade. Amazing it survived with so little damage. (give that the mainblades weren't damaged I don't think the mainshaft is bent)

The long ball link had come out of the swash causing it to flip over. I thought it had broken free at first but it seems to have unscrewed itself. The disturbing thing is that it was locktited in. I'm going to redo all the swash balls with green locktite to make sure they don't come loose again. The vibe log on the Robird doesn't show excessive vibrations so I have no idea how this could have happened.
Atomic Skull is offline Find More Posts by Atomic Skull
Reply With Quote
Old Oct 25, 2012, 09:50 PM
Suspended Account
Joined Sep 2012
428 Posts
Quote:
Originally Posted by mhills51 View Post
At least I have a AMA road racing license lol! And if you dropped your bike you would fail the test and be out $400
Cool. Not so with MSF, though. They supplied the bikes (mirrors, turn signals, etc already removed), so drop 'em all day long! Nobody fails anyway. Besides, the course was required by the military and you couldn't ride to work on base without the class. Can't get through the gate without a base sticker. Gets you a big insurance discount and the class was free on base, too. Only an IDIOT would pass that up.
crvnation is offline Find More Posts by crvnation
Reply With Quote  (Disabled)
Old Oct 27, 2012, 08:39 PM
..................
Dejavu*Xion's Avatar
United States, NV, Las Vegas
Joined Aug 2012
3,462 Posts
I had the most bizzar dirt nap today. I was out doing loops and barrel rolls with my align 500e. Just after completing a loop and leveling back out my main blades just stop turning. Of course ther is no salvaging an auto at this point. walking up I'm prepared for the worst. I could not believe the flybar took most of the thump. small crack in canopy and a bent main shaft. That was it nothing more. ( cheapest crash to date. lol ) ~Reason~: The pinion on motor shaft came loose, hence no main blade spin. From here on out think i'll use red threadlock for pinions.
Dejavu*Xion is offline Find More Posts by Dejavu*Xion
Reply With Quote
Old Oct 27, 2012, 10:11 PM
Registered User
Atomic Skull's Avatar
Joined Dec 2011
3,062 Posts
Quote:
Originally Posted by Dejavu*Xion View Post
I had the most bizzar dirt nap today. I was out doing loops and barrel rolls with my align 500e. Just after completing a loop and leveling back out my main blades just stop turning. Of course ther is no salvaging an auto at this point. walking up I'm prepared for the worst. I could not believe the flybar took most of the thump. small crack in canopy and a bent main shaft. That was it nothing more. ( cheapest crash to date. lol ) ~Reason~: The pinion on motor shaft came loose, hence no main blade spin. From here on out think i'll use red threadlock for pinions.
You'll never get red loose. I would use green and grind a flat spot in the shaft if there isn't one.


Shakedown flight tonight went well. At 2400rpm I had 3.85v left per cell after 4 minutes on a pair of 3S 2200mah batteries. Using a 1600kv SK3 Helidrive motor and 13T pinion. Throttle curve is 70% at 0 degrees, 85% at 5.5 degrees, 100% at 11 degrees. I might try bumping it up to a 14T pinion later.

Align has an ESP version of the new zero slop tail pitch slider now.
Atomic Skull is offline Find More Posts by Atomic Skull
Reply With Quote
Old Oct 27, 2012, 10:18 PM
Registered User
mhills51's Avatar
kansas city
Joined Feb 2007
11,911 Posts
If you use something just make it green around the shaft and blue on the screw. The newer motors are precision balanced that is why there is no flat spot. The MX are geared more for the pro models that use aluminum pinions with two set screws. The soft metal of the aluminum should better mold around the shaft. The green is gap filling and should take care of it. Often used to glue pinions on with no set screw.
mhills51 is online now Find More Posts by mhills51
RCG Plus Member
Old Oct 27, 2012, 10:27 PM
..................
Dejavu*Xion's Avatar
United States, NV, Las Vegas
Joined Aug 2012
3,462 Posts
Quote:
Originally Posted by mhills51 View Post
If you use something just make it green around the shaft and blue on the screw. The newer motors are precision balanced that is why there is no flat spot. The MX are geared more for the pro models that use aluminum pinions with two set screws. The soft metal of the aluminum should better mold around the shaft. The green is gap filling and should take care of it. Often used to glue pinions on with no set screw.
Great info rite ther hills...pinion I had on was brass...I now have alumnium..will use green on shaft and blue for grub screw.
Dejavu*Xion is offline Find More Posts by Dejavu*Xion
Reply With Quote
Old Oct 28, 2012, 07:12 PM
Registered User
Atomic Skull's Avatar
Joined Dec 2011
3,062 Posts
The throttle wire is a bit sloppy because the Plush 60A is temporary until the YEP80A arrives. I got some of those motor wire plugs from HK but after installing it on the ESC I decided I didn't like them. When the YEP80A arrives I'm going to use 4mm bullet connectors instead.

I couldn't figure out a better place to mount the ESC, under the canopy on the sides interferes with the canopy fit and under the battery tray puts the wires dangerously close to the pinion.

The extensions on the canopy spacers are aluminum cable stops from the hardware store. They are needed to keep the Pro canopy from touching the main gear. I'm going to order some canopy thumbscrews because I do not trust the canopy bolts, not even on a standard ESP canopy.





Atomic Skull is offline Find More Posts by Atomic Skull
Last edited by Atomic Skull; Oct 28, 2012 at 07:18 PM.
Reply With Quote
Old Oct 28, 2012, 07:27 PM
BahamaHeli
kdean's Avatar
The Bahamas
Joined Dec 2010
3,617 Posts
Looks good atomic.

I've got my plush 60a under the battery tray (modded) and there is just enough space for the pinion. The battery strap also keeps the wires from getting to close.

When i get my hk500tt i'll be mounting the cc ice on the side of the frame.

What walkera rx are you using? Is it a fbl/rx unit?
kdean is online now Find More Posts by kdean
Reply With Quote
Old Oct 28, 2012, 08:04 PM
AMA# 548800
jombo's Avatar
United States, CT, Trumbull
Joined Dec 2007
4,926 Posts
Sweet 500 Atomic Skull . I have the same plush esc and i have plenty of room in the front battery tray . Did they change the size of the plush esc , or is your tray modded ? I didnt mod or lower my tray , maybe that's why.
jombo is offline Find More Posts by jombo
Reply With Quote
Old Oct 28, 2012, 09:31 PM
Registered User
Atomic Skull's Avatar
Joined Dec 2011
3,062 Posts
Quote:
Originally Posted by kdean View Post
Looks good atomic.

I've got my plush 60a under the battery tray (modded) and there is just enough space for the pinion. The battery strap also keeps the wires from getting to close.

When i get my hk500tt i'll be mounting the cc ice on the side of the frame.

What walkera rx are you using? Is it a fbl/rx unit?
RX801 RX and a Robird G31 FBL. The Robird is the blue box on the receiver tray. The antennas on the RX801 are white because I damaged the antennas on it a while back so I soldered new wires onto the board and cut them to the same length as the originals (the RX801 antennas are just 41mm wires soldered into through holes on pads on the edge of the board)

Any way you could take a picture of how you mounted the ESC? I couldn't figure out a safe way to do it.

Quote:
Originally Posted by jombo View Post
Sweet 500 Atomic Skull . I have the same plush esc and i have plenty of room in the front battery tray . Did they change the size of the plush esc , or is your tray modded ? I didnt mod or lower my tray , maybe that's why.
The Tarot 500 kits now come with a dropped battery tray.
Atomic Skull is offline Find More Posts by Atomic Skull
Last edited by Atomic Skull; Oct 28, 2012 at 09:38 PM.
Reply With Quote
Old Oct 29, 2012, 12:31 AM
Registered User
United States, NY, New York
Joined Nov 2010
2,274 Posts
AS....where did you get the carbon blades?
ridge_racer is offline Find More Posts by ridge_racer
Reply With Quote
Old Oct 29, 2012, 07:42 AM
Registered User
mhills51's Avatar
kansas city
Joined Feb 2007
11,911 Posts
Those are tarot blades. You can get them at AC-RC.com http://www.ac-rc.com/product_info.ph...m9vqejjfnvjit5
mhills51 is online now Find More Posts by mhills51
RCG Plus Member
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
I got some Fan Fold what to build thread part II started by emoone!!! Don Sims Foamies (Kits) 188 Jan 23, 2010 08:28 PM
Mountain Models Tantrum Partial Build Thread.. Tram Parkflyers 142 Apr 03, 2004 10:41 PM
My Bobolink Build Thread (very Colibri like) Jim Poor Hand Launch 65 Dec 10, 2003 04:48 PM
Laird Super Solution Build Thread! boomerace Parkflyers 178 Oct 29, 2003 07:20 PM
Switchback re-build thread (or What the $#*& was that!) Biggles604 Parkflyers 17 Jun 23, 2003 09:34 PM