HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jul 19, 2012, 06:14 PM
Registered User
mhills51's Avatar
kansas city
Joined Feb 2007
12,743 Posts
I had the same thing, but it was on the pro. That made me realize I forgot to tighten the tail boom and it had slide out 1/4 inch 10mm. Yours could be the rear tail case. Have you checked to see if your tail pin is still in place? I almost started to make adjustments and questioned the servo jumping gears before I found mine.
mhills51 is online now Find More Posts by mhills51
RCG Plus Member
Sign up now
to remove ads between posts
Old Jul 19, 2012, 06:45 PM
Just fly
evltoy's Avatar
Australia, VIC, Glen Waverley
Joined Jan 2011
2,103 Posts
Quote:
Originally Posted by stingeragents View Post
evltoy. Took my heli for just a hover last night. Was checking out the tail and sure enough, I don't have full movement to the left side of tail slider, so that very well could be my problem. Not gonna get to fly tonight, but I'll have to change that in the tarot programming to get full movement. Not sure what happened as when I set it up it had full movement left and right. I'm assuming (and hoping) that is the problem as it will be a super easy fix.
Glad to read you worked it out. Check your servo, boom or tail case/box hadnt moved to cause this... Even though one of these parts could have been move I doubt is was the cause as it would have to move a fair amount which you would have notice my eye-balling.

Make sure before adjusting the gyro limits that you have the end points in the TX set to 100% on both ends and that you have mechanicaly zeroed your tail.
evltoy is offline Find More Posts by evltoy
Reply With Quote
Old Jul 19, 2012, 06:52 PM
Registered User
Joined Jan 2011
1,062 Posts
Yea the tail was centered when I set it up. It's belted so the tail boom couldn't have slipped much as my belt tension is still good (checked it yesterday). I have got in the habit of checking every single screw/part after each flight with this bird. Tail servo is tight as I checked that also. Still doesn't make a lot of sense to me. It has no problems doing a piro left or right in a hover, so don't think it should struggle too much in a simple turn. I call it FFF but honestly was not flying very fast just because of the problems from the day prior. I could be wrong though. I'll get it corrected and do another flight tomorrow to see if it's fixed.Honestly I guess I should just be happy I've had 3 actual flights now without the heli ending up in pieces . Still haven't flipped into idle up yet. After I see if my problem is sorted tomorrow, if it is i'll give idle up a shot and perhaps give it it's first inverted hover. In other news, while I was charging the 500 batt yesterday decided to fly the mcpx in the front yard. That thing is one reliable heli. If it wasn't for the tail hold not being very good it would be awesome. I've been contemplating a blade 130x to play around with as it should have cheap parts and it doesn't have a tail motor.I'm just super paranoid with the 500 after all the issues I've had with it over the last several months. Really don't wanna crash and restart months of issues getting it to fly. My x50e is still looking pretty sitting in the top of closet with no battery, esc , or motor.
stingeragents is offline Find More Posts by stingeragents
Reply With Quote
Old Jul 19, 2012, 07:08 PM
Just fly
evltoy's Avatar
Australia, VIC, Glen Waverley
Joined Jan 2011
2,103 Posts
stingeragents- with the tail facing you, hold the tail fin and swing it full left & full right. You should see the slider go full right and full left. I think you will find the deflection to one side will not go all the way. Adjust the gyro limits to makse sure they are set right. Once this is done then use the sticks on the TX to adjust end points for user input (speed of piros).
evltoy is offline Find More Posts by evltoy
Reply With Quote
Old Jul 19, 2012, 07:14 PM
Just fly
evltoy's Avatar
Australia, VIC, Glen Waverley
Joined Jan 2011
2,103 Posts
Quote:
Originally Posted by mhills51 View Post
I have never used silicon spray on a belt something about lubricating a cogged belt or any belt
Been using silicon sprays on all my belted heli since day one with no issues of slipping. If you get any kind of slipping its more likely it would be a tension or worn belt problem.

The silicon spray only protects the belt from cracking from drying up.
evltoy is offline Find More Posts by evltoy
Reply With Quote
Old Jul 19, 2012, 07:32 PM
Registered User
wlee1017's Avatar
Joined Jul 2011
1,389 Posts
i used silicone spray on my belts for years and no issue at all.
wlee1017 is offline Find More Posts by wlee1017
Reply With Quote
Old Jul 19, 2012, 07:43 PM
Registered User
Joined Jan 2011
1,062 Posts
I've never used silicone spray on a belt and never had an issue with static or belt cracking or anything. That is on about 6 different belted helis. Eco8, trex 450se, mini titan, raptor 30,exi 500, hk500,
stingeragents is offline Find More Posts by stingeragents
Reply With Quote
Old Jul 19, 2012, 09:44 PM
AMA# 548800
jombo's Avatar
United States, CT, Trumbull
Joined Dec 2007
5,205 Posts
Me too . i always spray my belts once a week if they need it or not . my basement is very dry , i already had my monster truck tires go bad after a few years .
jombo is offline Find More Posts by jombo
Reply With Quote
Old Jul 19, 2012, 11:48 PM
Registered User
Wisconsin
Joined Aug 2005
117 Posts
So far I'm pleased with this heli! The only thing that really bugs me is the play in the main rotor housing, it doesn't clamp tight to the main shaft. I'm thinking about trying to squeeze it in a vice when I get home tomorrow. Here are a couple of photos.
91awdTalon is offline Find More Posts by 91awdTalon
Reply With Quote
Old Jul 19, 2012, 11:56 PM
Registered User
mhills51's Avatar
kansas city
Joined Feb 2007
12,743 Posts
Just make sure the silicone contains no petroleum distillates. It will shorten you belt life and cause cracking.
mhills51 is online now Find More Posts by mhills51
RCG Plus Member
Old Jul 20, 2012, 12:00 AM
Registered User
mhills51's Avatar
kansas city
Joined Feb 2007
12,743 Posts
Quote:
Originally Posted by 91awdTalon View Post
So far I'm pleased with this heli! The only thing that really bugs me is the play in the main rotor housing, it doesn't clamp tight to the main shaft. I'm thinking about trying to squeeze it in a vice when I get home tomorrow. Here are a couple of photos.
You may have gotten a bad head. It happens. I spent a year trying to track down a wobble and found out all along it was the head it's self. I think one other person on here had the same problem. If it is you could go cheap and just get a new HK one because it seems to be a hit and miss and not most of them.
mhills51 is online now Find More Posts by mhills51
RCG Plus Member
Old Jul 20, 2012, 12:15 AM
Registered User
Wisconsin
Joined Aug 2005
117 Posts
Quote:
Originally Posted by mhills51 View Post
You may have gotten a bad head. It happens. I spent a year trying to track down a wobble and found out all along it was the head it's self. I think one other person on here had the same problem. If it is you could go cheap and just get a new HK one because it seems to be a hit and miss and not most of them.
If clamping it doesn't work I might put some retaining compound inside the shaft for the time being (I read about someone doing this on their align model with the same problem). Thanks for the suggestion. I'm going to see if I can't get a tarot replacement. Anywho, I'll be sure to post more photos as I progress.

Edit: I went ahead and ordered a new rotor housing for 15 shipped.
91awdTalon is offline Find More Posts by 91awdTalon
Last edited by 91awdTalon; Jul 20, 2012 at 12:32 AM. Reason: update
Reply With Quote
Old Jul 20, 2012, 01:15 AM
Registered User
Joined Jan 2011
1,062 Posts
U go with tarot. I've found all the parts I got from them are superb. U shoulda just picked up their fbl head and the zyx. But then again that opens up a new set of things to tinker with
stingeragents is offline Find More Posts by stingeragents
Reply With Quote
Old Jul 20, 2012, 08:43 AM
Registered User
Wisconsin
Joined Aug 2005
117 Posts
Well I put the housing in the vice and squeezed it making it fit just fine. I'll just have to keep an eye on it. My plan was to fly this for a few months FB and later this fall I would pick up the copter x fbl gyro/head. My wife is taking the kids out of town this weekend so I should hopefully have enough free time to get this thing going. Good times!
91awdTalon is offline Find More Posts by 91awdTalon
Reply With Quote
Old Jul 20, 2012, 09:20 AM
Registered User
Joined Apr 2012
26 Posts
Quote:
Originally Posted by 91awdTalon View Post
So far I'm pleased with this heli! The only thing that really bugs me is the play in the main rotor housing, it doesn't clamp tight to the main shaft. I'm thinking about trying to squeeze it in a vice when I get home tomorrow. Here are a couple of photos.
Talon that canopy is beautiful! May I ask where you bought it?
breault is offline Find More Posts by breault
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
I got some Fan Fold what to build thread part II started by emoone!!! Don Sims Foamies (Kits) 188 Jan 23, 2010 09:28 PM
Mountain Models Tantrum Partial Build Thread.. Tram Parkflyers 142 Apr 03, 2004 11:41 PM
My Bobolink Build Thread (very Colibri like) Jim Poor Hand Launch 65 Dec 10, 2003 05:48 PM
Laird Super Solution Build Thread! boomerace Parkflyers 178 Oct 29, 2003 08:20 PM
Switchback re-build thread (or What the $#*& was that!) Biggles604 Parkflyers 17 Jun 23, 2003 10:34 PM