HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Dec 23, 2013, 10:11 PM
Registered User
United States, TX, Jacksonville
Joined Apr 2012
14 Posts
Help!
Problem with my Hubson x4

I have a new hubson x4 h107L quad, i removed the props to install the guard and then reinstall the props is there right places, a-a-and b-b. Now for some unknown reason it will not take off, its like the motors have been reversed, I have a lot of air on top and very little air under the quad. WHAT IN THE WOLD HAVE I DONE NOW. Hope someone can answer my help question. Any ideas
Airhelo is offline Find More Posts by Airhelo
Reply With Quote
Sign up now
to remove ads between posts
Old Dec 24, 2013, 02:35 AM
⤤ ⤳ ⤴ ⇲
Joined Aug 2008
1,044 Posts
It still sounds like you have the props in the wrong places, are you sure the A's and B's are on the correct diagonals?
Looking at it from the top with the front facing away, the B's are on left front and rear right....

Name: Screenshot.png
Views: 10
Size: 30.8 KB
Description:

If you want the lighter colour props on the front, just swap each diagonal.
mono is offline Find More Posts by mono
Reply With Quote
Old Dec 24, 2013, 08:20 AM
Registered User
United States, TX, Jacksonville
Joined Apr 2012
14 Posts
Yes I have the props in the right places, A's are on the A and the B's are on the B location
Airhelo is offline Find More Posts by Airhelo
Reply With Quote
Old Dec 24, 2013, 08:29 AM
Registered User
United States, TX, Jacksonville
Joined Apr 2012
14 Posts
You are a smart person, I had the a's and b's wrong, I had the white on front and black on back but did not notice the A's on one side and B's on the other side.
Thank you very much, and have a very Merry Christmas
Airhelo is offline Find More Posts by Airhelo
Reply With Quote
Old Dec 24, 2013, 09:46 AM
⤤ ⤳ ⤴ ⇲
Joined Aug 2008
1,044 Posts
You are most welcome.
I'm pleased it helped to solve the problem.
mono is offline Find More Posts by mono
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question Blade Nano QX or Hubson x4 rb81690 Micro Helis 20 Jan 30, 2014 05:05 PM
Help! Looking to upgrade my 5.8ghz system, any advice? EDIT-possible problem with tx? rudyauction509 FPV Equipment 25 Dec 04, 2013 06:04 PM
Discussion My hubson x4 can't stand still whatsoever FlyingPancake Multirotor Talk 4 Aug 14, 2013 04:56 AM
Help! problem with my hubsan X4 - Any help at all would be appreciated rctech96 Mini Multirotors 6 Feb 21, 2013 06:32 PM