SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Oct 25, 2011, 11:56 AM
Registered User
United Kingdom
Joined Nov 2008
2,004 Posts
Quote:
Originally Posted by jaccies View Post
oops 10 glitches you mean after powering up
if it happens again what i dont hope ( dont like glitches ) i will report the raw values.
so my raw values are normal around 849 to 887?
errmm maybe not a glitch if 10 times in a row

Next time it happens, take down the numbers and note if the readings change with movement.

Yes, those numbers are fine.

<edit> I think you *may* have a bad connection on one of your gyros .....
Mike Barton is offline Find More Posts by Mike Barton
Last edited by Mike Barton; Oct 25, 2011 at 01:24 PM.
Reply With Quote
Sign up now
to remove ads between posts
Old Oct 25, 2011, 12:58 PM
Plane Destroyer / Life Enjoyer
airbagit13's Avatar
Miami, FL
Joined May 2009
3,500 Posts
Hey guys, I no longer have my KK boards so for sale I have the
5V Serial LCD Module:http://www.multircshop.com/site/inde...product_id=593 and the
Pololu USB AVR Programmer: http://www.multircshop.com/site/inde...product_id=595

I am looking for either $25 shipped for each or both for $45 shipped.

Thank you!
airbagit13 is online now Find More Posts by airbagit13
Last edited by airbagit13; Oct 25, 2011 at 01:24 PM.
Reply With Quote
Old Oct 25, 2011, 01:10 PM
Hovership
3rdeyepro's Avatar
United States, CA, Cupertino
Joined Aug 2010
1,008 Posts
Is there a mixer for a quad v-tail or Y6 v-tail?
3rdeyepro is online now Find More Posts by 3rdeyepro
Reply With Quote
Old Oct 26, 2011, 02:23 AM
Enjoying the sunshine
HappySundays's Avatar
Australia, NSW, Sydney
Joined Feb 2011
2,952 Posts
MultiWii GUI interface for the KK Plus board and NeXtcopter software

Hello,

Here's something new for the KK Plus that I am working on.
For full details, look in the NeXtcopter thread in this post.

MultiWii GUI for KK Plus board (0 min 58 sec)
HappySundays is online now Find More Posts by HappySundays
Reply With Quote
Old Oct 26, 2011, 04:42 AM
Registered User
The Netherlands, LI, Venray
Joined Dec 2008
1,395 Posts
Quote:
Originally Posted by Mike Barton View Post
errmm maybe not a glitch if 10 times in a row

Next time it happens, take down the numbers and note if the readings change with movement.
After powering up the board this morning the error showed up again.
checking the Gyro/diagnostics i had values:
Roll 849-0=849
Pitch 155-0=155
Yaw 887-0=887

when i move the copter raw values dont change!

When i had that error i did about 3 times powering up and got still that error,
after number 4 powering up error was gone.

I did not touch the board at all !

What could be wrong?
jaccies is offline Find More Posts by jaccies
Reply With Quote
Old Oct 26, 2011, 04:59 AM
Registered User
United Kingdom
Joined Nov 2008
2,004 Posts
Quote:
Originally Posted by jaccies View Post
After powering up the board this morning the error showed up again.
checking the Gyro/diagnostics i had values:
Roll 849-0=849
Pitch 155-0=155
Yaw 887-0=887

when i move the copter raw values dont change!

When i had that error i did about 3 times powering up and got still that error,
after number 4 powering up error was gone.

I did not touch the board at all !

What could be wrong?
ermm .. the Pitch value - it's too low !!!
They must be between 300 and 975.
Not sure why the values don't change tho'

Examine the Pitch gyro solder joints.
Check Pitch gyro voltage next time it happens....
Mike Barton is offline Find More Posts by Mike Barton
Reply With Quote
Old Oct 26, 2011, 05:34 AM
Registered User
The Netherlands, LI, Venray
Joined Dec 2008
1,395 Posts
Quote:
Originally Posted by Mike Barton View Post
ermm .. the Pitch value - it's too low !!!
They must be between 300 and 975.
Not sure why the values don't change tho'

Examine the Pitch gyro solder joints.
Check Pitch gyro voltage next time it happens....
I checked also gyro/diagnostics when i have no error at startup
i see now that pitch is varying when copter not moving
and is at stable level 465 -360=110 and the value 465 keeps varying between 430 till 470

copter wants to flip over backwards, and is very unstable

where should i measure pitch gyro voltage?


<edit> i seee now when i push on the board the value changes back to 886 , so it must be a solder joint or defective pitch gyro?
jaccies is offline Find More Posts by jaccies
Last edited by jaccies; Oct 26, 2011 at 05:49 AM.
Reply With Quote
Old Oct 26, 2011, 06:04 AM
Registered User
United Kingdom
Joined Nov 2008
2,004 Posts
Quote:
Originally Posted by jaccies View Post
I checked also gyro/diagnostics when i have no error at startup
i see now that pitch is varying when copter not moving
and is at stable level 465 -360=110 and the value 465 keeps varying between 430 till 470

copter wants to flip over backwards

where should i measure pitch gyro voltage?


<edit> i seee now when i push on the board the value changes back to 886 , so it must be a solder joint or defective pitch gyro?
Those numbers: 465 - 360 = 110 are not good.

The zero point is suspiciously low.
You can re-do the Gyro Calibration (when dis-armed!) by putting Collective Stick high. This will re-set the Zero point numbers
When still, the nett output (right-hand number should be max +/-2 !

To measure the Pitch Gyro voltages, I have attached one of Dans pictures with Roll & Pitch gyros indicated.

Vin's should be ~4.7V (this can vary by +/-0.2)
and Vout's should be ~ 1.38V (this can vary by +/-0.2)

Mike

ps: just seen your edit - yes, it could possibly be a bad solder joint ....
Mike Barton is offline Find More Posts by Mike Barton
Reply With Quote
Old Oct 26, 2011, 06:07 AM
Registered User
Cape Town, South Africa
Joined Jul 2008
25 Posts
Quote:
Originally Posted by dt8666 View Post
not sure if this will work. I assume you have the TX and RX line with Ground. you have to know which com port it is in.

try with your FTDI RX pin to TX of KK Plus, TX to RX and ground to ground. page 1 do have the 10 pin layout.

with the known com port, you also can follow the info at pg 1 to do step by step to get to the flashing.
Do you need power to the 5.5e board to flash to quadx.. I have only 3 wires connected like in vid but via FTDI cable ..

when I open port I get "successful" but when I plug in the cable I get "Please check the connection and Power"

I have also tried to swap rx and tx as there's conflicting posts on this thread but still get same message either way around
CX2X3 is offline Find More Posts by CX2X3
Reply With Quote
Old Oct 26, 2011, 06:55 AM
Registered User
Joined Oct 2005
1,662 Posts
Quote:
Originally Posted by jaccies View Post
I checked also gyro/diagnostics when i have no error at startup
i see now that pitch is varying when copter not moving
and is at stable level 465 -360=110 and the value 465 keeps varying between 430 till 470

copter wants to flip over backwards, and is very unstable

where should i measure pitch gyro voltage?


<edit> i seee now when i push on the board the value changes back to 886 , so it must be a solder joint or defective pitch gyro?
Check the Vref, not sure you accidentally adjusted the Vref Pot.

the picture shows the Vref point that you can measure, it should read 1.63V (refer to lower right hand text in the picture)
dt8666 is offline Find More Posts by dt8666
Reply With Quote
Old Oct 26, 2011, 06:57 AM
Registered User
Joined Oct 2005
1,662 Posts
Quote:
Originally Posted by CX2X3 View Post
Do you need power to the 5.5e board to flash to quadx.. I have only 3 wires connected like in vid but via FTDI cable ..

when I open port I get "successful" but when I plug in the cable I get "Please check the connection and Power"

I have also tried to swap rx and tx as there's conflicting posts on this thread but still get same message either way around
Yes, you need to power the KK Plus after you open the serial port.

you can power it using your ESC cable connected to one of the motor pin.
dt8666 is offline Find More Posts by dt8666
Reply With Quote
Old Oct 26, 2011, 07:52 AM
Registered User
Cape Town, South Africa
Joined Jul 2008
25 Posts
Quote:
Originally Posted by dt8666 View Post
Yes, you need to power the KK Plus after you open the serial port.

you can power it using your ESC cable connected to one of the motor pin.
thanks so much for the quick reply.. that worked (I think) it completed the flash to Quadx from the pc .. but I cant get the LCD to display anything but garbage.. so I cant confirm

I have tried to change set the board rate from the flash tool.. and also the "timing" but only get some garbage characters when in "timing" mode, otherwise the display is always blank

I have also somehow managed to dim the lcd display..

what am I doing wrong here? :-)
CX2X3 is offline Find More Posts by CX2X3
Reply With Quote
Old Oct 26, 2011, 08:07 AM
Registered User
Joined Oct 2005
1,662 Posts
Quote:
Originally Posted by CX2X3 View Post
thanks so much for the quick reply.. that worked (I think) it completed the flash to Quadx from the pc .. but I cant get the LCD to display anything but garbage.. so I cant confirm

I have tried to change set the board rate from the flash tool.. and also the "timing" but only get some garbage characters when in "timing" mode, otherwise the display is always blank

I have also somehow managed to dim the lcd display..

what am I doing wrong here? :-)
Hi,
that might be the LCD timing adjust needed as you can get from the readme file.

Did you see 9600baud at power up of the LCD?
dt8666 is offline Find More Posts by dt8666
Reply With Quote
Old Oct 26, 2011, 08:15 AM
Registered User
Cape Town, South Africa
Joined Jul 2008
25 Posts
Quote:
Originally Posted by dt8666 View Post
Hi,
that might be the LCD timing adjust needed as you can get from the readme file.

Did you see 9600baud at power up of the LCD?
no the lcd shows nothing on power up.. and only garbage if i start moving up or down in the timing mode
CX2X3 is offline Find More Posts by CX2X3
Reply With Quote
Old Oct 26, 2011, 08:26 AM
Registered User
Joined Oct 2005
1,662 Posts
CX, at power up, it should display the baud rate for a second. if not, i am not sure if your LCD is ok or not.
dt8666 is offline Find More Posts by dt8666
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Sold KK Multicopter Core Board V5.5 Quadcopter and firmware loader $95 Shipped terriwang Aircraft - Electric - Multirotor (FS/W) 20 Jun 05, 2011 11:34 PM
Discussion NEW KK Multicopter Core Board V5.5 Quadcopter and firmware loader terriwang Multirotor Talk 0 May 22, 2011 09:14 PM
Gallery KK Multicopter multicontroller v5.5,330 and MK sean520 Multirotor Talk 3 Apr 03, 2011 09:47 PM
Discussion Wanted -- KK Multicopter controller // XX Controller Chris Moon Multirotor Talk 0 Feb 07, 2011 10:21 AM