HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Oct 10, 2014, 11:10 AM
Registered User
Oldgazer's Avatar
United States, VA, Richmond
Joined Dec 2013
629 Posts
Question
Mini K Bar: Chasing my tail?

I'm running a Mini V Bar in a semi-scale Hughes 500 Little Bird 450 with a 5 blade head and 4 blade tail.

I can hover, but the tail "wags" slowly. This does not appear to be the typical high speed wag caused by the tail gain being too high, it's almost like the gain to too low.

The real problem I have is I cannot determine if my gear channel is actually causing a change in the gain setting. I have Tarot S and S2 gyros, and a "standard" HH gyro, and all three have a visual indication to tell you when you switch from Rate to HH modes. The K Bar just has a single power LED...

I've tried various things, like mixing a knob to the gyro gain, using the internal "Gyro Sense" function, and nothing seems to make any difference. The tail wags at the same rate..

So my question is, what must I do to be 100% certain that my radio (A FlySky TH9x) is actually controlling tail gyro gain?
Oldgazer is offline Find More Posts by Oldgazer
Reply With Quote
Sign up now
to remove ads between posts
Old Oct 10, 2014, 01:06 PM
Ground Repeller
Singapore
Joined Jun 2014
344 Posts
Can you adjust the gain in flight? If you can, put one real high and one at your current, flip the switch in flight and see if it makes any difference. Your gain is determined by alot of factors, including the servo in use - I have to set my gain at 110 to get the tail to stop wagging like yours, while a friend can get his stable at 70 (same heli different electronics).
ZeniethLily is offline Find More Posts by ZeniethLily
Reply With Quote
Old Oct 10, 2014, 05:18 PM
Where's the swimming pool
spykez's Avatar
Joined Jul 2011
987 Posts
Plug your gyro into your computer, run the client.

While it is active, check what it's reading on the gyro on the client's main screen. Change the gain/flip the switch on the radio and see what the gyro reads.

Naturally take precautions you don't spool your heli.

Basically, look and see what the vbar is actually doing with your gain channel. I usually use it to bankswitch, so that may be happening, or maybe you've set the vbar to take the gain from the programming (ie do nothing with the gear/gain channel).
spykez is offline Find More Posts by spykez
Reply With Quote
Old Oct 11, 2014, 02:03 AM
Grumpy old git.. Who me?
JetPlaneFlyer's Avatar
Aberdeen
Joined Mar 2006
11,764 Posts
+on spykez comment,
The easiest way is to connect up the Vstabi software then you should see the gain slider move up and down as you adjust the gain on the tx.
JetPlaneFlyer is online now Find More Posts by JetPlaneFlyer
Reply With Quote
Old Oct 11, 2014, 09:47 AM
Ground Repeller
Singapore
Joined Jun 2014
344 Posts
I found the tail wagging problem for mine, the tail linkage was set too close to the center. Changed out the horn for a bigger one and redid the maximum travel for my tail, and everything seems fine now.
ZeniethLily is offline Find More Posts by ZeniethLily
Reply With Quote
Old Oct 16, 2014, 02:24 PM
Registered User
Joined Aug 2013
13 Posts
I am very interested to know how you resloved this issue.

I am having the very same problem with mini K-bar (the one with the yellow transperant case). I have set very high and very low gain values, and it doesn't really make any significant difference. I have set high and low values through the VStabi programme, and the result is the same. The gyro seems to ignore the gain value, or makes a very little difference.

Also, i don't seem able to change from ΗΗ to rate and vice versa with the tx. I need to enter the programme and choose mode from there. The behaviour is as described above, slowly tail moves left-right, the heli is not easy controlable, and the situation gets worse if i try anything else than hover. Say if i move to the right, the heli becomes too undstable, to the point that is can turn 90 to 180 dgs on its own. I have double checked everything, can't find the cause. What troubles me the most is that it seems to ignore all the gain values.

Also tryed to use the outer hole on the servo horn, it did nothing.
FerDeLance is offline Find More Posts by FerDeLance
Reply With Quote
Old Oct 16, 2014, 04:19 PM
Registered User
mchopper's Avatar
Joined Mar 2014
48 Posts
setting the gain in vstabi only works if you have selected the bank switching option
Name: ImageUploadedByTapatalk1413494127.661391.jpg
Views: 10
Size: 146.2 KB
Description:

your transmitter gain channel does nothing when this is selected in the software

if you want to adjust the giro gain from your transmitter it need to be set to this

Name: ImageUploadedByTapatalk1413494261.961074.jpg
Views: 10
Size: 142.2 KB
Description:

if you have this set adjusting the giro gain in vstabi does nothing as it reverts to the transmitter gain
mchopper is online now Find More Posts by mchopper
Reply With Quote
Old Oct 16, 2014, 04:19 PM
Registered User
Oldgazer's Avatar
United States, VA, Richmond
Joined Dec 2013
629 Posts
Quote:
Originally Posted by FerDeLance View Post
I am very interested to know how you resloved this issue.

I am having the very same problem with mini K-bar (the one with the yellow transperant case). I have set very high and very low gain values, and it doesn't really make any significant difference. I have set high and low values through the VStabi programme, and the result is the same. The gyro seems to ignore the gain value, or makes a very little difference.

Also, i don't seem able to change from ΗΗ to rate and vice versa with the tx. I need to enter the programme and choose mode from there. The behaviour is as described above, slowly tail moves left-right, the heli is not easy controlable, and the situation gets worse if i try anything else than hover. Say if i move to the right, the heli becomes too undstable, to the point that is can turn 90 to 180 dgs on its own. I have double checked everything, can't find the cause. What troubles me the most is that it seems to ignore all the gain values.

Also tryed to use the outer hole on the servo horn, it did nothing.
Spot on! I've been messing with this POS for weeks, and I'm done. I've tried every switch setting, channel mixing (pot to gear etc), and software configuration imaginable, and this gyro will not hold the tail steady. Period, end of story.

What amazes me is I have a ZYX S, and it is freakin' awesome. Setup is a snap, and the tail is steady as a rock. Also, with the ZYX I get an LED indication when I switch from Rate to HH, but this POS K Bar does nothing,

As a final test, I set the Gear switch up to control gain. and then I used the radio GyroSense function to change the values in VStabi. For Downrate (Rate Mode), I set the gain to 0, and for Uprate (HH) I set it to max, and guess what? No matter which setting U used, The tail still wagged.

I'm going back to Tarot. Their gyros work.
Oldgazer is offline Find More Posts by Oldgazer
Reply With Quote
Old Oct 16, 2014, 04:41 PM
Registered User
Oldgazer's Avatar
United States, VA, Richmond
Joined Dec 2013
629 Posts
Quote:
Originally Posted by mchopper View Post
setting the gain in vstabi only works if you have selected the bank switching option
Attachment 7196314

your transmitter gain channel does nothing when this is selected in the software

if you want to adjust the giro gain from your transmitter it need to be set to this

Attachment 7196321

if you have this set adjusting the giro gain in vstabi does nothing as it reverts to the transmitter gain
BTDT, it still didn't work...

And just so you know, I tried using Bank switching so I could set the gain via the TX for testing, and when I found good gain settings I wanted to transfer them to the gain slider in the assistant. According to the software this was working on the bench, and I made sure I saved the config file before I powered down.

However, no mater which gain/switch/pot/bank configuration I used, the tail behavior NEVER CHANGED.

There are only two conclusions I can draw from this:

1. The gyro was crap out of the box
2. Mikado is fighting back.

As it stands now the point is mote. I'm going back to Tarot.
Oldgazer is offline Find More Posts by Oldgazer
Reply With Quote
Old Oct 16, 2014, 05:36 PM
Where's the swimming pool
spykez's Avatar
Joined Jul 2011
987 Posts
Hmm... . Sorry to hear your woes. Did your tarot FBL fly this exact mechanical setup previously without issue? If it did, then yea, change it back - if you have a solution that worked before.

But here's one or two other things you might want to try while the vbar is on your heli still.

- Firstly, unlikely as this may sound, it's worth checking. Radio. Are the pots on your rudder ok? Check on the radio channel output viewer or vstabi control panel tail channel - live - if your tail signal is oscillating or randomly going up and down even when sticks not moving.

- As ZenithLily says, if you think because the gain is too low despite maxing out gains electronically, bump up the mechanical throw on the tail servo linkage. But if your prior gyro worked on this same setup before, this generally should not be the issue I would think.

- 5 blades on main rotor, 4 on tail. Have you got enough tail RPM? I don't know any way to decide, I'm a boring bog standard build on all my helis. You could try less pitch or a tail speedup. Or maybe just more mechanical throw on the tail servo.

Just random ideas ...
spykez is offline Find More Posts by spykez
Reply With Quote
Old Oct 16, 2014, 09:41 PM
Registered User
Oldgazer's Avatar
United States, VA, Richmond
Joined Dec 2013
629 Posts
Quote:
Originally Posted by spykez View Post
Hmm... . Sorry to hear your woes. Did your tarot FBL fly this exact mechanical setup previously without issue? If it did, then yea, change it back - if you have a solution that worked before.
Yes. This heli flew fine with a ZYX S. I wanted to convert a 2nd heli to FBL and to save some money I snagged a K Bar.

In the hopes that the K Bar would be a better "fit" and would provide some additional diagnostic functionality I put the K Bar into my Hughes and put the ZYX into my new conversion, and that's when the fun started.
Oldgazer is offline Find More Posts by Oldgazer
Reply With Quote
Old Oct 16, 2014, 10:21 PM
Grumpy old git.. Who me?
JetPlaneFlyer's Avatar
Aberdeen
Joined Mar 2006
11,764 Posts
Shame you cant get it to work. take it from me that it's not an inherant fault that's common to all Kbars because I've used three and they all worked great. It's either a faulty unit (always a possibility with clones) or something about your set-up.

Just out of curiosity... when you connected the software could you see the gain slider moving when you adjusted gain on the tx?

FWIW.. here's my 7HV fitted with a Kbar hovering 'hands off'... rock solid:
Compass 7HV hovering 'hands-off' (0 min 16 sec)


Same heli in normal sports aerobatic flight with Kbar:
Compass 7HV Ultimate with Kbar (8 min 5 sec)


A number of other flyers have commented on just how solid the tail hold is on my Kbar equipped helis.
JetPlaneFlyer is online now Find More Posts by JetPlaneFlyer
Reply With Quote
Old Oct 17, 2014, 06:57 AM
Registered User
Paderborn DE
Joined Oct 2004
1,151 Posts
Funny, as reported hundreds of people using these with 100% success.

Not teaching you to suck eggs but which channel are you adjusting?? It has to be channel 5 'tied' to your Gyro switch. Go back to page 3 of the set-up menu (Transmitter adjustments) and check that your switch is moving the Aux/ Gyro gain/ Bank switch bar.

Also, as reported by Mchopper, you can only adjust the gain from the transmitter IF you have Active Bank Selection set to Aux->Gyro Gain on the main page.

Finally, the Kbar only looks at ONE end point to set the gain value, increasing or reducing BOTH end points will just screw stuff up. Once you are sure that you have channel 5 working set the end points using the Transmitter adjustment tab and then power up the gyro. With the switch in one direction you will be able to see the gyro working real hard when you swing the model's nose. Switched the other way effectively switches the Gyro off. You then know which end point to reduce to get the desired effect.

Good luck,

Paul
PaulB is offline Find More Posts by PaulB
Reply With Quote
Old Oct 17, 2014, 08:54 AM
Registered User
Joined Aug 2013
13 Posts
Quote:
Originally Posted by PaulB View Post

Also, as reported by Mchopper, you can only adjust the gain from the transmitter IF you have Active Bank Selection set to Aux->Gyro Gain on the main page.

Paul
This is actually the answer me and probably others have been looking for. I had no idea i should enable that option in the Active Bank Selection drop down menu. I haven't tryed it yet, it's too windy at the moment.
FerDeLance is offline Find More Posts by FerDeLance
Reply With Quote
Old Oct 17, 2014, 09:28 AM
Registered User
mhills51's Avatar
kansas city
Joined Feb 2007
12,494 Posts
OK I don't know if this is the same issue, but I had the same with my Futaba. With it set normally it seemed I could adjust the gain, but only by a little bit. I couldn't get it under 86% It ended up that I had to change my gyro setting to no gyro to get it to work right.
mhills51 is offline Find More Posts by mhills51
RCG Plus Member
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion K-BAR: Tweak Tail rotor Gain Oldgazer Electric Heli Talk 15 Sep 30, 2014 05:03 PM
Found Blue Koala Mini K-Bar Powerdyne Aircraft - Electric - Helis (FS/W) 1 Sep 16, 2014 09:51 PM
Sold FS - K-bar K8 mini 3 axis gyro - NIP ridge_racer Aircraft - Electric - Helis (FS/W) 1 Aug 06, 2013 10:24 PM
Still chasing my (Corona) tail william541 Electric Heli Talk 13 Jul 17, 2005 01:07 AM