HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Oct 19, 2012, 05:57 AM
Registered User
Joined Oct 2012
2 Posts
Discussion
x525 v3 setup

hi all
my name is ilan from israel.
i just finished my x525 v3 ( black board 5.5).
after callibraiting using info from rcgroup
the quad doe'snt react correctlly.
it turns to the left what ever i do and the motors are not
responding corectlly.
any ideas ????
thanks
eshchari is offline Find More Posts by eshchari
Reply With Quote
Sign up now
to remove ads between posts
Old Oct 19, 2012, 06:03 AM
Registered User
Joined Oct 2012
127 Posts
Calibrate the ESCs again
Adjust your trims on your radio (probably yaw)
Check solder connections between ESCs and motor
ElectroDie is offline Find More Posts by ElectroDie
Reply With Quote
Old Oct 19, 2012, 06:38 AM
Registered User
Woppit's Avatar
United Kingdom, Hastings
Joined Jul 2012
61 Posts
Quote:
Originally Posted by eshchari View Post
hi all
my name is ilan from israel.
i just finished my x525 v3 ( black board 5.5).
after callibraiting using info from rcgroup
the quad doe'snt react correctlly.
it turns to the left what ever i do and the motors are not
responding corectlly.
any ideas ????
thanks
Hi, I use the black board 5.5 FC running KK 4.7 X firmware, I have to reverse the yaw gyro on mine.
What firmware are you using, if it's 4.7 you will probably need to do it to.
Woppit is offline Find More Posts by Woppit
Reply With Quote
Old Oct 19, 2012, 09:20 AM
Registered User
Joined Oct 2012
2 Posts
well at the moment i found 2 of the outrunner free on the shaft so i have to tight it up unfortunatlly i don't have the alen size (it is very small) .
only after fixing it i shall check it all.
it took me 4 hours to understand why the motors are running but not on the correct speed.
ilan
eshchari is offline Find More Posts by eshchari
Reply With Quote
Old Oct 20, 2012, 12:52 AM
BUILD.FLY.CRASH.REPEAT.
p0st4L's Avatar
United States, CA, Santa Cruz
Joined Mar 2012
733 Posts
When I was running the KK 5.5 board, the 4.7 Firmware didn't work for me. I had to go down to 2.x for it to be able to fly right. but once at the lower version of firmware, it was just fine.
p0st4L is offline Find More Posts by p0st4L
RCG Plus Member
Reply With Quote
Old Oct 20, 2012, 01:52 AM
Registered User
Canada, AB, Calgary
Joined Sep 2012
51 Posts
Quote:
Originally Posted by eshchari View Post
well at the moment i found 2 of the outrunner free on the shaft so i have to tight it up unfortunatlly i don't have the alen size (it is very small) .
only after fixing it i shall check it all.
it took me 4 hours to understand why the motors are running but not on the correct speed.
ilan
What motors are you using to have this happen? I had 2 motors do the exact same thing, I tested it at home and was flying just fine, went to the field with a friend.... wanted to flip. Took a bit to figure out, but the same thing, the set screw loosened off! I just put the can back in place, and put some locktite in to help hold it, seems to be working..... for now! lol
The motors I were using were Turnigy 2822-1100 Kv. Have 16 of these (in different sizes) and never seen this yet????
hobiej is offline Find More Posts by hobiej
Reply With Quote
Old Oct 22, 2012, 06:15 AM
Registered User
flahut59's Avatar
France, Nord-Pas-de-Calais, Oignies
Joined Dec 2008
65 Posts
Hi all,
I bought on HK the x525 v3 frame (http://www.hobbyking.com/hobbyking/s...ame_600mm.html).
I wonder which motor is the best between these 2 brushless, I just want to fly longer.

http://www.bidproduct.com/part/Produ...MOTOR_278.html
http://www.bidproduct.com/part/Produ...MOTOR_277.html

Sorry for my english
Thank you for your precious help.
flahut59 is offline Find More Posts by flahut59
Reply With Quote
Old Oct 22, 2012, 09:04 AM
Registered User
France, Auvergne, Clermont-Ferrand
Joined Jul 2012
10 Posts
@flahut59 :
( <french mode> je suis français aussi (clermont-ferrand) , mais je vais répondre en anglais, on est sur rcgroups </french mode>)

To put on your X525 frame, here is my shopping list :
- rctimer 2826-13 1000kv (works great ! )
- Simonk 30A ESCs ( available on rctimer too)
- 2600mAh nanoTech lipos (hobbyking), (flight time : 10 minutes)

Bests,
Christophe.
dums2000 is offline Find More Posts by dums2000
Reply With Quote
Old Oct 22, 2012, 09:46 AM
Registered User
flahut59's Avatar
France, Nord-Pas-de-Calais, Oignies
Joined Dec 2008
65 Posts
Thanks a lot Christophe, but this one seems to be the same?
Right or wrong?
flahut59 is offline Find More Posts by flahut59
Reply With Quote
Old Oct 23, 2012, 03:02 AM
Registered User
France, Auvergne, Clermont-Ferrand
Joined Jul 2012
10 Posts
Not the same, your link show 2212-13 motors , rctimer are 2826-13. ( 28 is the diameter, 26 is the heigh), but according to specs, kv value and shaft diameter are equals.

I really recommand 1000kv and 28 as diameter to put on X525 frame.
dums2000 is offline Find More Posts by dums2000
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Sold X525 V3 QuadCopter bstussie Aircraft - Electric - Multirotor (FS/W) 4 Feb 24, 2012 12:34 PM
Discussion Introducing X525 V3 From CSL-Hobby CSLHobby Multirotor Talk 9 Feb 16, 2012 12:00 AM
Discussion X525 v3 build help please llVAPOURll Multirotor Talk 2 Jan 17, 2012 07:45 PM
Sold Foldable Quad copter X525 V3 frame bdpowers Aircraft - Electric - Multirotor (FS/W) 7 Sep 19, 2011 01:23 AM