SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Nov 23, 2012, 04:02 AM
Registered User
Joined Nov 2012
1 Posts
Discussion
Blade Nano Motor Cuts Out With HP6DSM Cyclic Inputs

I read the instructions for the Blade Nano CP X BNF I received yesterday and charged the batteries.

I also re-read the instructions for my HP6DSM Spektrum DSM2 transmitter (originally obtained with my Blade CP Pro RTF).

After following the instructions on page 7 of the English manual, the helicopter and transmitter seemed ready for the first flight.

I powered on the transmitter (set Throttle Hold to ON), connected the flight battery, and set the helicopter down to calibrate the 3-in-1 control unit.

The 3-in-1 control LED was solid, so I moved various transmitter cyclic controls and verified that they were functioning properly. I also moved the collective and verified that those controls were functioning properly.

Everything looked good, so I turned off Throttle hold and gradually increased the speed of the main rotor.
As I prepared to lift off, suddenly the main engine cut off (MECO) and the 3-in-1 control started blinking as it did during the binding process.

After a few tries I found that I had control of the flight motors when the LED was solid, but not when it was blinking. Also, the transmitter inputs that caused the MECO condition seemed to be cyclic inputs down and left.

After this happened, I turned throttle hold back on, then moved the cyclic controls around until the 3-in-1 controller LED was solid blue.

I found that power to the main engine had been restored, but any inputs to the left or down cyclic on the transmitter resulted in a MECO.

At first I thought it might be somehow Low Voltage Cut-off related (LVC) so I topped off the batteries and tested again.

Unfortunately, the helicopter cannot safely leave the ground until I have the ability to keep power to the main and tail rotors at all times.

The only thing that seemed related in the Troubleshooting Guide on page 11 of the English manual was an inverted loss of power in inverted flight but that is clearly not the issue here.

So how do I fix this condition?
HSoFW is offline Find More Posts by HSoFW
Reply With Quote
Sign up now
to remove ads between posts
Old Dec 07, 2012, 09:14 PM
AMA# SIMAGES
simages's Avatar
Hudson Valley
Joined Dec 2006
2,338 Posts
Did you ever fix your motor cut off problem? Believe it might be the binding......
simages is offline Find More Posts by simages
RCG Plus Member
Old Jan 01, 2013, 12:29 AM
Registered User
Joined Aug 2012
546 Posts
isnt that a 4 ch tx?
Greg Head is offline Find More Posts by Greg Head
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Motor cuts out at higher settings, what's up with that? vmikeb Electric Plane Talk 10 Jul 18, 2012 03:03 AM
Help! Motor cut out on heli - 450 size with Ice 50 JoeR Castle Creations 2 May 15, 2012 08:01 AM
Discussion Help with Blade-400 motor cut out problem RickAvery Beginner Training Area (Heli-Electric) 7 Oct 19, 2009 01:33 AM
My radio cut out when the motor cut out. What happened? Ralgh Power Systems 9 Mar 08, 2005 11:00 AM
pitch change with cyclic inputs, Why?? DSK Micro Helis 16 Feb 01, 2005 04:04 PM