New Products Flash Sale
Thread Tools
Old Nov 23, 2015, 12:50 PM
m_ghv_geo is offline
Find More Posts by m_ghv_geo
Registered User
Joined Nov 2015
9 Posts
electronics setup/troubleshooting no motor control

Hello all,
I am new to this hubby and need basic electronics setup/troubleshooting guidance.
I have
ZIPPY Compact 850mAh 2S 25C Lipo Pack(
Capacity: 850mAh
Voltage: 2S1P / 2 Cell / 7.4V
Discharge: 25C Constant / 35C Burst
Weight: 44g (including wire, plug & case)
Dimensions: 56x14x30mm
Balance Plug: JST-XH
Discharge Plug: JST
HobbyKing 12A BlueSeries Brushless Speed Controller(
Cont. Current: 12A
Burst Current: 16A/10sec
Battery: 2-4 Cell Lipo / 5-12 Cell Ni-XX
SBEC: 5V/ 1A Output
Size: 22*21*4mm
Weight: 10g
Hobby King 2.4Ghz 6Ch Tx & Rx V2 (Mode 2) (

hexTronik 24gram Brushless Outrunner 1300kv (
Kv: 1300rpm/v
Max Load:  7.5A
No Load Current: 0.7A
Suggested Lipo: 3 cell 11.1v
Thrust: 400g+
Suggested Prop: 8x3.8
Weight: 20g
I manged to bind the TX to RX servos are working, but the main motor is not doing anything.

When consulting manual it basically states to
1. Check connections. I did.
2. The battery pack voltage exceeds the acceptable range. Battery voltage printed is 7.4v. I checked with voltmeter it states 8.08v could this be the problem? Speed controller states 2-4 Cell Lipo. Mine is 2cell, but if it was 4cell it would been 14.8v.
3. Throttle stick is not at the lowest position. Lets just say I tried.
4. The ESC Throttle calibration has not set up. I tried to do by following this manual with no effect.
5. burnt motor coils. I bought new and it looks and smells okay.
m_ghv_geo is offline Find More Posts by m_ghv_geo
Reply With Quote
Sign up now
to remove ads between posts
Old Today, 06:15 PM
GMPheli is online now
Find More Posts by GMPheli
Registered User
United States, MA, West Bridgewater
Joined Mar 2002
302 Posts
Do you get any beeps from the motor when you plug in the battery?
GMPheli is online now Find More Posts by GMPheli
Reply With Quote

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion electronics setup/troubleshooting no motor control m_ghv_geo Beginner Training Area (Aircraft-Electric) 17 Yesterday 11:13 PM