HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Oct 11, 2012, 01:51 PM
Registered User
magrinsi's Avatar
Florence Italy
Joined Dec 2009
786 Posts
I have another problem with 106b.... i have turn on it using 16.5v (18v max according to instruction) and is burned... !!!
I want ask to Junsi why these Icharger 106b have problem with input over the 12v?
magrinsi is online now Find More Posts by magrinsi
Reply With Quote
Sign up now
to remove ads between posts
Old Oct 11, 2012, 02:30 PM
Registered User
So. Cal.
Joined Oct 2004
8,085 Posts
Did you verify the output voltage of your PS with a meter prior to plugging in your charger or are you simply quoting what is written on the power supply?
mrforsyth is online now Find More Posts by mrforsyth
RCG Plus Member
Reply With Quote
Old Oct 11, 2012, 02:47 PM
Registered User
magrinsi's Avatar
Florence Italy
Joined Dec 2009
786 Posts
Input from a 4s to 16,5v.....
magrinsi is online now Find More Posts by magrinsi
Reply With Quote
Old Oct 11, 2012, 03:22 PM
Registered User
So. Cal.
Joined Oct 2004
8,085 Posts
'nuff said.

Given that there is no purer DC source than a battery and your battery was well within the specified voltage limits of the charger, I would say that you have a very legitimate warranty claim (presuming polarity was correct).
mrforsyth is online now Find More Posts by mrforsyth
RCG Plus Member
Reply With Quote
Old Oct 11, 2012, 03:28 PM
Registered User
magrinsi's Avatar
Florence Italy
Joined Dec 2009
786 Posts
Polarity...correct to 100%.
I have read that anoter people has problem with icharger using the lipo....Junsi must declare it!
magrinsi is online now Find More Posts by magrinsi
Reply With Quote
Old Oct 11, 2012, 08:57 PM
Registered User
seattlebuoy's Avatar
United States, AZ, Flagstaff
Joined Sep 2011
270 Posts
Just got my 306B. What a nice piece of kit and straight forward manual. Who would have thought I would get all enamored with a battery charger.

Got my feather merchant 24v supply on order, then will be all set for the shop. We've got a solar powered deep cycle 12V system at the field I can take advantage of. This will be really nice cutting the field charge time by 75% and at least doubling our flying time. Worth every penny of the setup cost.
seattlebuoy is online now Find More Posts by seattlebuoy
Reply With Quote
Old Oct 11, 2012, 10:21 PM
iCharger
junsi's Avatar
Joined Mar 2007
1,086 Posts
Quote:
Originally Posted by magrinsi View Post
I have another problem with 106b.... i have turn on it using 16.5v (18v max according to instruction) and is burned... !!!
I want ask to Junsi why these Icharger 106b have problem with input over the 12v?
We are sorry to cause you this trouble, we have replied you via Email for more details, please check it.

Junsi
junsi is offline Find More Posts by junsi
Reply With Quote
Old Oct 13, 2012, 01:38 AM
Registered User
United States, CA, Palos Verdes Peninsula
Joined Dec 2011
1,031 Posts
Anyone know what to do when a 3010B does what's shown in the video? I ruled out the power supply as being the problem - checked the output with a voltmeter (was 24v) and also hooked up the 3010B to a different power supply (same result).

iCharger 3010B Malfunction (0 min 36 sec)
Jboy90277 is offline Find More Posts by Jboy90277
Reply With Quote
Old Oct 13, 2012, 07:48 AM
Registered User
Joined Apr 2012
7 Posts
Hi guys,

my (real/big) car battery died, and I would like to re-charge it using Icharger 206B.

I know the icharger is capable of this (I will set it to 6S/12V), but I dont have a connector for the PB battery.

The only way I could connect the battery is this:

ICharger -> ParaBoard -> Deans Cable with alligator clips on the end -> PB battery.

Please see the attached screenshot.

My only question is, is it safe to charge the battery like this?

Thanks a lot,
Marek
Marek8 is offline Find More Posts by Marek8
Reply With Quote
Old Oct 13, 2012, 10:34 AM
Southern Pride
everydayflyer's Avatar
Haralson County GA. USA
Joined Oct 2004
34,760 Posts
Yes that will be fine. I would suggest a charge rate of 5A not knowing the Ah capacity or max. charge rate you battery can take.
everydayflyer is online now Find More Posts by everydayflyer
Reply With Quote
Old Oct 13, 2012, 11:04 AM
Registered User
Joined Apr 2012
7 Posts
thanks. i have set the mode to Pb and current to 7.5A & the termination voltage to 2.45V per cell, but the battery reached the end voltage only after a couple of minutes of charging, which is weird... It took only about 1000mah , so i guess the battery is dead... ?
Marek8 is offline Find More Posts by Marek8
Reply With Quote
Old Oct 13, 2012, 12:17 PM
RC Helicopter Pilot
TheWoodCrafter's Avatar
United States, CA, Westminster
Joined Mar 2010
1,696 Posts
Quote:
Originally Posted by Jboy90277 View Post
Anyone know what to do when a 3010B does what's shown in the video? I ruled out the power supply as being the problem - checked the output with a voltmeter (was 24v) and also hooked up the 3010B to a different power supply (same result).
Looks like time to send it off for repair or time to buy a new one.
That doesn't look like firmware or a settings problem.
TheWoodCrafter is offline Find More Posts by TheWoodCrafter
Reply With Quote
Old Oct 13, 2012, 02:05 PM
Registered User
Joined May 2009
31 Posts
Overcharging LiPos

I have a new iCharger 106B+ and new 3s 1.3 nano-tech batteries. I have the Termination voltage set to 4.20. But on a balance charge (1.0A) the cell readings are reaching 4.28V and the voltages stay higher than 4.20V after charging is complete.

Have I got something set wrong? The iCharger readings match those of my multimeter.
chippypilot is offline Find More Posts by chippypilot
Reply With Quote
Old Oct 13, 2012, 02:21 PM
Registered User
The Netherlands, NH, Amsterdam
Joined Aug 2007
112 Posts
Hi,

I have a new 2s5000mah pack and a new 3s 5000mah pack with the same cells.
I want to charge these packs in series. Charger is a 3010b.

The packs are already connected in series. The 2s pack is the - and the 3s pack is the +.

Now which balance socket do I use for the 3s pack?
drkdgglr is offline Find More Posts by drkdgglr
Reply With Quote
Old Oct 13, 2012, 10:49 PM
BGR
Foam Junkie
United States, CA, Oceanside
Joined Dec 2003
1,656 Posts
Quote:
Originally Posted by chippypilot View Post
I have a new iCharger 106B+ and new 3s 1.3 nano-tech batteries. I have the Termination voltage set to 4.20. But on a balance charge (1.0A) the cell readings are reaching 4.28V and the voltages stay higher than 4.20V after charging is complete.

Have I got something set wrong? The iCharger readings match those of my multimeter.
I have exactly the same charger and the same batteries. Mine does not do that, there may be something wrong with that charger. I don't think you can do anything wrong except maybe charge in the wrong mode.
BGR is offline Find More Posts by BGR
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Best charger/discharger $ can buy namancio Batteries and Chargers 30 Jan 31, 2010 02:52 PM
Power Pacer Battery charger/discharger ACE_McCOOL Batteries and Chargers 4 Oct 22, 2002 12:39 PM
NIB Hitec CG-325 Charger/Discharger/Cycler for 4-9 cells - $39! Jason M Aircraft - Electric - Airplanes (FS/W) 0 Oct 03, 2002 03:29 AM
WTB Good charger/discharger 10 + cells WickedFunRC Aircraft - Electric - Airplanes (FS/W) 0 Sep 05, 2002 08:55 PM