HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Mar 15, 2011, 06:46 PM
UH-60 Blackhawk Mechanic
helifrek's Avatar
United States, TN, Clarksville
Joined Feb 2004
2,901 Posts
already threw a link! DOH! I should have put something on there to keep it from flying off I secured them with some of the wifes tiny hair rubber band things and some CA (see pics). this thing seems to get the shakes alot! I don't lose control or anything, it just starts shaking.... I have been flying for a long time but I am the type that "flies it like I borrowed it" (not stole...) so I don't get too fancy with my aerobatics. I can do inverted, rolls, loops no problem but that backwards flying and inverted backwards flying and stuff like that eludes me still but I am working on it. This little baby really gives you the confidence to let loose!
I have a DX7 and so far I am liking my settings, I don't fly in normal mode at all, only spooling up and then I hit the switch. My Normal throttle curve is per the manual but here are the settings I fly with.

EXPO-20% both ail and ele (I might increase this more but I get a pretty stable hover at 20%)
D/R-100% because for aerobatics you want alot of travel.
throttle curve 100-100-100-100-100 and I wish there was more but that little motor seems to get the job done pretty well.
Pitch curve 0 to 100 linear.
pitch travel 70%

and that does it for me. The motor is notchy, it's supposed to be (strong magnets). bout time to fly again!
helifrek is offline Find More Posts by helifrek
Reply With Quote
Sign up now
to remove ads between posts
Old Mar 15, 2011, 08:05 PM
UH-60 Blackhawk Mechanic
helifrek's Avatar
United States, TN, Clarksville
Joined Feb 2004
2,901 Posts
more flying!
helifrek is offline Find More Posts by helifrek
Reply With Quote
Old Mar 15, 2011, 09:39 PM
Registered User
Altamonte Springs, Fl.
Joined Nov 2010
43 Posts
Quote:
Originally Posted by stevebarrow View Post
Do you have the throttle set at 70-75% when the throttle stick is in the up (full) position?
Yes, I have it set right out of the manual.
taterb is online now Find More Posts by taterb
Reply With Quote
Old Mar 15, 2011, 09:45 PM
Registered User
Altamonte Springs, Fl.
Joined Nov 2010
43 Posts
Quote:
Originally Posted by ESylin View Post
How long are you flying before this starts happening?
I only get about 3 minutes of flight per charge. Which is of course the expected flight time. I'm just wondering if your breaching that time frame without noticing.
sometimes it happens on take off just after putting the (fully charged) battery in. Other times after I get in the air. I expect it if I start going for 3 min or so, but not so soon.
taterb is online now Find More Posts by taterb
Reply With Quote
Old Mar 15, 2011, 10:09 PM
Registered User
United States, AK, Ketchikan
Joined Mar 2008
1,377 Posts
Well crap! Just broke a ball link on the swash (the one the elevator servo connects), and it wasn't even a hard crash. I shut the motor down and landed on a blanket! I'm thinking maybe it was already weakened?? So I'm out for a week or so No LHS so I'll be making an order with Hobby Zone, but will stock up on spares. Just when I was slowly starting to experiment with some forward flight!
bdshort is offline Find More Posts by bdshort
Reply With Quote
Old Mar 15, 2011, 10:13 PM
Suspended Account
Prescott, AZ
Joined Jan 2011
2,380 Posts
Quote:
Originally Posted by bdshort View Post
Well crap! Just broke a ball link on the swash (the one the elevator servo connects), and it wasn't even a hard crash. I shut the motor down and landed on a blanket! I'm thinking maybe it was already weakened?? So I'm out for a week or so No LHS so I'll be making an order with Hobby Zone, but will stock up on spares. Just when I was slowly starting to experiment with some forward flight!
Don't feel bad. I did the same thing before I even got to fly my mSR. I was trying to pop a link off to mechanically level the swashplate, which came WAY off out of the box. Ball snapped right off with the link.
sviking is offline Find More Posts by sviking
Reply With Quote
Old Mar 15, 2011, 10:23 PM
Rocket Programmer
jasmine2501's Avatar
United States, AZ, Mesa
Joined Jul 2007
25,419 Posts
Quote:
Originally Posted by bdshort View Post
Well crap! Just broke a ball link on the swash (the one the elevator servo connects), and it wasn't even a hard crash. I shut the motor down and landed on a blanket! I'm thinking maybe it was already weakened?? So I'm out for a week or so No LHS so I'll be making an order with Hobby Zone, but will stock up on spares. Just when I was slowly starting to experiment with some forward flight!
Have you already used the two that come with it? They are in the same bag as the manual.
jasmine2501 is offline Find More Posts by jasmine2501
Reply With Quote
Old Mar 15, 2011, 10:25 PM
Suspended Account
Prescott, AZ
Joined Jan 2011
2,380 Posts
Quote:
Originally Posted by jasmine2501 View Post
Have you already used the two that come with it? They are in the same bag as the manual.
I think maybe he meant he broke a ball off the swashplate arm.
sviking is offline Find More Posts by sviking
Reply With Quote
Old Mar 15, 2011, 10:33 PM
Registered User
United States, AK, Ketchikan
Joined Mar 2008
1,377 Posts
Correct. I broke the ball on the swash assembly. I've also lost one link and broke another! :lol: Just ordered $60 worth of spares from HZ, including a pair of blade grips, another tail boom, and a few other parts.
bdshort is offline Find More Posts by bdshort
Reply With Quote
Old Mar 15, 2011, 10:48 PM
Rocket Programmer
jasmine2501's Avatar
United States, AZ, Mesa
Joined Jul 2007
25,419 Posts
Oh bummer... you can break a swash ball twice though too...
jasmine2501 is offline Find More Posts by jasmine2501
Reply With Quote
Old Mar 15, 2011, 11:00 PM
Registered User
United States, AK, Ketchikan
Joined Mar 2008
1,377 Posts
Quote:
Originally Posted by jasmine2501 View Post
Oh bummer... you can break a swash ball twice though too...
The one I broke is on the lower plate, the one the rear servo link connects to.
bdshort is offline Find More Posts by bdshort
Reply With Quote
Old Mar 15, 2011, 11:16 PM
Rocket Programmer
jasmine2501's Avatar
United States, AZ, Mesa
Joined Jul 2007
25,419 Posts
Oh crap... yeah you're hosed. Sorry... I don't think our shop even got swash plates, but they got some parts.
jasmine2501 is offline Find More Posts by jasmine2501
Reply With Quote
Old Mar 15, 2011, 11:20 PM
certified crash instructor
Scottsdale Arizona
Joined Dec 2009
2,215 Posts
Quote:
Originally Posted by bdshort View Post
The one I broke is on the lower plate, the one the rear servo link connects to.
I did that last night while I was trying to remove the link to make adjustments, ball snapped right off I was pretty hammered and still managed to ca it back to the swash and it's been working perfect, I've even made 3 more adjustments since then and it still works perfect, it's worth a try!
slo-fly is offline Find More Posts by slo-fly
Reply With Quote
Old Mar 15, 2011, 11:41 PM
Registered User
United States, AK, Ketchikan
Joined Mar 2008
1,377 Posts
Quote:
Originally Posted by slo-fly View Post
I did that last night while I was trying to remove the link to make adjustments, ball snapped right off I was pretty hammered and still managed to ca it back to the swash and it's been working perfect, I've even made 3 more adjustments since then and it still works perfect, it's worth a try!
I took a look. Waaaay to small. It might have been doable but I think it would have been very frustrating. I'll just wait.
bdshort is offline Find More Posts by bdshort
Reply With Quote
Old Mar 15, 2011, 11:43 PM
2 seconds from crashing
indoorheli's Avatar
United States, WA, Seattle
Joined Sep 2007
7,349 Posts
Quote:
Originally Posted by helifrek View Post
my issue so far, I haven't messed with anything yet but coming out of fff or after a roll or in little gusts of wind the head starts doing a weird shaking and stops if I pump the pitch real quick, anyone else have this problem?
I have the same issue not just in gust but any fast change in direction.
Z06 Tony said if you change Ele and Ail to 84% or lower it appears to stop this....i will try that in the morning as I left my heli at work.
indoorheli is offline Find More Posts by indoorheli
RCG Plus Member
Latest blog entry: FPV - DRQ250 and a little speed
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Blade mCP X BNF Heli... ChuckTseeker Micro Helis 15454 Oct 13, 2014 07:41 PM
Discussion Blade mCP X Discuss anything thread A Rdnek Micro Helis 457 Jul 26, 2011 11:34 PM
Discussion The New BLADE mCP X Has Arrived... ChuckTseeker Electric Heli Talk 38 Mar 27, 2011 07:35 PM
Discussion new blade mcp X anyone know anything new. epoweredrc Atlanta Area RC 6 Mar 16, 2011 08:14 PM
Discussion Blade mCP x - strictly on topic Q and A thread jdog83 Micro Helis 58 Feb 07, 2011 02:28 PM