HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Nov 13, 2012, 06:58 PM
Private Pilot
Twister773's Avatar
Joined Jul 2009
1,239 Posts
Mine had the yaw coupling issue without a camera mounted as well...BUT I finally got my level horizon even while yawing..."Radian"
Twister773 is offline Find More Posts by Twister773
Reply With Quote
Sign up now
to remove ads between posts
Old Nov 13, 2012, 09:54 PM
S11D336B's Avatar
USA, FL, Winter Springs
Joined Apr 2006
3,066 Posts
Check for binding in your pan axis. You may need to change the PID values for the yaw compensation to improve the behavior further. If you are still having an issue, fill out a support ticket here. http://hoverflytech.zendesk.com

Quote:
Originally Posted by darkovujasinovic View Post
I have setup yaw compensation and it works but I have a problem with very small movement as it has rapid stop ( like it is cutting ) but if I move it along the axes continiously it works well !
What should I work on to get rid of this issue ?
S11D336B is offline Find More Posts by S11D336B
Site Sponsor
Reply With Quote
Old Nov 14, 2012, 06:52 PM
Registered User
Bosnia
Joined Dec 2010
107 Posts
Quote:
Originally Posted by S11D336B View Post
Check for binding in your pan axis. You may need to change the PID values for the yaw compensation to improve the behavior further. If you are still having an issue, fill out a support ticket here. http://hoverflytech.zendesk.com
I do not have binding ( if you mean some kind of obstruction because of which yaw does not go smoothly ).
I am using av 130 with 360 , could you give me some rough idea about PID parameters as at the moment I have P8000, I 5000 and gain around 2

I tried changing all these values but with no success !
Thanks !
darkovujasinovic is offline Find More Posts by darkovujasinovic
Last edited by darkovujasinovic; Nov 14, 2012 at 07:13 PM.
Reply With Quote
Old Nov 15, 2012, 08:32 PM
Support yer local CharlieSheen
Joined May 2011
1,022 Posts
HFG diagnostic page

Hey now! I have one of Askmans AG550s I am running with a hoverfly. Ive been tweaking it for the past few days and slowly but surely I am getting all the bugs worked out. I have looked at the diagnostics screen a few times and all but once all the readouts are jumping wildly around. What causes this? Bad calibration? I have recalibrated 5 or 6 times and still I am getting some bouncy behavior from the gimbal. Some of it was from a loose pulley, and a loose nut that holds my potentiometer on the tilt but now that I have tacked all that down I am still getting bouncy gimbal. If I tun it off the video is smooth as silk so I no its not the copter. Also, if I am only using roll and tilt, is there any reason to calibrate the compass? Cheers!
isaacintheclouds is offline Find More Posts by isaacintheclouds
Reply With Quote
Old Nov 15, 2012, 08:36 PM
Registered User
jerrymeister's Avatar
Joined Oct 2011
482 Posts
Sounds like my experience. I am very close to where I want to be though

Jerry
jerrymeister is offline Find More Posts by jerrymeister
Reply With Quote
Old Nov 15, 2012, 09:40 PM
3D Heli and Planes
jbdww's Avatar
United States, TX, Round Rock
Joined Nov 2009
283 Posts
Quote:
Originally Posted by isaacintheclouds View Post
Hey now! I have one of Askmans AG550s I am running with a hoverfly. Ive been tweaking it for the past few days and slowly but surely I am getting all the bugs worked out. I have looked at the diagnostics screen a few times and all but once all the readouts are jumping wildly around. What causes this? Bad calibration? I have recalibrated 5 or 6 times and still I am getting some bouncy behavior from the gimbal. Some of it was from a loose pulley, and a loose nut that holds my potentiometer on the tilt but now that I have tacked all that down I am still getting bouncy gimbal. If I tun it off the video is smooth as silk so I no its not the copter. Also, if I am only using roll and tilt, is there any reason to calibrate the compass? Cheers!
I have the same exact product, and i have the same issue. I am so close, but I need to figure out the last bit. I am working on uploading a video to show.
jbdww is online now Find More Posts by jbdww
Reply With Quote
Old Nov 15, 2012, 09:48 PM
3D Heli and Planes
jbdww's Avatar
United States, TX, Round Rock
Joined Nov 2009
283 Posts
Here is my video. Ignore the horizon being off as that is my fault.
Over Looking the neighborhood. (6 min 18 sec)
jbdww is online now Find More Posts by jbdww
Reply With Quote
Old Nov 16, 2012, 05:16 PM
Registered User
jerrymeister's Avatar
Joined Oct 2011
482 Posts
That is pretty much what my video looks like and I am not sure if it can be improved. As your clip shows, it is steady much of the time and then every once in a while it jumps around. Not sure if we should just be satisfied, or something can be done to improve it. Thanks for sharing.

Jerry

Quote:
Originally Posted by jbdww View Post
Here is my video. Ignore the horizon being off as that is my fault.
https://vimeo.com/53648364
jerrymeister is offline Find More Posts by jerrymeister
Reply With Quote
Old Nov 19, 2012, 08:05 PM
3D Heli and Planes
jbdww's Avatar
United States, TX, Round Rock
Joined Nov 2009
283 Posts
I see that no one know what we are talking about on the jitter issues in our video.

What does the PID gains do?
Also is there a setting that tells the controller the frame rate speed of your servos?
jbdww is online now Find More Posts by jbdww
Reply With Quote
Old Nov 19, 2012, 10:04 PM
Registered User
jerrymeister's Avatar
Joined Oct 2011
482 Posts
I too would like to know the answers to these questions, so can someone please chime in??

Jerry

Quote:
Originally Posted by jbdww View Post
I see that no one know what we are talking about on the jitter issues in our video.

What does the PID gains do?
Also is there a setting that tells the controller the frame rate speed of your servos?
jerrymeister is offline Find More Posts by jerrymeister
Reply With Quote
Old Nov 19, 2012, 11:08 PM
S11D336B's Avatar
USA, FL, Winter Springs
Joined Apr 2006
3,066 Posts
It's very hard to tell you what is possible to get from your camera mount. The majority of motion you can see is normally related to either incorrectly set configuration or inadequacies of the camera mount.

In terms of what you can do to improve your mount... I'd look for backlash, and try adjusting the scaling factor and acceleration rate gain a bit more. It looks like you are very close. Balancing the camera on the mount may help as well.

The field of view of your lens is important as well. Too narrow and you will see every minor correction. I typically see 18 - 22mm lens being used.

The PID values for Yaw correction just affect how the controller responds and corrects for yaw movement. The PID values for continuous rotation servo mode allow you to adjust the repose of tilt/roll if you have continuous rotation servos without POTs. In general you shouldn't need to worry about these.

Quote:
Originally Posted by jbdww View Post
I see that no one know what we are talking about on the jitter issues in our video.

What does the PID gains do?
Also is there a setting that tells the controller the frame rate speed of your servos?
S11D336B is offline Find More Posts by S11D336B
Site Sponsor
Reply With Quote
Old Nov 20, 2012, 10:16 AM
3D Heli and Planes
jbdww's Avatar
United States, TX, Round Rock
Joined Nov 2009
283 Posts
We are using this gimbal.
http://tppacks.com/store/index.php?r...&product_id=55

A lot of guys are having lots of success with this gimbal. On my setup the belts are tight, I am using 6V to power the MKS BLS950 servos, the camera is well balanced on the gimbal. I am using the NEX5N with the 16mm Pancake lens that everyone else is using.

I changed the gains all the way down and I still get the jitters and you can see a huge lag in the movement. The scaling factor is dead on.

When I turn HFG off, the vido is solid smooth, so there is no vibrations from the props, and the gimbals vibration isolators are working great.

I am using V1.2 Rev2 with the latest firmware, so why is the PID gain button show up on the roll and pitch screens, and why does it seam like the graph is showing those access?
jbdww is online now Find More Posts by jbdww
Reply With Quote
Old Nov 20, 2012, 10:53 AM
Registered User
GGoodrum's Avatar
South Orange County, CA
Joined Mar 2003
8,113 Posts
I have one thing I think you need to try and that is to go back to v1.03 of the HFG board firmware. That's the only way I could stop the jitters and fix the yaw coupling issue. I've tried every version since v1.03, and they all have this same set of issues. They broke something, starting with v1.5, and can't seem to find out what. Until they do, I would definitely use v1.03.

The first video below is with v1.7r2. You can clearly see there's a horizon drift problem, and a pretty bad jitter/shake problem. It rolls left, slowly and after landing you can see it level back out. The jitter shows up in the roll axis the worst.

AG500 H3 2 Axis Gimbal Test 01 (6 min 21 sec)


In this second flight, the only change was to go back to v1.03. No horizon problem and no jitters.

AG500 H3 2 Axis Gimbal Test 02 (5 min 24 sec)


George here will tell you they can't duplicate this problem, but personally, I just don't think they are trying hard enough. For example, in another thread, he said that for all their test setups, the board is mounted vertically, and maybe the problem is related to the fact that for our setups, we mount it horizontally. He implied this is a design problem on our part. That is a total crock. Why do we have to make design changes to test their issues? Why can't they change their test setup, and just see if that is in fact a problem. This is just pure arrogance, in my opinion, and horrible customer support, at the very least.

-- Gary
GGoodrum is offline Find More Posts by GGoodrum
Reply With Quote
Old Nov 20, 2012, 03:39 PM
Support yer local CharlieSheen
Joined May 2011
1,022 Posts
"A lot of guys are having lots of success with this gimbal. On my setup the belts are tight, I am using 6V to power the MKS BLS950 servos, the camera is well balanced on the gimbal. I am using the NEX5N with the 16mm Pancake lens that everyone else is using.

I changed the gains all the way down and I still get the jitters and you can see a huge lag in the movement. The scaling factor is dead on.

When I turn HFG off, the vido is solid smooth, so there is no vibrations from the props, and the gimbals vibration isolators are working great."


I second that! I have done EXACTLY what is stated above with the AG550/HFG and where I am getting close I still have the dreaded jitters. After locating and addressing all the bugs with the gimbal itself, wrapping the servos, servo wires, Vtx and Vtx power wire and the HFG board itself with copper tape and flying with and without the HFG powered up I feel I have narrowed it down to the HFG. (I made sure to keep any copper tape from being able to touch the HFG board).

THANK YOU GARY for this video on the difference of performance between versions of HFG software. That is where I will go next! cheers!

(PS, how do I find v1.03?)
isaacintheclouds is offline Find More Posts by isaacintheclouds
Last edited by isaacintheclouds; Nov 20, 2012 at 03:52 PM.
Reply With Quote
Old Nov 20, 2012, 03:59 PM
Registered User
GGoodrum's Avatar
South Orange County, CA
Joined Mar 2003
8,113 Posts
Quote:
Originally Posted by isaacintheclouds View Post
(PS, how do I find v1.03?)
Go here and install the firmware update client. Run it, let it connect to the board and then select the HF Gimbal board. When you get to the flash screen, one of the firmware options will be v1.03.

-- Gary
GGoodrum is offline Find More Posts by GGoodrum
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion DJI Wookong-M Owners Thread *Pics*Videos*Settings* Z06 Tony Multirotor Talk 1780 Sep 03, 2014 08:28 AM
Discussion HoverflyGIMBAL Demonstration Videos photronix Hoverfly Technologies 10 May 18, 2012 03:53 PM
Link HoverflyGIMBAL Manual and Setup Client hoverben Hoverfly Technologies 1 May 17, 2012 02:25 PM
Discussion HoverflyGIMBAL - Input Voltage? Manual? defxxx Hoverfly Technologies 10 May 17, 2012 01:54 PM
New Product HoverflyGIMBAL - Now Shipping! photronix Multirotor Talk 9 May 15, 2012 12:46 PM