HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Feb 20, 2015, 12:20 AM
Jeff
United States, NH, Franklin
Joined Nov 2013
12 Posts
Discussion
Receiver Bad ??

I have a RX2703H-D receiver and when I plug in the battery I get no red light ??
All I get is 2 faint beeps from the motor I tested with a volt meter the ESC I was getting 4.2 from that?? I was wondering if any one had some insight on this


Thanks
Downzy is offline Find More Posts by Downzy
Reply With Quote
Sign up now
to remove ads between posts
Old Feb 20, 2015, 12:47 AM
Crash and learn
United States, PA
Joined Dec 2011
2,057 Posts
Reading - Nope, I am useless. Good luck.
Try removing Throttle cable from ESC to receiver position 5. Insert battery. If 2 beeps then ESC not getting signal from receiver.
Did you remove the binding plug from the elevator position 1.

V450D03
http://www.rcforus.com/ujtoys/user-m...ser-Manual.pdf




Turnigy ESC manual
http://www.hobbyking.com/hobbyking/s...X561242X33.pdf
Ribble is online now Find More Posts by Ribble
Last edited by Ribble; Feb 20, 2015 at 02:17 AM.
Reply With Quote
Old Feb 20, 2015, 04:01 AM
Registered User
Letchworth, Great Britain (UK)
Joined Jul 2004
12,344 Posts
What battery are you using to power your ESC?

If the 4.2v you're measuring is between the red and black wires (maybe red and brown, depending on the brand) in the lead that goes from the ESC to the receiver, then it's too low. And if you're measuring it with the plug not plugged into the receiver, the voltage is possibly going even lower when it's plugged in -- which would explain why you're getting no light.
abenn is offline Find More Posts by abenn
Reply With Quote
Old Feb 21, 2015, 12:50 PM
Registered User
Tucson, Az
Joined Feb 2007
10,104 Posts
Is RX in a heli all set up ? You do not give any details.
dankar04 is offline Find More Posts by dankar04
Reply With Quote
Old Feb 25, 2015, 04:07 PM
I failed to crash a heli once!
dteel's Avatar
United States, CA, El Cajon
Joined Mar 2014
1,828 Posts
Quote:
Originally Posted by Downzy View Post
I have a RX2703H-D receiver and when I plug in the battery I get no red light ??
All I get is 2 faint beeps from the motor I tested with a volt meter the ESC I was getting 4.2 from that?? I was wondering if any one had some insight on this


Thanks
Hi Jeff, welcome to RG Groups forum!

Based on the receiver you have I assume you are taking about a Walkera V450D01 FPV Flybarless Helicopter?

If so then the beeping is likely coming from the ESC not the motor. I don't have this model of helicopter but in general 450 sized helicopters use an ESC with a BEC (Battery Eliminator Circuit) so that you don't have to have a separate battery to operate your receiver. Is this where you measured 4.2V? Many ESCs with a BEC the BEC output voltage is adjustable from around 4V to 7V. I would check to see if yours is correct for your Rx and servos.

You really need to supply just a bit more information if you expect people to help. I'm still not 100% clear on what the problem is but it appears that your Rx is not receiving any operating voltage.
dteel is online now Find More Posts by dteel
Reply With Quote
Old Today, 12:24 AM
Jeff
United States, NH, Franklin
Joined Nov 2013
12 Posts
Hi dteel,
I just wanted to say thank you For the info ,and the advice !

Ok I am flying a Walkera V450D03 With A 11v 25c battery with a 40amp ECS (BCE)
I am running a rx2703H-D receiver

My issue started after trying to use the UP02 adapter I was trying to update receiver
Now the receiver does nothing no red light nothing All I get is the 2 faint beeps ????When I plug in the battery .
I have tried to do the Binding process a few times with no progress...

thank you to all that tried to help ,,,
Downzy is offline Find More Posts by Downzy
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Is my receiver bad? turner air Electric Plane Talk 5 Jan 20, 2015 12:22 PM
Discussion how bad are flysky receivers ? handsomejackuk Radios 3 Jan 09, 2015 06:20 AM
Discussion Bad Receiver? Two-Six Radios 2 Apr 09, 2014 03:56 AM
Discussion Did i receive a bad Zenmuse H3 2D? eyyaz Multirotor Talk 3 Feb 26, 2014 10:27 AM
Discussion bad receiver aqib akbar Electric Power Cars 1 Jan 10, 2014 10:01 AM