HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Feb 12, 2013, 02:12 PM
Registered User
Joined Jan 2013
143 Posts
Help!
flysky radio problems....please help...

so I know this is mostly an aircraft forum but i know there are a lot of smart people on here and though maybe someone could help...
i decided to get my hyper 10sc out for the first time this year and when i powered everything up the steering went full lock to the right...i tried the Tx on a couple other rc's and they did the same thing....i know the Tx worked fine 2-3 months ago and it has been sitting undisturbed on my shelf that whole time...another problem is that it seems to be deleting my model memory....the radio is a flysky fsgt3c...any help/opinions anyone has is greatly appreciated....thanks guys..
pugs2300 is online now Find More Posts by pugs2300
Reply With Quote
Sign up now
to remove ads between posts
Old Feb 12, 2013, 02:36 PM
Did you check the FAQ already?
SoloProFan's Avatar
The Netherlands
Joined Jul 2010
13,595 Posts
If the model memory is messed up, it could also be that neutral and endpoints settings are messed up as well, causing the servo to behave erratically.
SoloProFan is offline Find More Posts by SoloProFan
Reply With Quote
Old Feb 12, 2013, 02:45 PM
Registered User
Joined Jan 2013
143 Posts
ok guys i have found another problem....usually when you press in the selector wheel thing it highlights one of the menus and lets you scroll between them and change things......well if i press my selector wheel it takes me to some kind of calibration instead....and it seems to be the calibration for the steering since the values on the screen change when i turn the steering wheel.....this leads me to believe that the problem with the steering is that it is badly out of calibration.....this doesn't explain how it got so far out of calibration or why the radio seems to delete my model memory unless of course i somehow entered the calibration mode by mistake.......
pugs2300 is online now Find More Posts by pugs2300
Reply With Quote
Old Feb 12, 2013, 02:46 PM
Registered User
Joined Jan 2013
143 Posts
oh and i checked all the epa, and stuff...
pugs2300 is online now Find More Posts by pugs2300
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion FlySky 9X problem, too low range on 2 modules? JLT_GTI Radios 12 Apr 03, 2014 08:43 AM
Help! Help! Burn the Flysky 9x radio, and now shows me 1.1V on the screen Mc.Daniel Radios 11 Oct 19, 2013 04:04 AM
Discussion Flysky 9 channel receiver problems!! Help! gmwahl Radios 4 Jan 04, 2012 08:24 PM
Discussion Flysky FS-CT6B radio system. Just one quick question about setup. Please help. larsen8or117 Radios 4 Jul 01, 2011 11:55 AM
Help! Eurgle/flysky 3ch 2.4g radio. Help needed doh2doh Radios 0 Jan 16, 2010 11:28 AM