HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Nov 10, 2012, 08:41 PM
Registered User
Joined Apr 2008
34 Posts
Discussion
Double horse 9116 tail problem

Well, I crashed my new(er) 9116 the other day into a tree limb and now I cant seem to get the heli to fly anymore. The problem is with the tail motor (behavior at least).

When I start moving the trottle, the tail motor comes on full speed (it does not track the throttle). I can push the stick all the way to the left and make it turn off, but I can't seem to get it to have more than two speeds, either on or off. I checked all the structures I could think of including gears and wires. Any idea how to fix or test for my solution?
Gregdoug is offline Find More Posts by Gregdoug
Reply With Quote
Sign up now
to remove ads between posts
Old Nov 11, 2012, 06:33 AM
ironhorse99's Avatar
United States, NJ
Joined Sep 2012
84 Posts
I can't say if this will remedy it or not but it has worked for me just the other day. I have observed that from time to time when my 9116 tail acts in this manner I unplug the power with the transmitter still on then re-connect the heli power, wait till it binds & things are back to normal. Don't turn the heli switch off but rather disconnect the power completely. The Pc board design has a lot to do & I'm guessing its design is kind-of on the edge.....just my observation.
ironhorse99 is offline Find More Posts by ironhorse99
Reply With Quote
Old Nov 11, 2012, 12:13 PM
Registered User
Joined Apr 2008
34 Posts
Ironhorse, thanks for the post. I tried it several times just now and it doesn't seem to fix it. I may have fixed it a little though, now I can push the stick over to the far left, which stops the tail motor from spinning and then can ease the stick to the right as I increase throttle and sort of control the spin. Any other ideas?
Gregdoug is offline Find More Posts by Gregdoug
Reply With Quote
Old Nov 11, 2012, 01:56 PM
ironhorse99's Avatar
United States, NJ
Joined Sep 2012
84 Posts
I did have a bad motor(tail) when I first got mine so it might be that. You might want to touch up the solder joints if you've got an iron(low wattage) I've had wires pull out thru the joint. Q.C. in China is not Stellar.......as a matter of fact by the looks of what I've seen I bet they don't even wash their boards after re-flow. If you continue to fly this your advised to stock up on motors both main & tail. they don't last very long.
ironhorse99 is offline Find More Posts by ironhorse99
Reply With Quote
Old Nov 14, 2012, 12:13 AM
Registered User
Joined Apr 2008
34 Posts
Any other ideas how I might fix the tail motor from going to either 0% or 100%?
Gregdoug is offline Find More Posts by Gregdoug
Reply With Quote
Old Nov 14, 2012, 12:20 AM
ironhorse99's Avatar
United States, NJ
Joined Sep 2012
84 Posts
Sounds like the tail motor......time to stock up.
ironhorse99 is offline Find More Posts by ironhorse99
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question double horse 9116 need help with EMCycle Beginner Training Area (Heli-Electric) 14 Jan 10, 2013 05:05 PM
Discussion My Double Horse 9116 have this problem louai Beginner Training Area (Heli-Electric) 1 Aug 03, 2012 11:42 AM
Discussion How to adjust tail rotor on 9116 double horse Cullen1 Beginner Training Area (Heli-Electric) 5 Jul 29, 2012 11:51 AM
Question Turnigy 9x and Double Horse 9116 rudder problem Doc Monty Beginner Training Area (Heli-Electric) 3 May 16, 2012 11:44 PM
Discussion 9116 Double Horse Daza1964 Beginner Training Area (Heli-Electric) 1 Mar 26, 2012 10:22 AM