HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Sep 09, 2014, 06:39 PM
Registered User
Ronin Storm's Avatar
United Kingdom, York
Joined Sep 2014
2 Posts
Help!
Heli-Max 1SQ RTF unstable, flips out on take-off

Picked up a Heli-Max 1SQ RTF from Amazon.co.uk last week. Across three battery charges, maybe two hours of experimenting, and roughly 25 take-off attempts, only 3 have resulted in successful flight.

Many attempts just flip out on take-off. Either just a pair of rotors spin, flipping the quad, or three spin and the quad spins then flips. Either is a crash.

I've tried to contact Hobbico (helihotline@hobbico.com) but had no response -- 2 attempts over 6 days (4 working days), nothing but their automated reply.

Here's what I sent them:

Quote:
Originally Posted by Me in email to Hobbico
I've purchase a 1SQ Quadcopter from Amazon.co.uk and received it today. I'm having trouble getting stable flight from the quad.

Some of the time, only two or three rotors spin under power; increasing power (unsurprisingly) causes the quad to spin or flip then crash. Some of the time, all spin but there's a lot of drift on takeoff that requires a lot of notches of trim to mitigate and, even then, is pretty temperamental.

I've read the maintenance instructions on your web site and followed them all. Specifically:
  • I've ensured the motors are pushed upwards.
  • I've ensured that there's around 1mm of visible axle below each rotor after positioning the motors.
  • I've gently pushed the motors up within their housing by removing the red caps, using the provided screwdriver, then replacing the caps.
  • I've replaced the front left rotor with one of the spares as it was a little loose on the axle.
I've also experimented with unplugging then reconnecting all the motors from the base board. I've replaced these in order left to right of front-left, rear left, rear right, front right. I've also ensured the black wires are at the front.

I've tried only connecting the battery with the quad on the floor (carpet, in this case, to cushion flip-crashes), or connecting the battery with the quad inverted for easier access. Neither seems to affect the result.

When connecting the battery, I notice the red LED at the back of the board flashes briefly, then stays on solid. On some flights, I've also noticed another red LED in the centre of the board light up, then flicker. It seems like when that central LED is lit, the quad is more stable, but on most flight attempts it may flicker a few times, then go out and stay out for the rest of the flight. A light downwards pressure on the sides of the board can cause the central LED to light, but releasing the pressure results in flickering, then the central light goes off. In each case, the back LED stays on solid.

The battery feels like it only has 4 or so minutes of flight time, but the rotors spin and a couple of times I've had the quad in a steady flight for the 10 or so seconds I can actually manage to keep it under control (I admit I'm a novice with RC flight).

I've dialed the controller sensitivity down to 20, though the results are much the same on 20, 30 or 40.

Am I doing something wrong? Am I merely pants at flying? Or is the quad faulty?

Be great if you could help me out on this one please!

Thanks in advance,
I can still return this quad to Amazon for a refund (though not a replacement, it seems) but if I can reasonably get her working then I'd rather do that. The web seems full of reviews praising the 1SQ for a new pilot... not having a good experience so far though.

Any pointers?

Thanks in advance!
Ronin Storm is offline Find More Posts by Ronin Storm
Reply With Quote
Sign up now
to remove ads between posts
Old Sep 10, 2014, 09:32 AM
Registered User
Ronin Storm's Avatar
United Kingdom, York
Joined Sep 2014
2 Posts
I've watched a lot of video reviews of the 1SQ this afternoon and tried to pay special attention to the state of the two LEDs on the FCB.

This is most easily seen in the following YouTube video (linked to 4m35s where the LEDs are clearly shown).

http://youtu.be/-pmHmOd078g?t=4m35s

The rear most LED indicates connection to Tx.

The central LED is full on.

In another video, the central LED seemed to be blinking constantly.

In mine, the central LED usually fails to light.

I'm thinking that mine is faulty. Time to send back to Amazon.
Ronin Storm is offline Find More Posts by Ronin Storm
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Heli-max 1SQ V-CAM RTF Flip, Video, Pic Buttons Don't Work bulmoss Multirotor Talk 1 Mar 14, 2014 08:15 PM
For Sale RTF Heli-Max 1SQ V-Cam $110 + Shipping Thmprusmc Aircraft - Electric - Multirotor (FS/W) 1 Jan 02, 2014 11:19 AM
Help! Hex flipped over on take off! LostMoonOfPoosh Multirotor Talk 0 Oct 17, 2013 05:43 PM
For Sale RTF Heli-Max 1SQ V Cam $120 Shipping Thmprusmc Aircraft - Electric - Helis (FS/W) 0 Oct 01, 2013 03:06 PM
Discussion F550 + Naza V2 Flip on take off bryanwood Multirotor Talk 2 Oct 01, 2013 02:43 AM