SMALL - espritmodel.com SMALL - Telemetry SMALL - Radio
Reply
Thread Tools
Old Sep 29, 2012, 04:01 PM
Registered User
Marietta GA.
Joined Jan 2011
332 Posts
Discussion
Ice 75 acting odd

Guys, I just put a ICE 75 in a plane with a omega 130mg motor with the recommended prop(11x7)...The battery is 2650ma 30c zippys...when I put a fresh pack it cuts out when I go to full throttle like the voltage is low..Its running the default programming..If I switch to my 3000ma packs it works fine...Total current draw WOT throttle is about 45 amps with the 3k packs..I have been using those packs in a larger plane with more current draw I think no problems..I`m not over the current of the pack or the ESC by far..why is it cutting out..Is it a timing issue maybe or I just need to use 3k packs...thx
mazjag is offline Find More Posts by mazjag
Reply With Quote
Sign up now
to remove ads between posts
Old Sep 29, 2012, 04:32 PM
A man with too many toys
United States
Joined Feb 2001
17,612 Posts
The data log will tell you the reason for the shutdown. If you move the cursor over the vertical line at cutoff time it will display the reason for the cutoff. It’s probably getting voltage spikes below the cutoff voltage.


Change to soft cutoff.
Keep lowering the cutoff voltage by .1v/cell until it does not cut off.


.
RC Man is offline Find More Posts by RC Man
Reply With Quote
Old Sep 30, 2012, 05:16 PM
Registered User
Marietta GA.
Joined Jan 2011
332 Posts
Thanks, I don`t have the link to view that, but its on its way...I`m getting the 2 beep error..LVC cutoff malfunction . I`m getting that with all four of my older 2650ma packs...The two new 2650s work ok and the 3000s are fine.. both planes pull about 44 amps are about 545-585 watts..The batteries work in one, but not the other...shouldn`t the 2650s be able to put out 45 amps?? they are 30c..The voltage does sag with the old 2650s when I punch it...I understand what you are saying about the LVC adjustment, but the default is 3.2 volts..Do I do that or get better batteries?
mazjag is offline Find More Posts by mazjag
Reply With Quote
Old Oct 09, 2012, 07:47 AM
Castle Support
Clintstone's Avatar
USA, GA, Statesboro
Joined Oct 2007
956 Posts
Quote:
Originally Posted by mazjag View Post
Thanks, I don`t have the link to view that, but its on its way...I`m getting the 2 beep error..LVC cutoff malfunction . I`m getting that with all four of my older 2650ma packs...The two new 2650s work ok and the 3000s are fine.. both planes pull about 44 amps are about 545-585 watts..The batteries work in one, but not the other...shouldn`t the 2650s be able to put out 45 amps?? they are 30c..The voltage does sag with the old 2650s when I punch it...I understand what you are saying about the LVC adjustment, but the default is 3.2 volts..Do I do that or get better batteries?
I would get a link and view the data so you can tell what is going on and change the LVC to 3.0v... If they are older batteries the LVC may need to be at 3.0v... 3.2 v became the default to protect some of the new batteries...
Clintstone is offline Find More Posts by Clintstone
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Sold NIP Phoenix ICE 75 - $75 Shipped! pherasi1 Aircraft - Electric - Power Systems (FS/W) 1 Mar 05, 2012 07:22 AM
Wanted Castle Creations Ice 75 for 75 Ice Lite Jkonen Aircraft - Electric - Power Systems (FS/W) 1 Jun 21, 2011 09:29 AM
Found CC ICE 75 or ICE Lite 75 ESC brianfp_400 Aircraft - Electric - Power Systems (FS/W) 0 Oct 26, 2010 11:25 AM
Found CC Phoenix ICE 75 or ICE Lite 75 ESC brianfp_400 Aircraft - Electric - Power Systems (FS/W) 0 Apr 28, 2010 12:32 PM
Discussion ICE 75 ESC acting all wonky! jasmine2501 Electric Plane Talk 11 Apr 19, 2010 03:24 PM