HobbyKing.com New Products Flash Sale
Closed Thread
Thread Tools
Old Sep 04, 2014, 10:36 PM
Registered User
rrothman's Avatar
Joined Nov 2011
29 Posts
Help!
Guardian Stabilizer not working - LED flashing

I just noticed while working on a fuel problem I had no elevator, rudder or aileron control, the servos are jittering (digital) like normal, then I notice the Guardian LED is just flashing no matter which mode I put it in or even if I turn the 2D/3D off.

I hooked up to my PC and everything looks normal - LED flashes 3 times, horizon moves. I did a factory reset and put back in plane, same problem. I know the battery is good and the radio is putting out signals (9X with monitor to see channel activity). If I bypass the Guardian putting servos directly into receiver all is well.

With Guardian powered up on a receiver all by itself, just constant flashing.

Not getting the 4 long flashes followed by the error code, just constant steady fast flash.
rrothman is offline Find More Posts by rrothman
Last edited by rrothman; Sep 04, 2014 at 10:40 PM. Reason: change from discussion to HELP
Sign up now
to remove ads between posts
Old Sep 05, 2014, 09:27 AM
JohnET's Avatar
United States, NC, Charlotte
Joined Apr 2013
435 Posts
Hello,

Can you please open a support ticket on our website? We will help you get it sorted.

Regards, John
JohnET is offline Find More Posts by JohnET
Site Sponsor
Old Sep 05, 2014, 10:16 AM
Registered User
rrothman's Avatar
Joined Nov 2011
29 Posts
Done, ticket #151095!
rrothman is offline Find More Posts by rrothman
Old Sep 15, 2014, 10:19 AM
Registered User
rrothman's Avatar
Joined Nov 2011
29 Posts
got the replacement from Eagletree this weekend, great service!
rrothman is offline Find More Posts by rrothman
Closed Thread


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Hitec Flash 5 -throttle not working cvint Hitec/Multiplex USA 3 Apr 26, 2014 05:46 AM
Discussion Guardian 2d/3d not working correctly on a Stryker F27Q MichaelT1960 Eagle Tree Systems 9 Nov 14, 2013 07:48 AM
Discussion Guardian Expander not functioning-led flashing MrMum Eagle Tree Systems 6 Jun 04, 2013 05:48 PM
Help! Support Ticket [#579924] Guardian Stabilization don't work properly‏ cesarjuliogm Eagle Tree Systems 4 Oct 23, 2012 12:21 PM
Discussion Aileron Does Not Work with Guardian texasdrifters Eagle Tree Systems 4 Jul 20, 2012 03:53 AM