HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Dec 18, 2014, 04:19 PM
Registered User
Joined Dec 2014
3 Posts
Discussion
multirotor setup help :(

recently purchased a quadcopter 250 frame, skeptrum dx6i the controller is naza32 and a LemonRX PPM DSMX

was advertised as ready to fly just needed a battery i thought GREAT! , plugged battery in i get solid red led and solid blue, green flashes a few times and if you move the quad about it flashes aswel, also it beeps continuously and doesn't stop, seller did advice me it should beep a few times then fall silent, really at a lose as to what can be wrong.
I was informed the throttle needs to be at the lowest position to arm the quad which im presuming down all the way, be honest i think ive tried every position along with restarting the skeptrum inbetween nothing..

if ive posted in the wrong section apologizes im a new user, any help would be greatly appreciated
madbristol1 is offline Find More Posts by madbristol1
Reply With Quote
Sign up now
to remove ads between posts
Old Dec 18, 2014, 04:36 PM
The Blacksite Dev
The_DoGMaN's Avatar
Canada, ON, Niagara Falls
Joined Dec 2014
57 Posts
Here is a page from the users manual. Not sure if this is what you meant when you said all the way down.

http://www.abusemark.com/downloads/naze32_rev3.pdf
The_DoGMaN is online now Find More Posts by The_DoGMaN
Reply With Quote
Old Yesterday, 08:20 AM
Registered User
Joined Dec 2014
3 Posts
that seems accurate to what this guy told me but the problem is even doing this, the drone just continuously beeps and doing the above nothing happens :\ totally at a loss
madbristol1 is offline Find More Posts by madbristol1
Reply With Quote
Old Yesterday, 08:27 AM
The Blacksite Dev
The_DoGMaN's Avatar
Canada, ON, Niagara Falls
Joined Dec 2014
57 Posts
Sorry, hopefully someone with more experience will pop in and lend a hand.
The_DoGMaN is online now Find More Posts by The_DoGMaN
Reply With Quote
Old Yesterday, 11:33 AM
Control the Truth#1 goal inWAR
TonyTronicWSP's Avatar
United States, WA, Walla Walla
Joined Oct 2012
191 Posts
First check that your transmitter is bound to your controller? Light on reciever, which is on your quad, the light should blink waiting for Transmitter to turn on. Once Transmitter is on the light should go solid on.

Because of constant beep from esc's

Sounds like you need to calibrate your esc's. How you do it is.... Remove the Props first.
1. Put the throttle all the way up.
2. turn on the Transmitter it might alarm because of throttle that's OK.
3. With Transmitter ON plug in the battery for the quad and listen for beep, then immediately disconnect the battery, then plug battery back in listen for beep then lower your throttle down all the way (You lower the throttle pretty quickly after plugging in the battery the 2nd time). The esc's have now learned your throttle. and the constant beeping should now stop.

If you are using Opto Esc's they do not learn and you have a different issue.

Good Luck
TonyTronicWSP is offline Find More Posts by TonyTronicWSP
RCG Plus Member
Latest blog entry: Extreme Frame Replaced
Reply With Quote
Old Yesterday, 05:55 PM
Registered User
Joined Dec 2014
3 Posts
need to wait for a binding plug to arrive and will post back results thanks for the help guys !
madbristol1 is offline Find More Posts by madbristol1
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Build Log Need Help with my setup/building my 1st Multirotors! Vince2611 Multirotor Electronics 0 Nov 07, 2014 11:10 AM
Help! Need Help with my setup/building my 1st Multirotors! Vince2611 Multirotor Talk 0 Nov 06, 2014 06:35 PM
Discussion Need Help with my setup/building my 1st Multirotors! Vince2611 Scratchbuilt Multirotors 0 Nov 06, 2014 05:21 PM
Discussion Help with Multirotor Setup for Autnomous /Long Range Missions vishalrao Multirotor Talk 0 Sep 15, 2014 09:58 AM
Discussion First Multirotor build, need help with KK2 setup _Spook Multirotor Talk 1 Mar 20, 2013 03:52 PM