HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jun 02, 2011, 10:31 AM
Registered User
Canadian Geek's Avatar
Joined Jan 2007
4,495 Posts
---Deleted---
Canadian Geek is offline Find More Posts by Canadian Geek
Last edited by Canadian Geek; Feb 10, 2012 at 06:18 PM.
Reply With Quote
Sign up now
to remove ads between posts
Old Jun 02, 2011, 10:35 AM
Registered User
Canadian Geek's Avatar
Joined Jan 2007
4,495 Posts
---Deleted---
Canadian Geek is offline Find More Posts by Canadian Geek
Last edited by Canadian Geek; Feb 10, 2012 at 06:18 PM.
Reply With Quote
Old Jun 02, 2011, 11:39 AM
Registered User
Belgique, Région Wallonne, Wavre
Joined Feb 2011
211 Posts
Quote:
Originally Posted by zirt57 View Post
Nice looking frame. What's the price on that frame may I ask?

- Jeff
Thanks Jeff for the feedback.
The frame is about 384€, the gopro camera mount with 2 servos included is 157€ and finally the transparent cover is about 35€.
For sure not the less expensive Y6 frame, but one of the nicest one I have seen.
moombe is online now Find More Posts by moombe
Reply With Quote
Old Jun 02, 2011, 11:44 AM
Suspended Account
United Kingdom, Swansea
Joined Mar 2011
2,225 Posts
Quote:
Originally Posted by nestergaard View Post
I didn´t find any motor mounts on that page. Anyone knows where to buy for x8?
The only people that make them is XAircraft (for their pending X8), all others have had to fabricate them for themselves (accept Josh I think who was sent some by XA)
TeeJayBee is offline Find More Posts by TeeJayBee
Reply With Quote  (Disabled)
Old Jun 02, 2011, 02:11 PM
Registered User
United States, NV, Las Vegas
Joined May 2011
43 Posts
Hi,

I just finished with assembly of my X650

On a test run the motor3 does not spin, it shakes left-right but does not spin

I checked connections and they are all correct - any ideas?

thanks

P.S. Rotated the motors and same motor works on different port of ESC. The motor on M3 port of the ESC does not spin

P.S. there is video: http://www.youtube.com/watch?v=braQRTFKUBA
TheGunMan is offline Find More Posts by TheGunMan
Last edited by TheGunMan; Jun 02, 2011 at 07:14 PM.
Reply With Quote
Old Jun 02, 2011, 02:13 PM
Registered User
Joined Feb 2004
136 Posts
Try throttling down all the way and up again. Sometimes I'll get a motor that won't spin when I first throttle up. You double checked that you have it wired correctly?

Nick
seafarer is offline Find More Posts by seafarer
Reply With Quote
Old Jun 02, 2011, 02:23 PM
Registered User
United States, NV, Las Vegas
Joined May 2011
43 Posts
Quote:
Originally Posted by seafarer View Post
Try throttling down all the way and up again. Sometimes I'll get a motor that won't spin when I first throttle up. You double checked that you have it wired correctly?

Nick
Triple checked the connections, swap motors, did throttling up and down and no change

Is it possible to have ESC bad?
TheGunMan is offline Find More Posts by TheGunMan
Reply With Quote
Old Jun 02, 2011, 02:26 PM
Registered User
Canadian Geek's Avatar
Joined Jan 2007
4,495 Posts
---Deleted---
Canadian Geek is offline Find More Posts by Canadian Geek
Last edited by Canadian Geek; Feb 10, 2012 at 06:18 PM.
Reply With Quote
Old Jun 02, 2011, 02:32 PM
Registered User
Ironbridge (UK)
Joined Jan 2009
3,966 Posts
Quote:
Originally Posted by zirt57 View Post
For now you will have to build them yourself. I just received 8 X650 motor mounts and cut them in half along the arm direction. I kept the tabs that connect between the top and bottom. Then I drilled out the threads on just one set of the motor mounts and bolted them together. If I get a chance I'll take some pictures today. This setup really worked well. It looks very professional which was my target all along.

- Jeff
be good if you could post some pics of them, close up etc

cheers

Josh
Joshbb is offline Find More Posts by Joshbb
Reply With Quote
Old Jun 02, 2011, 02:33 PM
Registered User
United States, NV, Las Vegas
Joined May 2011
43 Posts
Quote:
Originally Posted by zirt57 View Post
Yes it is possible (anything man made can and will break). Check the LED lights on the ESC to see if they are all flashing the same way. If they aren't, take a video of them for Jingchen as they will help him figure out what is wrong.

- Jeff
The LED's flash all together when the throttle is all the way down. When the motors spin they are on all 4 of them
TheGunMan is offline Find More Posts by TheGunMan
Reply With Quote
Old Jun 02, 2011, 03:40 PM
Registered User
Joined Feb 2004
136 Posts
I also used x650 motor mounts. I have a full machine shop, but rather than take the quad to my shop, I just used the tools in the basement. Cut the mounts in half on a bandsaw, drilled out the threads on one half, and ground off the ridge with a dremel. Finished on a sander. I'll post some pictures tomorrow, x650 is at the office, and I stayed home today.

Nick
seafarer is offline Find More Posts by seafarer
Reply With Quote
Old Jun 02, 2011, 03:44 PM
Registered User
Canadian Geek's Avatar
Joined Jan 2007
4,495 Posts
---Deleted---
Canadian Geek is offline Find More Posts by Canadian Geek
Last edited by Canadian Geek; Feb 10, 2012 at 06:18 PM.
Reply With Quote
Old Jun 02, 2011, 04:00 PM
Registered User
Ironbridge (UK)
Joined Jan 2009
3,966 Posts
you guys who have made motor mounts need to post piccies to help peoples

here is my very diy 2 axis camera mount, not much help to diy motor mounts though sorry..
Joshbb is offline Find More Posts by Joshbb
Reply With Quote
Old Jun 02, 2011, 05:05 PM
Registered User
The Highlander1's Avatar
The Highlands of Scotland
Joined Jan 2011
79 Posts
Quote:
Originally Posted by nestergaard View Post
I didn´t find any motor mounts on that page. Anyone knows where to buy for x8?
Hi thats because there not there, as I dont have any but if you want me to make you some just ask!!!
The Highlander1 is offline Find More Posts by The Highlander1
Reply With Quote
Old Jun 02, 2011, 05:09 PM
Registered User
The Highlander1's Avatar
The Highlands of Scotland
Joined Jan 2011
79 Posts
Quote:
Originally Posted by wiggysk10 View Post
you could try quadframes.co.uk , i bought a 450 frame off them and it is superb and took 20mins to put together
Hi thanks hope you are getting on with your FSM X450 frame really easy to put together eh!!

I have just finnished my Y6 here she is!!!

I have just tested here tonight ans she flys well so far!!!
thanks for looking.....
The Highlander1 is offline Find More Posts by The Highlander1
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Xaircraft X650 Quad Owners and Testers Thread Z06 Tony Multirotor Talk 459 Feb 07, 2014 02:54 PM
Discussion x650 Technical Documents Translation:XAircraft X650 LED Module infmetry Multirotor Talk 9 Nov 22, 2011 06:03 PM
Discussion WANTED:Test-Pilots for X650&Letter to XAircraft Pilots/The final namelist determined xaircraft Multirotor Talk 35 Jan 11, 2011 07:28 AM
Discussion X650 the new quad from XAircraft to be launched very soon bob.titus Multirotor Talk 558 Nov 20, 2010 11:33 AM
Discussion Official!!!!!! Parrot A.RDrone USA owners thread Quad_Addict Multirotor Talk 59 Oct 27, 2010 11:48 PM