HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Feb 17, 2015, 03:02 PM
Registered User
United States, MT, Great Falls
Joined Jan 2014
72 Posts
Discussion
having an intresting issue, and I'm very confused.

My quad has had several issues but this newest one really has me stumped. I had posted previously and thought I had solved the problem, but alas.

So I went to fly , armed the copter and throttled up. It didn't want to throttle... It acted like the front right was at proper power but the back left was at a handicap. I fiddled with it and it kept acting like this. Finally it evenly throttled and lifted and it felt like it was flying fine, then all of a sudden I had no throttle control. I could still steer , but the throttle would idle up and down. Altitude hold is not turned on or even engaged. I grabbed it out of the air and pinned it down with my foot until I could unplug the power. Anybody have any ideas?

I'm using the multi win pro. Frisky radio module in 9xr.

I don't know if it's a brown out (I have a voltage protecter) if it's a radio problem or what.

I don't think it's a radio issue, because I recently replaced the rx with an upgrade.

I don't know how to tell if it's a voltage issue.
I do have fpv gear, running off a separate battery.
Minimosd and led running off main batt.

I can give a more detailed list of parts if needed.writing this on my lunch break atm.
Nickshchaos81 is online now Find More Posts by Nickshchaos81
Reply With Quote
Sign up now
to remove ads between posts
Old Feb 17, 2015, 08:39 PM
Registered User
United States, MT, Great Falls
Joined Jan 2014
72 Posts
So doing some math, and im thinking my c rating is too low for my model. my
Motors have 21 amp draw , so I have a 30 Amp Esc that is max of 30amps
so I say 30 amps x 4 = 120amps being drawn ... right?
Well if my math is right then that would mean that if my motors and esc's are pulling 120amps , my Flight Controler pulls like 3.7 amps
so 120 + 3.7 = 123.7 amps and this is not including my minmosd being powered off flight control board or led lights....

I am using a 3300mah 35c 3cell battery and by my math that means i can discharge at about 115 amps....
Am I correct so far????

So with this being said , could this cause problems like im describing. Where it feels like something is trying to power off , but just has enough power to stay on and cause problems. Like say the rx losing enough power to cause it to malfunction , but not enough to kick the failsafe on the fcb on? or maybe the esc's not getting the right power and causing the motors to goof up?

Either way this bird is grounded until i know i figured my math right. Im pretty sure that when i built this I did the math wrong and got the wrong batteries. So I guess my final question is could this cause my problem , or did i just discover a new problem unrelated to the previous problem?

thx guys
Nickshchaos81 is online now Find More Posts by Nickshchaos81
Reply With Quote
Old Feb 17, 2015, 08:58 PM
Air, Ground & Water
freechip's Avatar
Canada, ON, Rockland
Joined Aug 2008
25,471 Posts
Just because you have 30a ESC doesn't mean that your motor/prop combo are pulling that much.

You need a Wattmeter if you want to get real numbers on current draw.
freechip is offline Find More Posts by freechip
Reply With Quote
Old Feb 17, 2015, 09:15 PM
Registered User
United States, MT, Great Falls
Joined Jan 2014
72 Posts
could this still be the cause of my problem? Because it has happened before and when it has its been random.
Nickshchaos81 is online now Find More Posts by Nickshchaos81
Reply With Quote
Old Feb 18, 2015, 01:21 AM
Registered User
United States, OR, Mt Hood
Joined May 2014
908 Posts
Did the problems start after upgrading your receiver?
PatR is offline Find More Posts by PatR
Reply With Quote
Old Feb 18, 2015, 06:40 AM
Registered User
Joined Mar 2007
17 Posts
Hi, looking at your math there are some numbers such as FC draw that I dont think is correct, I doubt it pulls that much. I also dont think that your C rating on the battery has anything to do with it. If anything it would just limit the torque of the motors. Anyways, I dont think that would be your problem. As PatR asked, when did the problem start? Was it after upgrading the receiver?
NXTized is offline Find More Posts by NXTized
Reply With Quote
Old Feb 18, 2015, 09:09 AM
Registered User
United States, MT, Great Falls
Joined Jan 2014
72 Posts
No , the problems prompted me to change the rx, but the problem still persisit. This is why I'm leaning towards the battery not being able to discharge at the proper rate. But have yet to get a yes, your c rating being lower then what is recommended could cause those problems
Nickshchaos81 is online now Find More Posts by Nickshchaos81
Reply With Quote
Old Feb 18, 2015, 02:53 PM
Registered User
United States, MT, Great Falls
Joined Jan 2014
72 Posts
your correct on the FCB its more like .37 amps .
Ill try to be a bit more descriptive.
The problem started last summer. I took the copter with me to work to show my boss. I fired it up and flew around the parking lot not doing anything different then normal.(this is in the rurals btw) Everything was fine then all of a sudden the damn thing twitched and momentarily had no control. Then all steering came back except for throttle, it climbed to about 30 ish feet and hung there better then altitude hold could have ever done. It acted also like the something was up with the self level , it wanted to pull hard in one direction. I managed to hold it still over our field , then after almost 10 minutes the failsafe kicked on (with tx still controlling) and motors died and it fell.
I got it home went over everything I could took it out in my field and flew the crap out of it all the next day with out even the slightest of problems. Then the following day , at my house. I got the twitch throttle locked and pull was so bad that it bit the dust.

I replaced the broken parts , reprogrammed the board, replaced the rx added a voltage protector. Everything seemed fine till just before winter I had it at a hover by my car showing my son how to fly and the failsafe just kicked on the thing fell and tilted backwards and crumbled. It was only like 5 feet or so. I gave up for the winter and rebuilt then whole damn thing. New frame , removed camera pan and tilt servos , made the thing lighter , installed my minimosd organized it all better and kept the fpv on a "seperate battery" Got it out after snow melted and flew great for around 30 minutes.

Friend at work got one that i built for him, went to work to fly together on lunch his flew like a dream (so jealous) mine .... not so much.

this was 2/17/15 it did not want to arm , once armed i throttled and the motors didnt act like they were powering up at the same time , (sputtering). Unarmed , checked connections, tried again and it seemed fine , then like 5 seconds in the air it twitched , throttle locked it hovered with all control except throttle... i pinned it to the ground and you could hear the motors throttleing up then down , until i got the power pulled. Check FcB and no altitude hold is not even assigned.

So to me it acted like i got a brown out either in fcb or rx but didnt lose all power , and got stuck between off and on

Im confused , because this was the first out of about six that I have built , none with any problems even remotely close to as confusing as this. I really dont know where to even start either. I thought I had fixed the problem twice already.
Nickshchaos81 is online now Find More Posts by Nickshchaos81
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion I have an issue with my new micromotor warehouse motors on my nano qx help!! spencer911 Mini Multirotors 13 Oct 25, 2014 02:18 PM
Discussion First build and have an issue Sandman70 3D Foamies 8 Oct 23, 2014 09:14 PM
Help! Having an Issue JRAllen Multirotor Talk 0 Aug 19, 2014 01:40 PM
Discussion I'm very new to this hobby and very confused about batteries (v959,v222). Nano-tech? Wignorant Mini Multirotors 2 May 24, 2013 05:07 PM
Question RX issue, and I'm confused. mcphatty Electric Plane Talk 14 Jul 17, 2012 07:07 PM