Espritmodel.com Telemetry Radio
Reply
Thread Tools
Old Sep 07, 2012, 07:39 AM
Winging it ̉>
leadfeather's Avatar
Joined May 2006
9,416 Posts
Looking good crazyj!
leadfeather is online now Find More Posts by leadfeather
Reply With Quote
Sign up now
to remove ads between posts
Old Sep 07, 2012, 09:11 AM
MultiCopterPilot & Film Maker
crazyj's Avatar
United States, CA, San Ramon
Joined Oct 2002
2,543 Posts
Thanks guys! Hope the beast continues to do well in the testing. I'd like to have it all sorted out and done in the next few weeks.

=)
crazyj is offline Find More Posts by crazyj
Reply With Quote
Old Sep 15, 2012, 05:56 PM
Registered User
Joined Jun 2010
58 Posts
Well here I am with a new board, new bigger motors and can not get the v1.7 code from this thread to load. I am getting "cannot find com 3 port" messages. I can't select com port 3 because my "tools" "select port" will not light up to allow me to select serial port com 3. I ran into this problem another time but I can't remember what I did to correct it. I couldn't get that board to work either. If anyone has some helpful suggestions, I would really appreciate some help. I'm getting pretty frustrated.
tom-tom 1 is offline Find More Posts by tom-tom 1
Reply With Quote
Old Sep 15, 2012, 06:02 PM
Registered User
RCvertt's Avatar
Joined Aug 2007
4,081 Posts
Are you using the correct Arduino IDE version? Has to be version 0023 if memory serves me right, which it usually doesn't.
RCvertt is offline Find More Posts by RCvertt
RCG Plus Member
Last edited by RCvertt; Sep 16, 2012 at 05:17 AM.
Reply With Quote
Old Sep 15, 2012, 09:00 PM
MultiCopterPilot & Film Maker
crazyj's Avatar
United States, CA, San Ramon
Joined Oct 2002
2,543 Posts
Worked on my VTOL some more this week. Moved the motors forward 3" and now the CG is good both in hover and in forward flight (cg not tested, but at least in a decent range on the wing). Also installed a Hitec 645MG servo for wing tilt. She's all ready to fly but the code is giving me grief.

My first test hovers was with the basic tricopter MultiWii code 2.1. Now I'm trying to get Cass's code to work on my Paris flight controller and the various VTOL configs in the code don't seem to be working quite right.

The motors arm, but the tail motor doesn't change it's speed with pitch control. Also the rudder servos (ailerons in FF) work for a split second then stop. In the GUI the gyro is reading normally and the RX inputs are all moving as expected. There are no debug numbers or errors I can tell.

I'm guessing the paris board's wiring for the arduino doesn't match the wiring needs for the VTOL code - inputs and outputs are mixed..?

I reached out to Cass in a PM, but if anyone knows how to tweak the code - let me know! I've looked at it and even though I know VBS and Powershell (IT admin by trade) I can't seem to grasp what's happening in the code with all the variables and logic.
crazyj is offline Find More Posts by crazyj
Reply With Quote
Old Sep 15, 2012, 11:01 PM
Design, Build, and Fly
KatanaGuy's Avatar
Pleasant Grove, Utah
Joined Nov 2001
372 Posts
Could you post the offending collection of code or point us to which version you are using? I've been developing a fork of MultiWii 2.1 for VTOL work, but haven't addressed all the various configurations beyond my tricopter hybrid.

-Steve
KatanaGuy is offline Find More Posts by KatanaGuy
Reply With Quote
Old Sep 15, 2012, 11:16 PM
MultiCopterPilot & Film Maker
crazyj's Avatar
United States, CA, San Ramon
Joined Oct 2002
2,543 Posts
Quote:
Originally Posted by KatanaGuy View Post
Could you post the offending collection of code or point us to which version you are using? I've been developing a fork of MultiWii 2.1 for VTOL work, but haven't addressed all the various configurations beyond my tricopter hybrid.

-Steve
Hi Steve, I'm not sure what section of code is at fault or even if it's just some mapping of pins between the Ardunio and the Paris v.4 board I have. The code I'm trying to use is Cass's code found on his RCG blog:

http://www.rcgroups.com/forums/member.php?u=56274

Appreciate any help you can give. My VTOL is mechanically done - just needs working code! :-)
crazyj is offline Find More Posts by crazyj
Reply With Quote
Old Sep 16, 2012, 01:33 AM
Registered User
VTOLicious's Avatar
Austria
Joined Oct 2007
281 Posts
Quote:
Originally Posted by crazyj View Post
Hi Steve, I'm not sure what section of code is at fault or even if it's just some mapping of pins between the Ardunio and the Paris v.4 board I have. The code I'm trying to use is Cass's code found on his RCG blog:

http://www.rcgroups.com/forums/member.php?u=56274

Appreciate any help you can give. My VTOL is mechanically done - just needs working code! :-)
Hi crazyj, I think your pin-assignment is messed up. Have a look at cass´s dedicated WiiTOL-thread for more info: http://www.rcgroups.com/forums/showthread.php?t=1523814

Cheers, Michael

This might help you too:
VTOLicious is offline Find More Posts by VTOLicious
Reply With Quote
Old Sep 16, 2012, 05:17 AM
Registered User
RCvertt's Avatar
Joined Aug 2007
4,081 Posts
(tom-tom 1) make sure you have the right config version also.
RCvertt is offline Find More Posts by RCvertt
RCG Plus Member
Last edited by RCvertt; Sep 16, 2012 at 01:13 PM.
Reply With Quote
Old Sep 17, 2012, 08:54 PM
Registered User
Joined Jun 2010
58 Posts
I finally got the code to upload to my board. I've yet to install the board into my QTR. I could not get the GUI to respond so I have doubts about it working when I install it. I'll try tomorrow.
tom-tom 1 is offline Find More Posts by tom-tom 1
Reply With Quote
Old Sep 17, 2012, 09:11 PM
Registered User
RCvertt's Avatar
Joined Aug 2007
4,081 Posts
Do you still have your first build that looked to me like it was working?

It'll be easier if you get the GUI working before you install the arduino in your plane again.
Hope this one works out for you
RCvertt is offline Find More Posts by RCvertt
RCG Plus Member
Last edited by RCvertt; Sep 17, 2012 at 10:28 PM.
Reply With Quote
Old Sep 17, 2012, 10:18 PM
Registered User
Joined Jun 2010
58 Posts
I had a KK board in the QTR at that time.
tom-tom 1 is offline Find More Posts by tom-tom 1
Reply With Quote
Old Sep 17, 2012, 10:32 PM
Registered User
RCvertt's Avatar
Joined Aug 2007
4,081 Posts
Opps my mistake. You got pretty far with the KK.
RCvertt is offline Find More Posts by RCvertt
RCG Plus Member
Last edited by RCvertt; Sep 17, 2012 at 10:55 PM.
Reply With Quote
Old Sep 18, 2012, 08:21 PM
Registered User
Joined Jun 2010
58 Posts
WELL! I don't know what is going wrong. I still can't get the board to work.

I've used both arduino 22 and arduino 23. I have loaded MultiWiiV1_7 with both. I got the port COM4 open. The message says the upload was done. I open the conf. file which downloaded with the MultiWiiV1_7, and then nothing! The GUI does nothing. I click on the port, read, write, calibrate, start and all I get is a straight line graph. I installed the board in the QTR and............................... NOTHING.
tom-tom 1 is offline Find More Posts by tom-tom 1
Reply With Quote
Old Sep 18, 2012, 08:40 PM
MultiCopterPilot & Film Maker
crazyj's Avatar
United States, CA, San Ramon
Joined Oct 2002
2,543 Posts
I've mapped out the pins on my Paris board for the VTOL code and everything seems to be in order. Strange that the rear motor starts/stops but doesn't vary speed - we know the pin out is correct because it starts/stops with the other motors... Also there's still no input to the yaw servo in VTOL tail mode / config.

I might try to fly this thing using the regular tricopter code from 2.1 - there seems to be a "pass through" option in the GUI - maybe this will prevent the gyros from inputting commands once transitioned to FF?

EDIT: I tried to read and understand parts of the code - think I see that the pass-through mode is only for some model types - not quads or tris. Booo!
crazyj is offline Find More Posts by crazyj
Last edited by crazyj; Sep 18, 2012 at 08:49 PM.
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Build Log Quad Tilt Rotor - Build Log (Comments & Suggestions Welcome) maxvtol VTOLs 253 Sep 09, 2013 10:36 AM
Discussion QTD- Quad Tilt Duino (Arduino- Tilt Rotor) RCvertt VTOLs 100 Jun 28, 2012 12:15 AM
Discussion Help selecting receivers and transmitters for quad rotor oscioscia Multirotor Talk 5 Sep 06, 2011 01:43 PM
Discussion mcx 5in1 Unit for Roll Tilt Compensation on Quad nicnaimless Multirotor Talk 0 Aug 11, 2010 01:17 PM
Cool WOW!!!! Iphone controlled quad with vid link to iphone, tilt controlled!! helifrek Multirotor Talk 8 Jan 18, 2010 09:23 AM