SMALL - Telemetry SMALL - Radio
Thread Tools
Old Today, 12:23 AM
FyreSG is online now
Find More Posts by FyreSG
新加坡的飞儿
FyreSG's Avatar
Singapore, Singapore
Joined Apr 2012
5,875 Posts
Thanks.
FyreSG is online now Find More Posts by FyreSG
Reply With Quote
Sign up now
to remove ads between posts
Old Today, 04:34 AM
mario.awad is offline
Find More Posts by mario.awad
Microheli Flyer
mario.awad's Avatar
Lebanon
Joined Apr 2015
4 Posts
Hi guys,

Reporting back on the HCP80v2 lag issues. Bad news still. I bought the 25c upgraded batteries from here http://www.banggood.com/Giant-Power-...0-p-89101.html as I heard it might fix the lag issue. Well, it does make the lag a bit less pronounced but the lag is still there. Also, with this battery, the HCP80v2 has much more power even after 1 or 1.5 minutes. With the original battery, a lot of power is lost after that. Note that this battery is a very tight fit to the landing skids and I'm afraid I might break them sometime. But works fine and gives much better response than the original one.

Awaiting the official final lag fix from Hisky hopefully soon.

Cheers.
mario.awad is offline Find More Posts by mario.awad
Reply With Quote
Old Today, 05:34 AM
NELICOPTER is offline
Find More Posts by NELICOPTER
The Teenage Flyer.
NELICOPTER's Avatar
Australia, VIC, Melbourne
Joined Sep 2014
193 Posts
Quote:
Originally Posted by mario.awad View Post
Hi guys,
Reporting back on the HCP80v2 lag issues. Bad news still. I bought the 25c upgraded batteries from here http://www.banggood.com/Giant-Power-...0-p-89101.html as I heard it might fix the lag issue. Well, it does make the lag a bit less pronounced but the lag is still there. Also, with this battery, the HCP80v2 has much more power even after 1 or 1.5 minutes. With the original battery, a lot of power is lost after that. Note that this battery is a very tight fit to the landing skids and I'm afraid I might break them sometime. But works fine and gives much better response than the original one.
Awaiting the official final lag fix from Hisky hopefully soon.
Cheers.
Good luck, as those batteries are notorious for having an incredibly short life span.
I haven't heard any success stories with them. Time will tell.
I'll have to try something sneaky to bypass the receiver board problem.
Hurry please...
NELICOPTER is offline Find More Posts by NELICOPTER
Reply With Quote
Old Today, 06:07 AM
IM back! is offline
Find More Posts by IM back!
Registered User
Joined Dec 2009
272 Posts
if Batterys affect servo lag issues, it might be usefull to see if they still happen with a lab power supply. or a large cap (1F 5.5v supercap maybe) in the supply rail
IM back! is offline Find More Posts by IM back!
Reply With Quote
Old Today, 07:03 AM
Ashura is online now
Find More Posts by Ashura
Registered User
United States, OK, Norman
Joined Mar 2009
11 Posts
If it were a hardware problem, it wouldn't fly in either mode. It doesn't make sense for the components themselves to use more power with the accelerometer turned off. There's something wrong with the way the 3-axis setting handles analog output on the microcontroller, though I couldn't tell you where it's sending all the excess power without the source code in front of me.

Provided I'm right, it's a cheap fix as a board redesign is unnecessary. The bad news is debugging this stuff is...not a good time.
Ashura is online now Find More Posts by Ashura
Reply With Quote
Old Today, 10:41 AM
victzh is offline
Find More Posts by victzh
Registered User
Joined Oct 2012
334 Posts
Actually, it's very hard to guess what went wrong with the code in 3 axis mode. There can be hundreds (if not thousands) different interactions which can affect it. There is no "analog output" with regards to servos, only analog input if the servos are dumb, or 5-pin.

You're right it's a software problem, they're "looking into it 12 hours a day" since James was with them, though. It must be a very hard one!

I'd like to take a look at source code as well, but I'm afraid it's not possible - the competition there is so strong they'll never allow this.
victzh is offline Find More Posts by victzh
Reply With Quote
Old Today, 12:48 PM
Ashura is online now
Find More Posts by Ashura
Registered User
United States, OK, Norman
Joined Mar 2009
11 Posts
I was referring to output to the motor/servos. A digital controller obviously can't output in analog, but I was trying to avoid getting overly technical.

But you're right. It could essentially be anything pulling power away from the servos. Either way, obviously something is running when it shouldn't be. In my experience, it's usually a code implementation mistake (a typo or somesuch) and not a software engineering problem. Good luck finding that in Assembly or whatever godawful thing they used to write it. Whoever is on this has my sympathies.
Ashura is online now Find More Posts by Ashura
Reply With Quote
Old Today, 04:23 PM
victzh is offline
Find More Posts by victzh
Registered User
Joined Oct 2012
334 Posts
It's a reasonably powerful processor, they coded it in C.
victzh is offline Find More Posts by victzh
Reply With Quote


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Cool The Official Tarheel R/C Flyers "discuss anything" thread Mike_Then Tarheel R/C Flyers 3782 Today 01:14 PM
Discussion The mSR Discuss anything Thread bublehead Micro Helis 12734 Apr 27, 2015 05:51 PM
Discussion 3d talk thread,Discuss anything 3d Benjamin Kies 3D Flying 7 Feb 04, 2015 05:41 AM
Discussion E-flite Blade SR 120 Discuss Anything Thread BJ64 Micro Helis 694 Jan 29, 2012 10:21 AM
Discussion Blade mCP X Discuss anything thread A Rdnek Micro Helis 457 Jul 26, 2011 11:34 PM