New Products Flash Sale
Thread Tools
Old May 20, 2015, 10:14 AM
Sessholvlaru is offline
Find More Posts by Sessholvlaru
Registered User
United States, NJ, Caldwell
Joined Apr 2007
374 Posts
Help!
10S won't charge through balance tab only (POS Term error)

I recently bought a second 10S that is barely used (I just love this charger). However, for some reason this one refuses to charge any batteries through just their balance tabs. I've tried several different batteries on several different power sources.

It gives me a "Check positive terminal" error every time. My other 10S does not exhibit this behavior.

What could this be?
Sessholvlaru is offline Find More Posts by Sessholvlaru
Reply With Quote
Sign up now
to remove ads between posts
Old May 21, 2015, 11:36 AM
Howard Matos is offline
Find More Posts by Howard Matos
AR-15 BRD!
Howard Matos's Avatar
Frederick, MD
Joined May 2002
1,050 Posts
Quote:
Originally Posted by Sessholvlaru View Post
I recently bought a second 10S that is barely used (I just love this charger). However, for some reason this one refuses to charge any batteries through just their balance tabs. I've tried several different batteries on several different power sources.

It gives me a "Check positive terminal" error every time. My other 10S does not exhibit this behavior.

What could this be?
Take an ohm reading on the plug blocker, you should be seeing approximately 4.63 k. Try switching your adapter. Let me know how you make out.

howard@fmadirect.com
Howard Matos is offline Find More Posts by Howard Matos
Reply With Quote
Old May 21, 2015, 01:04 PM
Sessholvlaru is offline
Find More Posts by Sessholvlaru
Registered User
United States, NJ, Caldwell
Joined Apr 2007
374 Posts
Hi Howard. My plug blocker is reading 4.6k Ohms. I also tried two different adapters.

It either gives me the positive terminal error or the "no plug blocker" error.

The charger seems to think about it for a while before giving the error.

Am I stuck sending it in?
Sessholvlaru is offline Find More Posts by Sessholvlaru
Reply With Quote
Old May 26, 2015, 09:38 AM
Howard Matos is offline
Find More Posts by Howard Matos
AR-15 BRD!
Howard Matos's Avatar
Frederick, MD
Joined May 2002
1,050 Posts
Quote:
Originally Posted by Sessholvlaru View Post
Hi Howard. My plug blocker is reading 4.6k Ohms. I also tried two different adapters.

It either gives me the positive terminal error or the "no plug blocker" error.

The charger seems to think about it for a while before giving the error.

Am I stuck sending it in?
That is all you can check at this point. Please log into your Revolectrix account and start a case requesting a RA. You will receive an email with the RA along with the return instructions.
Howard Matos is offline Find More Posts by Howard Matos
Reply With Quote


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Why can't I charge through just the balance leads Hummina Batteries and Chargers 6 Jan 27, 2015 09:24 AM
Discussion Parallel Charging with ParaBoard - won't finish balancing? oneskinnydave Batteries and Chargers 12 Jun 28, 2014 09:06 PM
Discussion Cellpro 10S - Max Size Lipo to Charge through just Balance Taps? boiko FMA Direct 2 Sep 05, 2012 05:30 PM
Discussion Resoldered Balance Tab, Still Won't Balance Toysrme Batteries and Chargers 9 Sep 30, 2011 05:31 AM
Discussion 10S error code withe Ch 2 -- Can't charge two packs Prof100 FMA Direct 6 Jul 03, 2010 11:59 PM