New Products Flash Sale
Thread Tools
Old Jan 29, 2016, 06:07 PM
Miniclip12 is offline
Find More Posts by Miniclip12
Registered User
Joined Jan 2013
33 Posts
Hello, I am having trouble flashing the f20a escs from h-king. I had the same problem as this earlier post
Quote:
Originally Posted by kiliam View Post
I am having a problem, trying to flash some hobbyking f-20a.
I am using an arduino with arduinosip sketch and i think i have everything well wired but using kkflashtool just gives me this:

Flash the firmware file.
Flashing firmware from file.: C:\Users\cortez\Downloads\tgy_2012-03-01_2e27c08\bs_nfet.hex

C:\Users\cortez\Downloads\kkmulticopterflashtool_0 .60beta10\lib\avrdude\windows\avrdude.exe -C C:\Users\cortez\Downloads\kkmulticopterflashtool_0 .60beta10\lib\avrdude\windows\avrdude.conf -p m8 -P COM3 -c arduino -B 8 -e -U flash:w:C:\Users\cortez\Downloads\tgy_2012-03-01_2e27c08\bs_nfet.hex:i

avrdude.exe: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.02s

avrdude.exe: Device signature = 0x1e950f
avrdude.exe: Expected signature for ATmega8 is 1E 93 07
Double check chip, or use -F to override this check.

avrdude.exe done. Thank you.

Error during writing flash.



Any suggestion?
so I tried the solution of addin the 10uf capacitor here
Quote:
Originally Posted by alteskind View Post
No, they didnt switch the chip, and it wont brick the ESC, as it wont flash the ESC .


the F-20A has an atmega8.

there is no problem to flash it using an arduino.
but u need a 120ohm resistor or a small capacitor (>10μF ) to disable autoreset on arduino


Reason for your problem: if you try to flash it with an arduino, unless switching arduino auto-reset off, the flashprog will flash your arduino instead of the ESC.


the solution is adding a 20μF capacitor between the RESET and GND lines (at arduino nano )
i used my arduino nano to flash my turnigy 9x, and it worked fine with this patch.



another way to disable autoreset using a resistor is described here. as i didnt have a 120ohm resistor, i did it the capacitor-way
http://www.arduino.cc/playground/Mai...rialConnection


those arduinoos are soooo useful, i like them.
but now I am getting this error:

/Applications/kkMulticopter Flash Tool.app/Contents/Resources/Java/lib/avrdude/mac/avrdude -C /Applications/kkMulticopter Flash Tool.app/Contents/Resources/Java/lib/avrdude/mac/avrdude.conf -p m8 -P /dev/cu.wchusbserialfa130 -c arduino -b 57600 -e -U lfuse:r:/Users/Abhishek/Library/Preferences/kkMulticopterFlashTool//lfuse.hex:r -U hfuse:r:/Users/Abhishek/Library/Preferences/kkMulticopterFlashTool//hfuse.hex:r
avrdude: stk500_recv(): programmer is not responding

avrdude done. Thank you.Error during reading of high fuse.


Flashing of firmware aborted.

I have tried everything and nothing has worked. plz help.im so confused
Miniclip12 is offline Find More Posts by Miniclip12
Reply With Quote
Sign up now
to remove ads between posts


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Rctimer 30A esc cutting out with KK board Efliernz Multirotor Talk 2 May 26, 2011 03:20 PM
Sold FS: Tricopter Parts- HK401b, Pentium 30A ESC, rctimer 750kv motors pwu_1 Aircraft - General - Miscellaneous (FS/W) 2 Jan 18, 2011 10:58 PM
Sold RCTimer 2826-6 + ESC 30A New in packaging will trade as well Pics Added! planebldr Aircraft - Electric - Power Systems (FS/W) 4 May 25, 2010 10:54 PM
Discussion RCTimer 30A Programmable ESC hunter7193 Power Systems 8 Jan 02, 2010 03:27 PM
For Sale Several New ESC's - 10a, 20a, 30a - Reduced Callen9345 Aircraft - Electric - Power Systems (FS/W) 0 Apr 20, 2009 03:31 PM