HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Aug 13, 2014, 10:26 PM
build, fly, crash, repeat
BrendanH's Avatar
United States, WA, Spokane
Joined Jul 2012
464 Posts
Help!
Blade Nano QX loss of connection?

Hi everyone,

Been having some issues with my Spektrum DX6i. I had been experiencing brownouts so I sent it in and had Horizon service it for me. Today when I got it back from HH, I bound it to my Nano CPX and had zero problems. Although, when bound to the Nano QX, I experience the same loss of connection. Everything will work fine for a few seconds then the light goes red and I lose control of everything but power.

Very confused,

Brendan
BrendanH is offline Find More Posts by BrendanH
RCG Plus Member
Latest blog entry: Good week!
Reply With Quote
Sign up now
to remove ads between posts
Old Aug 14, 2014, 05:27 PM
Registered User
United States, MD, Annapolis
Joined Jun 2013
2,228 Posts
Check battery on tx, battery on nqx etc. I'm thinking the nqx has a faulty 1s.
Waterbound is offline Find More Posts by Waterbound
RCG Plus Member
Reply With Quote
Old Aug 14, 2014, 07:04 PM
build, fly, crash, repeat
BrendanH's Avatar
United States, WA, Spokane
Joined Jul 2012
464 Posts
Quote:
Originally Posted by Waterbound View Post
Check battery on tx, battery on nqx etc. I'm thinking the nqx has a faulty 1s.
Replaced batts in TX, and this occurs with all of my Eflite 1s 150mah batts. Should I try a different brand? Hyperion?
BrendanH is offline Find More Posts by BrendanH
RCG Plus Member
Latest blog entry: Good week!
Reply With Quote
Old Aug 14, 2014, 07:10 PM
A380 Pilot - It's a wank
BieneFlyer's Avatar
Australia
Joined Mar 2013
628 Posts
That always happens to me when my DX6i batteries are getting low.

That's the one thing wrong with the DX6i. The thing is battery hungry.

I'm going to look for some LiPo alternatives.
BieneFlyer is offline Find More Posts by BieneFlyer
Reply With Quote
Old Aug 14, 2014, 07:23 PM
build, fly, crash, repeat
BrendanH's Avatar
United States, WA, Spokane
Joined Jul 2012
464 Posts
Quote:
Originally Posted by BieneFlyer View Post
That always happens to me when my DX6i batteries are getting low.

That's the one thing wrong with the DX6i. The thing is battery hungry.

I'm going to look for some LiPo alternatives.
Hmm. I'll try some different batteries and report back.
BrendanH is offline Find More Posts by BrendanH
RCG Plus Member
Latest blog entry: Good week!
Reply With Quote
Old Aug 14, 2014, 07:52 PM
build, fly, crash, repeat
BrendanH's Avatar
United States, WA, Spokane
Joined Jul 2012
464 Posts
Tried lots of new TX batteries and they all had the same result.
BrendanH is offline Find More Posts by BrendanH
RCG Plus Member
Latest blog entry: Good week!
Reply With Quote
Old Aug 15, 2014, 07:02 AM
Registered User
Dubbin1's Avatar
United States, OH, Findlay
Joined Jan 2013
249 Posts
If its only doing it when you're flying the NQX I would have to say its a problem with the quad not the transmitter.
Dubbin1 is offline Find More Posts by Dubbin1
Reply With Quote
Old Aug 15, 2014, 10:52 AM
build, fly, crash, repeat
BrendanH's Avatar
United States, WA, Spokane
Joined Jul 2012
464 Posts
Quote:
Originally Posted by Dubbin1 View Post
If its only doing it when you're flying the NQX I would have to say its a problem with the quad not the transmitter.
That's what I thought too but it doesn't occur when I use the DX4 thing that the Nano QX came with.
BrendanH is offline Find More Posts by BrendanH
RCG Plus Member
Latest blog entry: Good week!
Reply With Quote
Old Aug 15, 2014, 10:54 AM
Registered User
Dubbin1's Avatar
United States, OH, Findlay
Joined Jan 2013
249 Posts
Quote:
Originally Posted by BrendanH View Post
That's what I thought too but it doesn't occur when I use the DX4 thing that the Nano QX came with.
Did you try a rebind?
Dubbin1 is offline Find More Posts by Dubbin1
Reply With Quote
Old Aug 15, 2014, 10:58 AM
build, fly, crash, repeat
BrendanH's Avatar
United States, WA, Spokane
Joined Jul 2012
464 Posts
Quote:
Originally Posted by Dubbin1 View Post
Did you try a rebind?
Multiple times. I'm going to check the manual and see if there is a special way to bind to a computer transmitter vs. cheap transmitter.
BrendanH is offline Find More Posts by BrendanH
RCG Plus Member
Latest blog entry: Good week!
Reply With Quote
Old Aug 15, 2014, 11:02 AM
Registered User
Dubbin1's Avatar
United States, OH, Findlay
Joined Jan 2013
249 Posts
Quote:
Originally Posted by BrendanH View Post
Multiple times. I'm going to check the manual and see if there is a special way to bind to a computer transmitter vs. cheap transmitter.
On your 6i all you need to do is hold the bind switch, you don't need to move either one of the sticks.
Dubbin1 is offline Find More Posts by Dubbin1
Reply With Quote
Old Aug 15, 2014, 11:08 AM
build, fly, crash, repeat
BrendanH's Avatar
United States, WA, Spokane
Joined Jul 2012
464 Posts
Rebound per manual instructions and it works like a charm! Thanks Dubbin!

Brendan

PS: In case you're wondering, the only thing I had done wrong was input the wrong model type (Heli instead of Plane). Fixed this and no more connection loss *knock on wood*
BrendanH is offline Find More Posts by BrendanH
RCG Plus Member
Latest blog entry: Good week!
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product NEW Blade Nano QX RCaDDiCT! Mini Multirotors 5707 Yesterday 08:19 PM
News Blade Helis: Nano QX Tip and Tricks awagar Multirotor Talk 22 Aug 02, 2014 06:17 PM
Sold My nano quad lot (blade nano qx FC) ummagawd Aircraft - Electric - Multirotor (FS/W) 4 Oct 10, 2013 02:58 PM
Sold Blade Nano QX RTF. vacahtu Aircraft - Electric - Multirotor (FS/W) 4 Jun 27, 2013 03:29 PM
Sold Blade Nano QX RTF. vacahtu Aircraft - General - Miscellaneous (FS/W) 0 Jun 25, 2013 07:58 PM