HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Dec 09, 2012, 05:34 PM
Tampa,Fl
Dale 813's Avatar
United States, FL, Tampa
Joined Jan 2007
1,493 Posts
Discussion
Charger won't charge my LIFE batt

I have a Duralite sentinel A123 LIFE batt 2300mah. Charged it fine yesterday on a buddies charger. This is a different buddies charger. Onyx 245. It's giving me a Err 8 Balance voltage error. It reads if balance cell voltage is more or less than acceptable voltage of each battery, this error should occur. My battery has an internal balance board so ya just hook up the deans and charge. Now that being said. I have never liked these chargers so IMO, there junk. My Turnigy will be here some time this year from Hobbyking need some input guys. Thanks
Dale 813 is offline Find More Posts by Dale 813
Reply With Quote
Sign up now
to remove ads between posts
Old Dec 09, 2012, 05:53 PM
RC Helicopter Pilot
TheWoodCrafter's Avatar
United States, CA, Westminster
Joined Mar 2010
1,696 Posts
Quote:
Originally Posted by Dale 813 View Post
My battery has an internal balance board so ya just hook up the deans and charge.
What the heck is an internal balance board?

So you don't need to plug a balance lead from the battery into your charger and it automatically balances by itself?

I would have to see this to believe it.
TheWoodCrafter is offline Find More Posts by TheWoodCrafter
Reply With Quote
Old Dec 09, 2012, 06:05 PM
Registered User
United States, NJ, Frenchtown
Joined Mar 2003
9,122 Posts
I think his battery has a protective circuit board glued under the battery heat shrink. It normaly is used in consumer applications..........Not RC planes.
cyclops2 is offline Find More Posts by cyclops2
Reply With Quote
Old Dec 09, 2012, 06:11 PM
Registered User
United States, NJ, Frenchtown
Joined Mar 2003
9,122 Posts
It is a complete Protection Board to only do a safe recharge @ 3C, bad cells stop any charges............It is only on 6.6 & 7.2 packs.2500 mahr

Web site was skimpy on data.
cyclops2 is offline Find More Posts by cyclops2
Reply With Quote
Old Dec 09, 2012, 06:12 PM
Tampa,Fl
Dale 813's Avatar
United States, FL, Tampa
Joined Jan 2007
1,493 Posts
Name: image.jpg
Views: 53
Size: 281.8 KB
Description:
Dale 813 is offline Find More Posts by Dale 813
Reply With Quote
Old Dec 09, 2012, 06:14 PM
Tampa,Fl
Dale 813's Avatar
United States, FL, Tampa
Joined Jan 2007
1,493 Posts
Aside from the deans end connector I have two leads and a small lead. Like I said. Yesterday, it charged on another charger. Name: image.jpg
Views: 57
Size: 274.8 KB
Description:
Dale 813 is offline Find More Posts by Dale 813
Reply With Quote
Old Dec 09, 2012, 06:20 PM
Registered User
United States, NJ, Frenchtown
Joined Mar 2003
9,122 Posts
maybe the non charger is not designed to do 2 cells ? Or it is defective on 2 cells ?
cyclops2 is offline Find More Posts by cyclops2
Reply With Quote
Old Dec 09, 2012, 06:35 PM
Tampa,Fl
Dale 813's Avatar
United States, FL, Tampa
Joined Jan 2007
1,493 Posts
Quote:
Originally Posted by cyclops2 View Post
maybe the non charger is not designed to do 2 cells ? Or it is defective on 2 cells ?
Which charger are you talking about ? The Onyx 245 or the Turnigy that charged it fine yesterday ?
Dale 813 is offline Find More Posts by Dale 813
Reply With Quote
Old Dec 09, 2012, 06:40 PM
Registered User
United States, NJ, Frenchtown
Joined Mar 2003
9,122 Posts
The one that refused to charge the 2 cell pack.
cyclops2 is offline Find More Posts by cyclops2
Reply With Quote
Old Dec 09, 2012, 07:04 PM
Tampa,Fl
Dale 813's Avatar
United States, FL, Tampa
Joined Jan 2007
1,493 Posts
It's a brand new Onyx 245. Is says it charges LIFE but who knows. Maybe I'll ge lucky and my Turnigy charger will be here tomorrow from HK.
Dale 813 is offline Find More Posts by Dale 813
Reply With Quote
Old Dec 09, 2012, 08:53 PM
Registered User
United States, MN
Joined Feb 2011
4,374 Posts
You selected LIFE on the Onyx 245 right? It does have a specific setting for it.
grimbeaver is offline Find More Posts by grimbeaver
Reply With Quote
Old Dec 09, 2012, 09:24 PM
Registered User
nj
Joined Jan 2004
1,430 Posts
I charge big 2s 4200 life packs all the time on my onyx 245 never had a problem... maybe it's not working because it senses the protector board in the pack?
reptileman is offline Find More Posts by reptileman
Reply With Quote
Old Dec 09, 2012, 09:51 PM
Tampa,Fl
Dale 813's Avatar
United States, FL, Tampa
Joined Jan 2007
1,493 Posts
Quote:
Originally Posted by grimbeaver View Post
You selected LIFE on the Onyx 245 right? It does have a specific setting for it.
Yes. I tried the other leads as well as the deans end. The result is the same. I also tried putting the settings at different charge amps with no success. I'll see what happens when I use a different charger.
Dale 813 is offline Find More Posts by Dale 813
Reply With Quote
Old Dec 10, 2012, 03:31 AM
Registered User
nj
Joined Jan 2004
1,430 Posts
Hi looked in my manual it say's error8 is when voltage of pack is not correct over or under so one of the cells can be to low or to high.

also make sure the positive and negitive plugs on the charger are in the correct way and sometimes on packs the little radio plug plus and minus could be reversed ... take a look over it all.
reptileman is offline Find More Posts by reptileman
Reply With Quote
Old Dec 10, 2012, 05:28 AM
Tampa,Fl
Dale 813's Avatar
United States, FL, Tampa
Joined Jan 2007
1,493 Posts
Quote:
Originally Posted by reptileman View Post
Hi looked in my manual it say's error8 is when voltage of pack is not correct over or under so one of the cells can be to low or to high.

also make sure the positive and negitive plugs on the charger are in the correct way and sometimes on packs the little radio plug plus and minus could be reversed ... take a look over it all.
Yep. I double checked and re checked the polarity. Used the deans, and the little RX plug. I'll plug it in a different charger and get post back.
Dale 813 is offline Find More Posts by Dale 813
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question Can I charge a LiFe Tx batt. with a basic Lipo charger? Just4parts Batteries and Chargers 5 Jun 03, 2012 02:09 PM
Discussion PowerLab 8 won't auto discharge after charge (won't cycle) martinwinlow FMA Direct 6 Apr 08, 2012 05:26 AM
Discussion eflite charger won't charge my pack. Beeps error. Help a noob plz CarComp Batteries and Chargers 8 Sep 06, 2009 02:26 PM
Help! Batt won't hold charge bizzo Batteries and Chargers 12 Aug 24, 2006 11:38 AM
Can I use my new GWS MC2002 Charger to charge my Transmitter Batts? mrebman Batteries and Chargers 16 Jan 09, 2003 10:12 AM