HobbyKing.com New Products Flash Sale
Thread Tools
Old Dec 23, 2012, 10:23 PM
Registered User
MaydayMayday's Avatar
United States, CA, Fremont
Joined Jul 2011
769 Posts
Blade MSR X No servo movement, servo hot

So I just got this MSR X used, knowing that the elevator servo was bad.

tried all the little tricks that the various groups said to try to free up the servo, no luck, it didn't even twitch, and gets very hot.

Cut the wires and twisted the wires onto to the new servo. But didn't mount the servo, Turn it on, it twitches and moves all the way to the top and stops, and gets VERY hot. When I move the elevator control, no response

Is this because of a bad board, or maybe because I don't have it mounted? I only think this because this servo moves and the other one doesn't.

I'm reluctant to mount the servo and solder it because I don't want to screw up this servo if the board is bad.

So I thought I would post this before doing anything further.

Give me your thoughts and ideas how to resolve this.

Thank you in advance.
MaydayMayday is offline Find More Posts by MaydayMayday
Reply With Quote
Sign up now
to remove ads between posts
Old Dec 24, 2012, 01:26 AM
Registered User
MaydayMayday's Avatar
United States, CA, Fremont
Joined Jul 2011
769 Posts
- I installed the servo, still doesn't move but doesn't get hot anymore.

Also, is it possible I think I have an issue but I don't because I have it bound to my Dx8? Is there maybe something there that is setup wrong, I haven't adjusted any setting just selected HELI and then bound the copter. The reason I ask is because when I press full right rudder the rudder servo goes nut and doesn't stop till I press full left.
MaydayMayday is offline Find More Posts by MaydayMayday
Reply With Quote
Old Dec 24, 2012, 08:51 AM
banging head on wall
skyeblu's Avatar
United States, CA, Santa Rosa
Joined Feb 2010
1,199 Posts
The binding instuctions say to use acro mode

1. Disconnect the flight battery from the helicopter.
2. Select a clean model memory on your transmitter (computer radios only).
3. Select Acro or Airplane model type on your transmitter.
4. Make sure all servo reversing is set to Normal on your transmitter.
5. Center all trims and make sure sub-trims are disabled (zeroed) on your transmitter.
6. Power off the transmitter and move all switches to the 0 position. Move the throttle to the low/off position.
7. Connect the flight battery in the helicopter. The LED on the 4-in-1 control unit flashes after 5 seconds.
8. Put the transmitter into bind mode while powering on the transmitter.
9. Release the bind button or switch on your transmitter after 2–3 seconds. The helicopter is bound when
the blue LED on the 4-in-1 control unit is solid.
10. Disconnect the flight battery and power the transmitter off.
skyeblu is offline Find More Posts by skyeblu
Last edited by skyeblu; Dec 24, 2012 at 01:44 PM.
Reply With Quote

Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Question Crona 4 channel receiver problems ? Lock in & no servo movement ? cyclops2 Radios 1 Dec 19, 2012 07:41 AM
Wanted Blade mSR X or mSR BNF scottieusa Aircraft - Electric - Helis (FS/W) 1 Dec 12, 2012 01:45 AM
Discussion 130x no servo movement sing23 Electric Heli Talk 0 Aug 12, 2012 10:05 PM
Question Blade mSR X circles CCW when no inputs given ltx Micro Helis 21 Jun 26, 2012 12:09 PM
Discussion Blade MSR X Starts flying forward or backward with no input scohrdarkshado Micro Helis 1 Mar 07, 2012 08:44 PM