HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Jan 10, 2015, 09:47 AM
Registered User
Joined Sep 2012
11 Posts
Help!
Some servos wont work?

Hi.
I started up my new Durafly Vampire today and some things didn't work. The ailerons, throttle and rudder channels worked fine, however the elevator and retract channels don't seem to.

I know that the elevator servo is getting power because I can hear a quiet buzzing from it, but I don't know about the retracts.

Help.
DarthRoar is offline Find More Posts by DarthRoar
Reply With Quote
Sign up now
to remove ads between posts
Old Jan 10, 2015, 10:03 AM
Registered User
Joined Sep 2012
11 Posts
I tried switching around the aileron and elevator channels and it was the same story, the aileron servos worked but the elevator servo still didn't.
DarthRoar is offline Find More Posts by DarthRoar
Reply With Quote
Old Jan 10, 2015, 10:28 AM
Registered User
Joined Sep 2012
11 Posts
Well I tried just plugging one retract servo into the gear channel and it worked, but when all three are connected with a three way connector they don't...
DarthRoar is offline Find More Posts by DarthRoar
Reply With Quote
Old Jan 10, 2015, 11:33 AM
Da' Cajun
Boogie_'s Avatar
Lake Charles, Louisiana
Joined Jun 2009
2,981 Posts
Is the the polarity is correct when plugging in the servo connectors?
Boogie_ is online now Find More Posts by Boogie_
Reply With Quote
Old Jan 10, 2015, 11:45 AM
Registered User
Joined Sep 2012
11 Posts
Quote:
Originally Posted by Boogie_ View Post
Is the the polarity is correct when plugging in the servo connectors?
I believe they can only go in one way?
DarthRoar is offline Find More Posts by DarthRoar
Reply With Quote
Old Jan 10, 2015, 11:58 AM
Registered User
Joined Sep 2012
11 Posts
Well I found that I can add the 2 rear retracts to any of the ports on the three way splitter and it works fine, but when I add the nose retract none of them work regardless of which port they are in.
DarthRoar is offline Find More Posts by DarthRoar
Reply With Quote
Old Jan 10, 2015, 12:09 PM
Registered User
Joined Sep 2012
11 Posts
Quote:
Originally Posted by Boogie_ View Post
Is the the polarity is correct when plugging in the servo connectors?
Well I found they can go in two ways and thats why. Thanks.
DarthRoar is offline Find More Posts by DarthRoar
Reply With Quote
Old Jan 10, 2015, 12:33 PM
222 km/hr Parkjet flyer
solentlife's Avatar
Latvia, Ventspils pilsēta, Ventspils
Joined Jan 2010
9,695 Posts
Quote:
Originally Posted by DarthRoar View Post
Well I found they can go in two ways and thats why. Thanks.
Its why Futaba has the tab on the side of the plug .... to make sure it goes in one way only. (And most people unless they use Futaba Rx ... cut that tab off !)

But of course everyone else with the JR style plug - no tab .. and even though the plug has a shape to it - it can as you found out be plugged in wrong way round.

In the old days of JR when that plug first appeared - it only went in one way ... the socket had plastic guide to make sure :



You can see the curved shape one side of socket matches the plug ...

But of course in the quest for smaller Rx's etc. - that plastic guide is removed and all pins are now in one hole with no separation plastic.

Nigel
solentlife is offline Find More Posts by solentlife
Reply With Quote
Old Jan 10, 2015, 03:50 PM
Registered User
4stripes's Avatar
Canada, ON, Burlington
Joined Jan 2009
3,625 Posts
Have you checked the receiver operating voltage during operation? Some BECs integral to ESCs are rather weak in output. It could also be a poor connector but it isn't inconceivable that you have some dud components. The stock servos are not great on many ARFs. The servoless type retracts also will jam very easily if the gear leg comes in contact with any part of the structure or the retract motor area. Make sure the leg and wheel is completely free when retracted or it may not extend.
4stripes is online now Find More Posts by 4stripes
Reply With Quote
Old Jan 11, 2015, 03:21 AM
222 km/hr Parkjet flyer
solentlife's Avatar
Latvia, Ventspils pilsēta, Ventspils
Joined Jan 2010
9,695 Posts
Quote:
Originally Posted by 4stripes View Post
Have you checked the receiver operating voltage during operation? Some BECs integral to ESCs are rather weak in output. It could also be a poor connector but it isn't inconceivable that you have some dud components. The stock servos are not great on many ARFs. The servoless type retracts also will jam very easily if the gear leg comes in contact with any part of the structure or the retract motor area. Make sure the leg and wheel is completely free when retracted or it may not extend.
If you go back a couple of posts - he plugged servos in wrong way round .. a common error ...

Nigel
solentlife is offline Find More Posts by solentlife
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! lightbridge wont work..... occhiblughiaccio FPV Equipment 1 Jan 29, 2015 05:31 AM
Help! Phantom 2 vision plus camera tilt and battery life % wont work avs Scotland DJI-Innovations 1 Oct 06, 2014 10:39 AM
Help! Tail servo wont work! RCDestroyer Electric Heli Talk 2 Jul 15, 2011 02:18 PM
Help! servos have power but wont work redwoodace Off-road Cars 1 Jul 01, 2009 07:26 AM
Discussion servo wont work typhoon/dx6i keithn4 Beginner Training Area (Aircraft-Electric) 5 Apr 25, 2008 07:36 AM