Espritmodel.com Telemetry Radio
Reply
Thread Tools
Old Nov 19, 2001, 03:34 PM
Registered User
los angeles,ca
Joined Jun 2001
224 Posts
help in restoring performance on zagi

Hello everyone,
After flying my zagi for about 15 times, I notice the performance wasn't like it used to be. It used to do loops on level flights but not anymore. The speed and climb seems to have decreased. Is there anything I can do or check to restore the performance on my zagi 400x. The setup is p450, 6.5X4 aeronaut, 8xcp1300 with astroflight 215d esc. Any suggestions and advice is deeply appreciated. Thanks for your time and concern.

bill
billyboy is offline Find More Posts by billyboy
Reply With Quote
Sign up now
to remove ads between posts
Old Nov 19, 2001, 04:00 PM
SKINNI MINI flyer
Barrett's Avatar
Pearl River, LA, USA
Joined Sep 2001
645 Posts
Im not familar with all the equipment that you are using, but only 15 flights seems like a short life. Maybe you can be a little more specific with us. Like, what kind of throttle do you use during a flight, full power non stop will decrease performance over time. So if you go all out all the time maybe you should slow down every now and then. Also are you giving your motor and batteries time to cool between flights? Always wait until everything (batts, motor, ESC, servos, etc, etc..) has chilled out before your next flight. Or in the case of batteries wait to charge them as well.
Check to see if anything gets way to hot after a flight. Ive heard that batts and motor should only be warm under normal flying conditions in a plane like a zagi or speed 400 size plane. And im in no way an expert on these things so just remember that im trying to get you thinking, so post again with a little more info and see what the guys and gals here come up with. Good luck!
Barrett is offline Find More Posts by Barrett
Reply With Quote
Old Nov 19, 2001, 05:33 PM
Registered User
los angeles,ca
Joined Jun 2001
224 Posts
Sorry for the lack of info. My zagi has about 40 flights. I took it out about 15 times with 2-3 paks everytime. I never quick charge it at the field. I always let it cool before I charge it at home. My paks are warm not hot after flight but not sure about my motor or esc. I fly it at full throttle almost all the time. I charge my paks at 1C. Let me know what other info you guys need to help me figure out what is wrong. Thanks

bill
billyboy is offline Find More Posts by billyboy
Reply With Quote
Old Nov 19, 2001, 06:54 PM
Registered User
Pasadena
Joined Oct 2001
343 Posts
performance

sounds like you've worn out your brushes. spend 5-10$ and replace them. That should do the trick.
Waxer is offline Find More Posts by Waxer
Reply With Quote
Old Nov 19, 2001, 07:06 PM
Registered User
mtayl's Avatar
Boulder, CO USA
Joined Sep 2001
1,405 Posts
Three things to check: your motor, prop or battery. Sounds silly I know, but make sure your prop isn't slipping on you. I'm not familiar with the p450 but if you can change your brushes then check those.

Your pack is another obvious thing to look at. It was unclear in your post whether or not you are seeing this slowdown with all three of your packs. If you are, then I would certainly suspect your motor. Do you have another one you can quickly swap it out with? I fly full bore most of the time but I also do 1 minute of just tooling around kind of stuff to give my motor a chance to cool off before it's vertical again.
mtayl is offline Find More Posts by mtayl
Reply With Quote
Old Nov 19, 2001, 11:34 PM
Registered User
los angeles,ca
Joined Jun 2001
224 Posts
Thanks for the replys. I will check out my brushes. How do I know when the brushes are bad. Where can I get some brushes. Does it have to be the brushes for that motor or all brushes are universal. If it is the battery how can I improve the performce on my battery. Thanks again.
bill
billyboy is offline Find More Posts by billyboy
Reply With Quote
Old Nov 20, 2001, 11:18 AM
SKINNI MINI flyer
Barrett's Avatar
Pearl River, LA, USA
Joined Sep 2001
645 Posts
A good charger like the FMA supernova or the Robbe infinity II will be a good investment if you want a way to not only improve you battery performance but also have a way to monitor thier performance.
Barrett is offline Find More Posts by Barrett
Reply With Quote
Old Nov 20, 2001, 02:16 PM
Registered User
RonJ's Avatar
Sparta,WI,USA
Joined Nov 2000
1,537 Posts
Sounds like my Zagi-X a month ago. Checked it out with a tachometer and revs were down almost 2000.
A drop of oil on each end of the shaft and the revs picked up a little, This is on a Max 480 with a MAS 5.5x4.5 prop and Zagi's 8-1700 nicad set up. The old Zag is heavy and well used.
Dymond had a cobalt 480 on the shelf at a price I couldn't refuse. We matched it to an APC E-prop and headed for the field. I could tell by the sound that it was going to go, and it did. A new experience from an old war horse. I like it, especially when I cranked up the throws.
I have a couple of can type 400 motors that I feel are worn out, i.e. can't get the revs out of them anymore. For 8 bucks or so I could get a new one. For 40 bucks more I got a cobalt with bearings and replacable brushes and some serious power.
RonJ is offline Find More Posts by RonJ
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! Can I use any of these GB's on a Zagi? RandyK1 Power Systems 14 Feb 12, 2003 04:48 PM
Help in Removing Stick on Graphics kelvin Electric Plane Talk 2 Dec 09, 2002 12:04 PM
Help me break my plane - Zagi combat in Florida (Pasco, Pinellas, Hillsborough) Joe B Foamies (Kits) 5 Mar 19, 2002 07:26 AM
Help me break my plane - Zagi combat in Florida (Pasco, Pinellas, Hillsborough) Joe B Electric Plane Talk 1 Mar 17, 2002 01:37 AM
Confused on Zagi Upgrade Please Help Photo Attached dntmn Foamies (Kits) 8 Mar 04, 2002 01:43 PM