New Products Flash Sale
Thread Tools
Old Nov 10, 2014, 11:58 AM
Dwayne Dibbley is offline
Find More Posts by Dwayne Dibbley
Registered User
Dwayne Dibbley's Avatar
United Kingdom, England, Ivybridge
Joined Sep 2013
38 Posts
Is there a recommended version of BruGi ? currently i have flashed 050 r217 on to the V3 Martinez Board, loaded the suggested gopro params from the included txt file.

But when i power up the controller ( from dedicated 3s pack ) blue led comes on and motors twitch once the stay still, moving the camera around nothing moves .

in the GUI when clicking wave view, if i tilt camera upwards i get a + roll and if i rotate the camera right ( from behind the gimbal ) i also get + roll so IMU seems to be working.

Is there a way of testing the motors somehow to tell if they are going the correct way...


Thanks
Dwayne Dibbley is offline Find More Posts by Dwayne Dibbley
Reply With Quote
Sign up now
to remove ads between posts
Old Nov 11, 2014, 07:42 PM
mark_q is offline
Find More Posts by mark_q
Seattle, WA & Las Vegas, NV
mark_q's Avatar
Joined Sep 2003
3,937 Posts
Quote:
Originally Posted by Dwayne Dibbley View Post
Is there a recommended version of BruGi ? currently i have flashed 050 r217 on to the V3 Martinez Board, loaded the suggested gopro params from the included txt file.

But when i power up the controller ( from dedicated 3s pack ) blue led comes on and motors twitch once the stay still, moving the camera around nothing moves .

in the GUI when clicking wave view, if i tilt camera upwards i get a + roll and if i rotate the camera right ( from behind the gimbal ) i also get + roll so IMU seems to be working.

Is there a way of testing the motors somehow to tell if they are going the correct way...


Thanks

The good news is it sounds like you have the drivers working. For more information on setting this board up, please visit my wiki pages here:

http://www.itsqv.com/QVW/index.php?t...troller_Set-Up

It includes a section on motor direction and how to check but this is likely not what is causing your issue. A functioning controller will still function with the motors reversed, it will just lag and drift (slowly) away from level.

Your issue could be simple PID & PWM tuning which is also covered on my set-up pages.

As far as firmware, make sure you are getting it from the Sourceforge site and yes, r217 is good.

It might help to know what motors you are using and what camera you are using. The most common error generating issue is balance and wire tension. For balance, the camera mount must be adjusted such that no matter what position you place it in with power OFF, it stays there. It is OK if it moves one magnet cog but it should not move more than that. Wire tension can never tug against the intended motion either but this should be covered in the balancing.

Hope that helps
Mark
mark_q is offline Find More Posts by mark_q
RCG Plus Member
Latest blog entry: $65 Mobile Launcher
Reply With Quote
Old Nov 12, 2014, 12:06 PM
Dwayne Dibbley is offline
Find More Posts by Dwayne Dibbley
Registered User
Dwayne Dibbley's Avatar
United Kingdom, England, Ivybridge
Joined Sep 2013
38 Posts
Quote:
Originally Posted by mark_q View Post
The good news is it sounds like you have the drivers working. For more information on setting this board up, please visit my wiki pages here:

http://www.itsqv.com/QVW/index.php?t...troller_Set-Up

It includes a section on motor direction and how to check but this is likely not what is causing your issue. A functioning controller will still function with the motors reversed, it will just lag and drift (slowly) away from level.

Your issue could be simple PID & PWM tuning which is also covered on my set-up pages.

As far as firmware, make sure you are getting it from the Sourceforge site and yes, r217 is good.

It might help to know what motors you are using and what camera you are using. The most common error generating issue is balance and wire tension. For balance, the camera mount must be adjusted such that no matter what position you place it in with power OFF, it stays there. It is OK if it moves one magnet cog but it should not move more than that. Wire tension can never tug against the intended motion either but this should be covered in the balancing.

Hope that helps
Mark
The motors i am using are 0.15mm/70T/18ohm from http://quadframe.com/collections/cm/products/bldc_m_01

Camera is a GoPro Hero 2 on a 2 axis quadframe gimbal again from http://quadframe.com/products/bldc_g_001

camera i balanced as instructed, IMU mounted on top imu facing up and dot facing rear left ( viewed from behind camera )

GUI uncheck Z for imu so Z it upwards.

Thanks
Dwayne Dibbley is offline Find More Posts by Dwayne Dibbley
Reply With Quote
Old Dec 24, 2014, 03:13 PM
luanthon is offline
Find More Posts by luanthon
Anthony lu
Ukraine, Lviv Oblast, Lviv
Joined Dec 2014
6 Posts
Hi All
I use gimbal with 2 axis ( pitch and yaw). Is it possible to modify IMU.ino file to control them.
Thank,s for any ideas.
luanthon is offline Find More Posts by luanthon
Reply With Quote
Old Dec 29, 2014, 05:58 PM
pataro is offline
Find More Posts by pataro
Registered User
Joined May 2014
102 Posts
Here I post my 2 last videos.
Open source Martinez type board, 050_R217 firmw. , fpv monkey gimbal, Mbius camera, wltoys v303, rcpitch controlled by RC, and YouTube stabilization image
Edited with W7 Movie Maker

Every thing is fine

Arroyo de la Vega, Alcobendas. Video con drone. (1 min 39 sec)


Madrid East (2 min 50 sec)
pataro is offline Find More Posts by pataro
Reply With Quote
Old Jan 28, 2015, 05:08 AM
Mjeduar is offline
Find More Posts by Mjeduar
Registered User
Joined Feb 2014
4 Posts
Stunning Gimbals

This site is offering great gimbals base on alexmos http://www.stunningmovement.com.au/ I bought a gimbal here an is excellent, I highly recommend it.
Mjeduar is offline Find More Posts by Mjeduar
Reply With Quote
Old Feb 09, 2015, 01:46 AM
sliver001 is offline
Find More Posts by sliver001
Registered User
Joined Mar 2014
1 Posts
Please share the file hex or bin that is running firmware. Arudino can not connect to the gimbal controller.
sliver001 is offline Find More Posts by sliver001
Reply With Quote
Old Feb 12, 2015, 04:44 PM
RM_Sparks is offline
Find More Posts by RM_Sparks
We Do It With FRQZ
RM_Sparks's Avatar
United States, CA, San Diego
Joined Aug 2009
2,299 Posts
So what if my board did not come with a boot loader? Am I hosed? Also I am using a MAC.
RM_Sparks is offline Find More Posts by RM_Sparks
Reply With Quote
Old Feb 12, 2015, 05:17 PM
Truglodite is offline
Find More Posts by Truglodite
Registered Aircraft Offender
Truglodite's Avatar
Carmichael, CA
Joined Feb 2007
3,545 Posts
I think you can flash a new bootloader using arduino with spi (ie with a usbasp). The bootloader for the 328 chip is built in to arduino.

Kev
Truglodite is offline Find More Posts by Truglodite
Reply With Quote
Old Feb 13, 2015, 09:35 AM
RM_Sparks is offline
Find More Posts by RM_Sparks
We Do It With FRQZ
RM_Sparks's Avatar
United States, CA, San Diego
Joined Aug 2009
2,299 Posts
I am Ardurino, ugh to say this politely...... I'm "slow" when it comes to arduino, so I guess I have some research to do haha.
RM_Sparks is offline Find More Posts by RM_Sparks
Last edited by RM_Sparks; Feb 27, 2015 at 11:15 AM.
Reply With Quote
Old Feb 24, 2015, 11:48 AM
pataro is offline
Find More Posts by pataro
Registered User
Joined May 2014
102 Posts
Here I post the last video with the Open Source brushless gimbal, and Mobius Cam in a wltoys v303.

Im trying to check structures with this rig, and if things goes on, change to an hexa F550 with Pixhawk, same gimbal and cam.

The complete video has two problems, on one hand vibs, reduced with youtube estabilization algorithm, and the other, more important, is that some times gimbal gets crazy and unlevel roll 20-40 so I have to land, wait till gets rigth level and unland again.
I can not solve this problem, ideas?

https://www.youtube.com/watch?featur...&v=42CfhLILJ40
pataro is offline Find More Posts by pataro
Reply With Quote
Old Feb 24, 2015, 01:16 PM
mark_q is offline
Find More Posts by mark_q
Seattle, WA & Las Vegas, NV
mark_q's Avatar
Joined Sep 2003
3,937 Posts
Quote:
Originally Posted by pataro View Post
Here I post the last video with the Open Source brushless gimbal, and Mobius Cam in a wltoys v303.

Im trying to check structures with this rig, and if things goes on, change to an hexa F550 with Pixhawk, same gimbal and cam.

The complete video has two problems, on one hand vibs, reduced with youtube estabilization algorithm, and the other, more important, is that some times gimbal gets crazy and unlevel roll 20-40 so I have to land, wait till gets rigth level and unland again.
I can not solve this problem, ideas?

https://www.youtube.com/watch?featur...&v=42CfhLILJ40
Hi pataro,

I posted a response to this on the Martinez thread.

Cheers!
Mark
mark_q is offline Find More Posts by mark_q
RCG Plus Member
Latest blog entry: $65 Mobile Launcher
Reply With Quote
Old Feb 28, 2015, 04:00 AM
seafurymike is offline
Find More Posts by seafurymike
Registered User
Joined Mar 2011
302 Posts
I killed my bootloader on the Martinez board. Here is how i recovered it so i could flash the latest firmware again.hope someone finds this useful.

How to Burn (recover) a bootloader to your Martinez board (12 min 5 sec)
seafurymike is offline Find More Posts by seafurymike
Reply With Quote


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion The OSRC Project - Open Source Remote Control mdem Australia 16 Aug 02, 2013 08:40 AM
Discussion A true open source TX call to arms skripo Radios 28 Jul 14, 2013 02:25 AM
Help! DIY Brushless motor gimbal, need help sourcing parts for gimbal hexa Multirotor Talk 13 Apr 13, 2013 03:08 PM
Discussion Open Source Electric car kit dll932 Life, The Universe, and Politics 0 Jan 21, 2013 09:09 PM
For Sale HackHD 1080p Open Source Camera Ecibob FPV Equipment (FS/W) 1 Jan 17, 2013 11:04 AM