HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old May 12, 2014, 06:51 PM
Registered User
Joined Aug 2013
16 Posts
Discussion
Connection lag/breaking on 9XR/ORRX 2.4GHz

Hey all!

I'm having problems with my 9XR with an OrangeRx 2.4GHz module and my Nano QX quadcopter.
It seems to lag too much, or to lose connection every few seconds, I don't know why. One moment it works just fine, another second it loses all control (channels bind to last received command) and stays like that for a second or so

It was all working just fine, for a few months. I have noticed the problem after opening up the module
Didn't touch anything really, just unscrewed the case and took the board out to check it out. I did unplug the coax for the antenna, but plugged it back in.
I have checked the board for visual defects, but could not find any. I'd say that all the connections are okay.

The 9XR works just fine in the simulator, so that's probably not the problem.
I still do not have any other receiver to test the module.

Don't know what to do. I'd appreciate any shared knowledge or suggestions!

Edit: Started working OK again, for no apparent reason. I did nothing! Black magic I suppose
Imbanon is offline Find More Posts by Imbanon
Last edited by Imbanon; May 18, 2014 at 05:28 AM.
Reply With Quote
Sign up now
to remove ads between posts
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Help! help with 7mm USB camera wiring and connection to 2.4ghz TX nanobot9000 FPV Talk 2 Apr 02, 2014 02:44 PM
Question Can i connect an external 2.4GHZ antenna to a module? Asmooh Radios 0 Feb 25, 2014 09:24 AM
NIB turnigy 9XR with FRsky telem and RX plus LONG RANGE 2 watt AMP 2.4ghz joegermano1 Non R/C Items (FS/W) 0 Mar 17, 2013 02:52 AM
Discussion Need Help on How to connect n operate 2.4Ghz 8 Channel R/C system dbpam073 Radios 6 Jan 05, 2011 06:58 AM