HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Dec 30, 2014, 05:50 PM
Registered User
Austria
Joined Jan 2004
8,257 Posts
Quote:
Originally Posted by johnnynunes View Post
I did that, but the response when rotating by hand is still the same... Maybe an error when compiling?
You can go into the output mixer function, and change the 'sign' of the servo signal ... anyhow you have something wrong in your configuration
e_lm_70 is online now Find More Posts by e_lm_70
Reply With Quote
Sign up now
to remove ads between posts
Old Dec 30, 2014, 06:07 PM
Registered User
United States, CA, Redondo Beach
Joined Jun 2008
19 Posts
Correcting Rudder on a Tricopter

Quote:
Originally Posted by johnnynunes View Post
I did that, but the response when rotating by hand is still the same... Maybe an error when compiling?
No, the direction of the yaw response from Multiwii can be set in the MultiWiiConf. There maybe other ways of doing this but this is what I use. This problem use to re-occur everytime I update/change the software until recent.
  1. Connect Multiwii/tricopter to computer
  2. Open MultiWiiConf.exe which is in the MultiWii 2.3 subdirectories
  3. From the GUI, connect to the Multiwii/tricopter
  4. Click on the Servo Tab
  5. In the Servo Tab, click on the Servo button, then click on the Go Live button
  6. Click on the Yaw button under Change Gyro/ACC Direction
  7. Click the Save button and test the yaw response on the tricopter
  8. If OK, click Export to File. Locate file, open it, copy the contents, and replace the servo section in Config.h.
This last step will prevent this problem from re-occuring when updating software. Note the steps are independent of your rudder stick on the Tx. Reverse the rudder stick direction if necessary.

I've attached a picture of the MultiwiiConf with Servo Tab activated.

U
Whirligig is online now Find More Posts by Whirligig
Last edited by Whirligig; Jan 01, 2015 at 01:14 PM. Reason: Clarified last step about the servo setting file.
Reply With Quote
Old Dec 31, 2014, 06:32 AM
Registered User
Joined May 2013
122 Posts
Quote:
Originally Posted by Whirligig View Post
No, the direction of the yaw response from Multiwii can be set in the MultiWiiConf. There maybe other ways of doing this but this is what I use. This problem use to re-occur everytime I update/change the software until recent.
  1. Connect Multiwii/tricopter to computer
  2. Open MultiWiiConf.exe which is in the MultiWii 2.3 subdirectories
  3. From the GUI, connect to the Multiwii/tricopter
  4. Click on the Servo Tab
  5. In the Servo Tab, click on the Servo button, then click on the Go Live button
  6. Click on the Yaw button under Change Gyro/ACC Direction
  7. Click the Save button and test the yaw response on the tricopter
  8. If OK, click Export to File. Copy the contents and replace the servo section in Config.h.
This last step will prevent this problem from re-occuring when updating software. Note the steps are independent of your rudder stick on the Tx. Reverse the rudder stick direction if necessary.

I've attached a picture of the MultiwiiConf with Servo Tab activated.
Perfect, finally flying, I chaged the conf h on yaw direction, didn't work, then did what you said e its perfect. Next fase is trimming...

Thanks a lot for the help.
johnnynunes is offline Find More Posts by johnnynunes
Reply With Quote
Old Jan 19, 2015, 08:57 AM
Flying, Flying, Crash....
steenwijk NL
Joined Jun 2008
63 Posts
AccZ tops to 255

Hi, I have this HK mega board with 2.4 FW.
It flies but while i am working on fine tuning i found that on the graphics the Acc Z line tops to max (255). When i move the quad the accZ line moves nice but never goes to 0. I recalibrated the ACC several times...

Did i set something wrong?

benno
plantjes is offline Find More Posts by plantjes
Reply With Quote
Old Jan 19, 2015, 09:25 AM
Registered User
Austria
Joined Jan 2004
8,257 Posts
Quote:
Originally Posted by plantjes View Post
Hi, I have this HK mega board with 2.4 FW.
It flies but while i am working on fine tuning i found that on the graphics the Acc Z line tops to max (255). When i move the quad the accZ line moves nice but never goes to 0. I recalibrated the ACC several times...

Did i set something wrong?

benno
AccZ by default is 512 or 256 ... base on the type of sensor .. on this mage board 255/256 is fine ... it is the 1G gravity ... if you are good on accelerate vertically you can read also more then 255
e_lm_70 is online now Find More Posts by e_lm_70
Reply With Quote
Old Jan 23, 2015, 08:15 PM
Flying, Flying, Crash....
steenwijk NL
Joined Jun 2008
63 Posts
Quote:
Originally Posted by e_lm_70 View Post
AccZ by default is 512 or 256 ... base on the type of sensor .. on this mage board 255/256 is fine ... it is the 1G gravity ... if you are good on accelerate vertically you can read also more then 255
Well excuse my dumbness but as i understand the AccZ can be 256 i would expect its close to the other ACC readouts when the quad is not moving (eg. 0).
My friend had this same board and his readout are all close to 0 when board is not moving.
plantjes is offline Find More Posts by plantjes
Reply With Quote
Old Jan 23, 2015, 09:02 PM
We Do It With FRQZ
RM_Sparks's Avatar
United States, CA, San Diego
Joined Aug 2009
2,164 Posts
Does anyone get a a weird drop from their barometer? When I enable mine my quad goes whacky. I have it covered with porous foam...
RM_Sparks is offline Find More Posts by RM_Sparks
Reply With Quote
Old Jan 23, 2015, 09:29 PM
No bounce, No play.
davidmc36's Avatar
Canada, ON, Ottawa
Joined Oct 2010
3,923 Posts
I actually find this barometer pretty decent. Some of the smaller MW boards are all over the place for me. It's not as good as APM but pretty decent.
davidmc36 is offline Find More Posts by davidmc36
Reply With Quote
Old Jan 23, 2015, 10:24 PM
Flying, Flying, Crash....
steenwijk NL
Joined Jun 2008
63 Posts
Well by accedent found the AccZ is like 255 normaly cause the earth gravity is pulling...

When model is inverted (upside down) de AccZ readout is -255...
Same with other sensors when rotated left or right...

More to test...

Benno
plantjes is offline Find More Posts by plantjes
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Hobbyking KK board VS MultiWii for a simple quad? carl1864 Multirotor Talk 7 Jan 03, 2014 02:47 PM
For Sale X250 MWC Quadcopter new MWC Mega with gps, diy kit terriwang Aircraft - Electric - Multirotor (FS/W) 32 Jan 02, 2013 04:17 PM
Discussion Crius NEO-6M Ublox GPS+Nano Mini Board+ Multiwii Control Board I2C GPS Kit godwisper Multirotor Electronics 5 Aug 25, 2012 05:03 AM
Sold Ardupilot mega with compass, GPS and Disto board!!!! tc3wins Aircraft - Electric - Multirotor (FS/W) 4 Jan 02, 2012 04:22 PM
Mini-HowTo Straight USB Connect to MTK 3329 GPS larry baraniuk UAV - Unmanned Aerial Vehicles 8 Apr 17, 2011 11:29 PM