HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old May 11, 2012, 04:28 AM
Registered User
Lapino's Avatar
Deutschland, NDS, Braunschweig
Joined Mar 2011
135 Posts
Quote:
Originally Posted by Goofy23 View Post
this 6050 works fine too
http://flyduino.net/MPU6050-Break-Out-onboard-33V-reg

The Arms are back in stock, mega is back next week.
Now CNC milled and powder coated.
Na da freue ich mich schon auf den neuen Mega
wie wäre es, wenn du noch 90° Stiftleisten mit einer Reihe (statt 3) anbieten würdest? ...oder habe ich die übersehen?

Beste Grüße
Lapino is online now Find More Posts by Lapino
Reply With Quote
Sign up now
to remove ads between posts
Old May 12, 2012, 04:58 AM
OS Sponsor
kinderkram's Avatar
Germany, NRW, Dusseldorf
Joined Jun 2010
5,186 Posts
Quote:
Originally Posted by Goofy23 View Post
this 6050 works fine too
http://flyduino.net/MPU6050-Break-Out-onboard-33V-reg

The Arms are back in stock, mega is back next week.
Now CNC milled and powder coated.
I see all frame parts back in stock:
http://flyduino.net/Sets_1

Will you offer complete frame sets based on the Cheese Plate soon? I mean with all bells&whistles for quads - octos...
kinderkram is offline Find More Posts by kinderkram
RCG Plus Member
Reply With Quote
Old May 13, 2012, 12:05 PM
Registered User
The Netherlands, NH, Amsterdam
Joined Mar 2008
135 Posts
EDIT:
!! If you sourced the FMP04 from Paul/Flyduino, DO NOT update the software if you got that module from him after 12th of July 2012 !!

Hi guys,

After spending a frustrating (with amazing F1 in background) afternoon getting GPS to work and updated, I thought it might be handy for anyone that I'd write up a little how-to.
I'm working with FMP04 on Paul's (Flyduino.com) GPSBOB v1.1 and a Sparkfun FTDI Basic (5V)

1. Solder everything up, I started with JST-XT connector soldered directly to the GPSBOB connectors, but switched to regular connectors for software update.
2. Connect wires (I just used one servo-extension cable + jumper cable for GND) to FTDI. Just GND to GND, 5V of GPSBOB to 5V of FTDI (although my Sparkfun FTDI says 3V3, it seems to be a silkscreen error).
!! RX from GPSBOB -> RX from FTDI (same for TX->TX) !!
3a. Get firmware + updater from here: http://flyduino.net/documents/FMP04.zip (10Hz, WaaS, 115200Baud version)
4. Unpack files from archive + unpack the firmware tool
5. Start FlashTools.exe
6. In Options menu, select corresponding COM-port and speed (9600, 38400, 115200 or Autodetect)
7. Select DA: 3329 and click Download Agent.
8. Select the corresponding file (MTK_AllInOne_DA_MT3329_v4.02.bin in the FlashTool folder)
9. Click ROM and select the file you've downloaded above (FMP04_Camled_010327_A1.5E_20110118_10Hz_115200.bi n)
10. Click Download
11. Watch firmware being cleared (RED) and uploaded (BLUE) and get the (GREEN) circle confirming upload

If you somehow encounter a (RED) cross with an error, please confirm you've selected the right Download Agent and have actually(!) selected the ROM properly.
No need to use the USB_Loader also provided.

For additional options, you might also use the MTK uploader our ArduPilot (and/or DIY Drones) friends refer to: http://code.google.com/p/ardupilot/d...s.zip&can=2&q=.

Hope this helps anyone!

Cheers,


Ruben

EDIT: Forgot to update this post, after already updating some in MultiWii forums!
shufflez is offline Find More Posts by shufflez
Last edited by shufflez; Oct 13, 2012 at 11:01 AM.
Reply With Quote
Old May 13, 2012, 12:33 PM
Registered User
The Netherlands, NH, Amsterdam
Joined Mar 2008
135 Posts
Hi all,

I can't figure out orientation of the FIX-LED supplied with GPSBOB v1.1. I've now soldered it with Anode towards the resistor. Is that correct?

Because it still seems I can't get GPS fix, neither via LED or in software (even after all my struggles with soft/firmware ). Unit is placed by nearby window, where phones get cold-fix within minutes.

BTW, is fix depending on MWC, or will FMP04 get fix even if only powered on?
If so I'll leave it laying outside for a while to get GPS
shufflez is offline Find More Posts by shufflez
Reply With Quote
Old May 13, 2012, 06:38 PM
Registered User
Goofy23's Avatar
Hamburg, Germany
Joined Jan 2011
1,075 Posts
thanks!
have to say, the modules we got are not supporting the fixled like described in the datashhet, sry.
The new batch which is in stock have allready the 115200 baud firmware on it.
But status led of multiwii shows the fix.

Good point Kinderkram.
Goofy23 is offline Find More Posts by Goofy23
Reply With Quote
Old May 14, 2012, 06:29 AM
Registered User
Quadframes's Avatar
Joined Jun 2011
739 Posts
Quote:
Originally Posted by Goofy23 View Post
thanks!
have to say, the modules we got are not supporting the fixled like described in the datashhet, sry.
The new batch which is in stock have allready the 115200 baud firmware on it.
But status led of multiwii shows the fix.

Good point Kinderkram.
Hi Paul check your PM's m8
Quadframes is offline Find More Posts by Quadframes
Reply With Quote
Old May 17, 2012, 12:04 AM
Axel N.
axelnied's Avatar
United States, CA, San Diego
Joined Feb 2011
83 Posts
GPS v1.1 - orientation GPS fix (white LED)

Paul,

Today I received the GPS BOB v1.1 - thanks so much, looks nice...
As I am going through the parts, I figured the green LED would go into "LED" position, short leg on "-" as printed on the BOB.

But how about the white LED = fix? There are no marking on BOB on how to position the white LED (long/short = neg/pos)... I could not find a drawing or image. Could you plz post?

Axel
axelnied is offline Find More Posts by axelnied
Reply With Quote
Old May 17, 2012, 06:24 AM
Registered User
The Netherlands, NH, Amsterdam
Joined Mar 2008
135 Posts
Hi Axel,

Please read Paul's post 2 posts up
Currently FIX led is not supported, I fried an LED desoldering before I got to know that Orientation I think should be Anode (+) towards the resistor, Cathode (-) facing the resistor for the other LED (perpendicular).
shufflez is offline Find More Posts by shufflez
Reply With Quote
Old May 18, 2012, 02:58 PM
Registered User
Goofy23's Avatar
Hamburg, Germany
Joined Jan 2011
1,075 Posts
yes the datasheet got me, its simply no function on the pin stated in the datasheet, there is a pad underneath the module which is not on the pinrow, this can be used, may can post a pic later.
Btw. megas are back in stock.
Goofy23 is offline Find More Posts by Goofy23
Reply With Quote
Old May 18, 2012, 03:41 PM
Registered User
Goofy23's Avatar
Hamburg, Germany
Joined Jan 2011
1,075 Posts
http://imgur.com/TVh5G
http://imgur.com/MCTmS/

Some links to pics who showes the pad, no R is needed, its allready onboard.
Goofy23 is offline Find More Posts by Goofy23
Reply With Quote
Old May 19, 2012, 10:30 PM
Axel N.
axelnied's Avatar
United States, CA, San Diego
Joined Feb 2011
83 Posts
Quote:
Originally Posted by Goofy23 View Post
http://imgur.com/TVh5G
http://imgur.com/MCTmS/

Some links to pics who showes the pad, no R is needed, its allready onboard.
Thanks Paul, EXACTLY what I was looking for, easy fix (for the fix )
axelnied is offline Find More Posts by axelnied
Reply With Quote
Old May 20, 2012, 09:40 AM
Registered User
FERCYR37's Avatar
France, Centre, Saché
Joined Jan 2011
55 Posts
Hi,
Is the Flyduino ATMega1280 can be used much longer? I saw that there is now 2.5.1 MegapiratenNG Light3 version for this board, does not it? When should I upgrade to ATMega 2560?
FERCYR37 is offline Find More Posts by FERCYR37
Reply With Quote
Old May 21, 2012, 04:27 PM
Registered User
Joined Apr 2012
14 Posts
Trouble uploading megapirate ng 2.5.1 R3

Hi all

I have been following this thread and pulling a lot of useful info in building my soon-to-be-completed quad. However now all of a sudden, I came across an unsolvable mystery

Here goes: I try to upload megapirate ng 2.5.1 R3 to my flyduino mega board using the usb uart connector also from paul's store. I am on Windows 7, arduino 1.0 (and I also tried arduino 1.o relax patch). It will verify without errors, but hangs very late in the process of uploading. The led next to the ftdi pins flashes like when you upload firmware usually (I had mpng 2.0.49 and multiwii 2.0 on it) but then stops after just about 2 seconds. I read that "!!!" in the code can be a problem, searched for it and found it in one file of the megapirate sketch and in one of the libraries, and replaced it.

Output in the arduino console is as follows:

Code:
avrdude: Recv: B [42] 
avrdude: Recv: o [6f] 
avrdude: Recv: o [6f] 
avrdude: Recv: t [74] 
avrdude: Recv: l [6c] 
avrdude: Recv: o [6f] 
avrdude: Recv: a [61] 
avrdude: Recv: d [64] 
avrdude: Recv: e [65] 
avrdude: Recv: r [72] 
avrdude: Recv: > [3e] 
avrdude: Recv: $ [24] 
avrdude: Recv:   [20] 
avrdude: Recv: H [48] 
avrdude: Recv: u [75] 
avrdude: Recv: h [68] 
avrdude: Recv: ? [3f] 
avrdude: Recv: . [0d] 
avrdude: Recv: . [0a]
and this keeps on going and going and going and... you get the point.

Can anyone make sense out of this? Thank you guys for any pointers.

Cheers, Florian
florihan is offline Find More Posts by florihan
Reply With Quote
Old May 23, 2012, 06:36 AM
location: Almeria Spain
melilla's Avatar
Joined Feb 2011
25 Posts
problem with mega flyduino

Hi I have a mega flyduino v2, with FreeImu 4.3, gps FM4.
When I connect the battery sometimes the esc are ringing at intervals of one second, and the motors are not activated
multiwii_dev_20120504 (1 min 6 sec)
melilla is offline Find More Posts by melilla
Reply With Quote
Old May 23, 2012, 06:54 AM
OS Sponsor
kinderkram's Avatar
Germany, NRW, Dusseldorf
Joined Jun 2010
5,186 Posts
Quote:
Originally Posted by melilla View Post
Hi I have a mega flyduino v2, with FreeImu 4.3, gps FM4.
When I connect the battery sometimes the esc are ringing at intervals of one second, and the motors are not activated
http://youtu.be/8OlnMbSPX_A
Sounds like the ESCs aren't calibrated properly. Try to calibrate them one-by-one and set the endpoints of yaw/throttle on your transmitter.

btw: which firmware are you using?
kinderkram is offline Find More Posts by kinderkram
RCG Plus Member
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
New Product Please let me introduce myself jimaquo Dock Talk 7 Oct 27, 2010 02:27 AM
Let me introduce the DEMON!!!! (Transparent covering and eliptical wing!!!) modest-master Sport Planes 7 Aug 25, 2002 11:46 PM
Let me introduce Angelis 280/400, Benjamin, Zombi (ARFs) modest-master Parkflyers 17 Mar 14, 2002 01:20 PM
Let me introduce the "NIKE" modest-master Electric Sailplanes 3 Mar 07, 2002 05:20 AM