HobbyKing.com New Products Flash Sale
Reply
Thread Tools
Old Oct 25, 2014, 11:52 PM
Registered User
Oakridge, Oregon
Joined Jul 2004
670 Posts
Question
Did I fry my Run Cam on 4s?

I installed my runcam with 4s and I no longer receive video. I should have known better, but got excited and built to fast before checking. Is there a fix that could be done (ie a piece to replace) or should I just toss it???
TheDonski is offline Find More Posts by TheDonski
Reply With Quote
Sign up now
to remove ads between posts
Old Oct 26, 2014, 06:19 AM
A man with too many toys
United States
Joined Feb 2001
17,945 Posts
4s fully charged is 16.8 so that’s way over the limit for most FPV equipment. There are plenty of 12v BEC’s available or you can easily make your own.

Does runcam have a repair service? It’s probably a simple repair for someone with the right equipment.

.
RC Man is online now Find More Posts by RC Man
Reply With Quote
Old Oct 26, 2014, 11:26 AM
Registered User
Oakridge, Oregon
Joined Jul 2004
670 Posts
I have a RMRC 12v bec with a new runcam currently installed. I will check to see if they have a repair service. I just wanted to see if there was something I could change out to save a few bucks...
TheDonski is offline Find More Posts by TheDonski
Reply With Quote
Reply


Thread Tools

Similar Threads
Category Thread Thread Starter Forum Replies Last Post
Discussion Did I just fry my OrangeRx module? H2SO4 Radios 7 Sep 07, 2014 02:34 AM
Discussion Did I fry my ESC? Bob6831 Beginner Training Area (Aircraft-Electric) 14 Feb 03, 2014 05:22 PM
Discussion Did I fry my batteries ?? biglar Electric Heli Talk 9 Dec 05, 2013 08:31 PM
Discussion did i fry something in my 4-in-1 on my BCX? heligrom Coaxial Helicopters 4 Feb 13, 2006 10:43 AM
did I fry my cc35 on my new corona? aschen Electric Heli Talk 4 Jan 07, 2004 10:37 PM